aci_tenant_ep_retention_policy – Управление политиками удержания конечных точек (EP) протоколов (fv:EpRetPol)
Новое в версии 2.4.
Обзор
- Управление политиками удержания протоколов конечных точек (EP) на Cisco ACI fabric.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| bounce_age целое число | Интервал старения записей переброса в секундах. Допустимые значения находятся в диапазоне между 150 и 65535; 0 используется для бесконечного значения.APIC по умолчанию использует 630 при создании, если параметр не указан. | |
| bounce_trigger - |
| Определяет, устанавливаются ли записи переброса протоколом RARP Flood или COOP. APIC по умолчанию использует coop при создании, если параметр не указан. |
| certificate_name - | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию используется имя private_key без расширения.Псевдонимы: cert_name | |
| description - | Описание политики удержания конечной точки. Псевдонимы: descr | |
| epr_policy - | Имя политики удержания конечной точки. Псевдонимы: epr_name, name | |
| hold_interval целое число | Интервал удержания в секундах. Допустимые значения находятся в диапазоне от 5 до 65535. APIC по умолчанию использует 300 при создании, если параметр не указан. | |
| host - / обязательно | IP-адрес или имя хоста APIC, разрешаемый управляющим хостом Ansible. Псевдонимы: hostname | |
| local_ep_interval целое число | Интервал старения локальной конечной точки в секундах. Допустимые значения находятся в диапазоне от 120 до 65535; 0 используется для бесконечного значения.APIC по умолчанию использует 900 при создании, если параметр не указан. | |
| move_frequency целое число | Частота перемещения в секунду. Допустимые значения находятся в диапазоне от 0 до 65535; 0 используется для отсутствия перемещений.APIC по умолчанию использует 256 при создании, если параметр не указан. | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информационный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также указан private_key, он будет использован. | |
| port - | Номер порта для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи. Имя ключа (без расширения) используется как имя сертификата в ACI, если не указано certificate_name. Этот параметр взаимоисключающий с password. Если также указан password, он будет проигнорирован.Псевдонимы: cert_key | |
| remote_ep_interval целое число | Интервал старения удаленной конечной точки в секундах. Допустимые значения находятся в диапазоне от 120 до 65535; 0 используется для бесконечного значения.APIC по умолчанию использует 300 при создании, если параметр не указан. | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| tenant - | Имя существующего Tenant. Псевдонимы: tenant_name | |
| timeout целое число | По умолчанию: 30 | Таймаут сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS соединения будет использоваться HTTP соединение. |
| username - | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при использовании на контролируемых вами сайтах с самоподписанными сертификатами. |
Примечания
Примечание
- Tenant
tenantдолжен существовать перед использованием этого модуля в вашем playbook. Для этого можно использовать модуль aci_tenant. - Дополнительная информация об внутреннем классе APIC fv:EpRetPol из справочника по модели управления информацией APIC.
См. также
См. также
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей ACI инфраструктурой с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new EPR policy
aci_epr_policy:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
epr_policy: EPRPol1
bounce_age: 630
hold_interval: 300
local_ep_interval: 900
remote_ep_interval: 300
move_frequency: 256
description: test
state: present
delegate_to: localhost
- name: Remove an EPR policy
aci_epr_policy:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
epr_policy: EPRPol1
state: absent
delegate_to: localhost
- name: Query an EPR policy
aci_epr_policy:
host: apic
username: admin
password: SomeSecretPassword
tenant: production
epr_policy: EPRPol1
state: query
delegate_to: localhost
register: query_result
- name: Query all EPR policies
aci_epr_policy:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие значения, возвращаемые модулем, описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращённое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сформированная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный результат, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-код состояния от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратной совместимости. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Swetha Chunduri (@schunduri)
Подсказка
Если вы заметите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_tenant_ep_retention_policy_module.html