aci_vlan_pool_encap_block – Управление блоками encap, назначенными пулам VLAN (fvns:EncapBlk)
Новое в версии 2.5.
Синопсис
- Управление блоками VLAN encap, назначенными пулам VLAN на устройствах Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| allocation_mode - |
| Метод, используемый для распределения encap ресурсам. псевдонимы: mode |
| block_end integer | Конец блока encap. псевдонимы: end | |
| block_name - | Имя, которое нужно присвоить блоку encap. псевдонимы: name | |
| block_start integer | Начало блока encap. псевдонимы: start | |
| certificate_name - | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию private_key basename без расширения.псевдонимы: cert_name | |
| description - | Описание блока encap для пула. псевдонимы: descr | |
| host - / обязательно | IP-адрес или имя хоста APIC, разрешаемого хостом управления Ansible. псевдонимы: hostname | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, вкл. current словарьinfo добавляет информационный вывод, вкл. previous, proposed и sent словариdebug добавляет отладочный вывод, вкл. filter_string, method, response, status и url информацию |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если private_key также указан, он будет использован вместо него. | |
| pool - | Имя пула, которому должен быть назначен блок encap. псевдонимы: pool_name | |
| pool_allocation_mode - |
| Метод, используемый для распределения encap ресурсам. псевдонимы: pool_mode |
| port - | Номер порта для использования в соединении REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ, используемый для аутентификации на основе подписи. Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name. Этот параметр взаимоисключающий с password. Если password также указан, он будет проигнорирован.псевдонимы: cert_key | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для получения списка объекта или нескольких объектов. |
| timeout integer | Значение по умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy boolean |
| Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl boolean |
| Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения. |
| username - | Значение по умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs boolean |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при работе с лично контролируемыми сайтами, использующими самозаверенные сертификаты. |
Примечания
Примечание
poolдолжен существовать для добавления или удаления блока encap.- Дополнительная информация о внутреннем классе APIC fvns:EncapBlk из справочника по модели информации управления APIC.
См. также
См. также
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для участия.
Примеры
- name: Add a new VLAN encap block
aci_vlan_pool_encap_block:
host: apic
username: admin
password: SomeSecretPassword
pool: production
block_start: 20
block_end: 50
state: present
delegate_to: localhost
- name: Remove a VLAN encap block
aci_vlan_pool_encap_block:
host: apic
username: admin
password: SomeSecretPassword
pool: production
block_start: 20
block_end: 50
state: absent
delegate_to: localhost
- name: Query a VLAN encap block
aci_vlan_pool_encap_block:
host: apic
username: admin
password: SomeSecretPassword
pool: production
block_start: 20
block_end: 50
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for encap blocks
aci_vlan_pool_encap_block:
host: apic
username: admin
password: SomeSecretPassword
pool: production
state: query
delegate_to: localhost
register: query_result
- name: Query all VLAN encap blocks
aci_vlan_pool_encap_block:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата документированы здесь, следующие являются полями, уникальными для данного модуля:
| Ключ | Возвращённое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая с APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, использованная для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, использованный для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собранная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ с APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус с APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, использованный для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Jacob McGill (@jmcgill298)
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружите какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_vlan_pool_encap_block_module.html