openstack – Источник инвентаризации OpenStack
Обзор
- Получение узлов инвентаризации из облаков OpenStack
- Использует конфигурационный файл YAML openstack.(yml|yaml) для настройки плагина инвентаризации
- Использует стандартный конфигурационный файл YAML clouds.yaml для настройки учетных данных облака
Требования
Ниже перечислены требования, необходимые на локальном узле-мастере, который выполняет эту инвентаризацию.
- openstacksdk
Параметры
| Параметр | Варианты/Значения по умолчанию | Конфигурация | Комментарии |
|---|---|---|---|
| cache boolean | Значение по умолчанию: "нет" | записи ini: [inventory] переменная среды:ANSIBLE_INVENTORY_CACHE | Включение/отключение кэширования данных источника инвентаризации; для работы требуется настройка плагина кэширования. |
| cache_connection - | записи ini: [inventory] переменная среды:ANSIBLE_INVENTORY_CACHE_CONNECTION | Данные или путь к подключению кэша; см. документацию плагина кэша для получения подробностей. | |
| cache_plugin - | записи ini: [inventory] переменная среды:ANSIBLE_INVENTORY_CACHE_PLUGIN | Плагин кэширования для использования данных источника инвентаризации. | |
| cache_timeout целое число | Значение по умолчанию: 3600 | записи ini: [inventory] переменная среды:ANSIBLE_INVENTORY_CACHE_TIMEOUT | Срок хранения кэша в секундах |
| clouds_yaml_path строка | Переопределяет путь к файлу clouds.yaml. Если это значение задано, оно будет проверяться в первую очередь. По умолчанию файл инвентаризации Ansible добавляет /etc/ansible/openstack.yaml и /etc/ansible/openstack.yml к стандартным путям, описанным в https://docs.openstack.org/os-client-config/latest/user/configuration.html#config-files | ||
| compose словарь | Значение по умолчанию: {} | Создать переменные из выражений Jinja2. | |
| expand_hostvars boolean |
| Выполнить дополнительные команды на каждом узле, чтобы получить дополнительную информацию об узле. Может запрашивать данные cinder и neutron и может быть ресурсоемким для пользователей с большим количеством узлов. (Обратите внимание, что значение по умолчанию отличается от значения по умолчанию для параметра expand_hostvars в старом скрипте инвентаризации openstack.py) | |
| fail_on_errors boolean |
| Приводит к сбою инвентаризации и отсутствию узлов, если одно облако завершилось ошибкой (например, плохие учетные данные или недоступность). При значении False инвентаризация вернёт столько узлов, сколько сможет получить от доступных облаков. (Обратите внимание, что значение по умолчанию отличается от значения по умолчанию для параметра fail_on_errors в старом скрипте инвентаризации openstack.py) | |
| groups словарь | Значение по умолчанию: {} | Добавить узлы в группу на основе условных выражений Jinja2. | |
| inventory_hostname строка |
| Что зарегистрировать как имя узла инвентаризации. Если установлено значение 'uuid', будет использоваться uuid сервера, и будет создана группа для имени сервера. Если установлено значение 'name', будет использовано имя сервера, за исключением случаев, когда в инвентаризации присутствует более одного сервера с одинаковым именем, в этом случае будет использоваться логика 'uuid'. По умолчанию используется 'name', что отличается от значения по умолчанию параметра use_hostnames в старом скрипте инвентаризации openstack.py | |
| keyed_groups список | Значение по умолчанию: [] | добавление узлов в группу на основе значений переменной | |
| only_clouds список | Значение по умолчанию: [] | Список облаков из clouds.yaml, которые использовать, вместо использования всего списка. | |
| plugin - / обязательно |
| токен, который гарантирует, что это файл источника для плагина 'openstack'. | |
| private boolean |
| Использовать частный интерфейс каждого сервера, если он есть, как IP-адрес узла в инвентаризации. Это может быть полезно, если вы запускаете Ansible внутри сервера в облаке и хотите взаимодействовать с вашими серверами через частную сеть. | |
| show_all boolean |
| переключает отображение всех виртуальных машин по сравнению с отображением только тех, у которых есть рабочий IP-адрес | |
| strict boolean | Значение по умолчанию: "нет" | Если true, некорректные записи приводят к ошибке, иначе пропуск и продолжение. Так как в выражениях можно использовать факты, они могут не всегда быть доступны, и такие ошибки игнорируются по умолчанию. |
Примеры
# file must be named openstack.yaml or openstack.yml # Make the plugin behave like the default behavior of the old script plugin: openstack expand_hostvars: yes fail_on_errors: yes
Статус
Авторы
- Marco Vito Moscaritolo <marco@agavee.com>
- Jesse Keating <jesse.keating@rackspace.com>
Подсказка
Если вы заметите какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/plugins/inventory/openstack.html