Spec-Zone.ru › Ansible 2.8

aci_ap – Управление объектами профилей приложений верхнего уровня (AP) (fv:Ap)

Новая версия 2.4.

  • Краткое описание
  • Параметры
  • Примечания
  • См. также
  • Примеры
  • Возвращаемые значения
  • Статус

Краткое описание

  • Управление объектами профилей приложений (AP) верхнего уровня на Cisco ACI-матрицах

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
ap
строка / обязательно
Имя профиля сетевой приложений.

псевдонимы: app_profile, app_profile_name, name
certificate_name
строка
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
Если было предоставлено имя файла private_key, по умолчанию используется private_key имя файла без расширения.
Если для private_key был предоставлен контент в формате PEM, по умолчанию используется значение username.

псевдонимы: cert_name
description
строка
Описание для AP.

псевдонимы: descr
host
строка / обязательно
IP-адрес или имя хоста APIC, разрешаемый хостом управления Ansible.

псевдонимы: hostname
output_level
строка
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого ACI-модуля.
normal означает стандартный вывод, включая current словарь.
info добавляет информативный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
строка / обязательно
Пароль для аутентификации.
Этот параметр исключает private_key. Если также указан private_key, будет использован он.
port
целое число
Порт, используемый для подключения REST.
Значение по умолчанию зависит от параметра use_ssl.
private_key
строка / обязательно
Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемое для аутентификации на основе подписи.
Это значение также влияет на значение по умолчанию certificate_name, которое используется.
Этот параметр исключает password. Если также указан password, он будет проигнорирован.

псевдонимы: cert_key
state
строка
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для вывода информации об объекте или нескольких объектах.
tenant
строка / обязательно
Имя существующего арендатора.

псевдонимы: tenant_name
timeout
целое число
По умолчанию:
30
Таймаут на уровне сокета в секундах.
use_proxy
булево
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определен в переменной окружения на целевых хостах.
use_ssl
булево
    Варианты:
  • no
  • yes ←
Если no, вместо стандартного HTTPS-соединения будет использовано HTTP-соединение.
username
строка
По умолчанию:
"admin"
Имя пользователя для аутентификации.

псевдонимы: user
validate_certs
булево
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это значение следует установить на no только при работе с собственными сертификатами на контролируемых сайтах.

Примечания

Примечание

  • Этот модуль не управляет EPG, см. aci_epg, чтобы сделать это.
  • Используемый tenant должен существовать до использования этого модуля в вашем плане. Для этого можно использовать модуль aci_tenant.

См. также

См. также

aci_tenant – Управление арендаторами (fv:Tenant)
Официальная документация по модулю aci_tenant.
APIC Management Information Model reference
Дополнительная информация о внутреннем классе APIC fv:Ap.
Руководство по Cisco ACI
Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Разработка модулей Cisco ACI
Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.

Примеры

- name: Add a new AP
  aci_ap:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: production
    ap: default
    description: default ap
    state: present
  delegate_to: localhost

- name: Remove an AP
  aci_ap:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: production
    ap: default
    state: absent
  delegate_to: localhost

- name: Query an AP
  aci_ap:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: production
    ap: default
    state: query
  delegate_to: localhost
  register: query_result

- name: Query all APs
  aci_ap:
    host: apic
    username: admin
    password: SomeSecretPassword
    state: query
  delegate_to: localhost
  register: query_result

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:

Ключ Возвращаемое значение Описание
current
список
успех
Текущая конфигурация с APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращенная APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
HTTP-метод, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация с APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Скомпонованная конфигурация из предоставленных пользователем параметров

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращенный APIC REST API (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-код состояния с APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-URL, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

  • Данный модуль не гарантирует обратной совместимости. [превью]
  • Этот модуль поддерживается партнером Ansible. [сертифицировано]

Авторы

  • Swetha Chunduri (@schunduri)

Подсказка

Если вы обнаружите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.8/modules/aci_ap_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API