aci_domain_to_encap_pool – Привязка домена к пулам Encap (infra:RsVlanNs)
Новое в версии 2.5.
Описание
- Привязка домена к пулам Encap на устройствах Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если было предоставлено имя файла private_key, по умолчанию используется private_key без расширения.Если для private_key был предоставлен PEM-формат, по умолчанию используется значение username. псевдонимы: cert_name | |
| domain строка | Имя домена, ассоциируемого с пулом Encap. псевдонимы: domain_name, domain_profile | |
| domain_type строка |
| Определяет, является ли домен физическим (phys) или виртуальным (vmm). |
| host строка / обязательно | IP-адрес или имя хоста APIC, разрешимые управляющим хостом Ansible. псевдонимы: hostname | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, вкл. current dictinfo добавляет информационный вывод, вкл. previous, proposed и sent dictsdebug добавляет отладочный вывод, вкл. filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если предоставлен также private_key, будет использован он. | |
| pool строка | Имя пула. псевдонимы: pool_name | |
| pool_allocation_mode строка |
| Метод, используемый для распределения encaps к ресурсам. Только vlan и vsan поддерживают режимы распределения. псевдонимы: allocation_mode, mode |
| pool_type строка / обязательно |
| Тип encaps pool. |
| port целое число | Номер порта для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name.Этот параметр взаимоисключающий с password. Если предоставлен также password, он будет проигнорирован.псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут на уровне сокета в секундах. |
| use_proxy логическое |
| Если no, не будет использоваться прокси, даже если он определён в переменной среды целевых хостов. |
| use_ssl логическое |
| Если no, будет использоваться HTTP-соединение вместо стандартного HTTPS-соединения. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует установить в no только при работе с контролируемыми сайтами с самоподписанными сертификатами. |
| vm_provider строка |
| Платформа VM для домена VMM. Поддержка Kubernetes была добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1. |
Примечания
Примечание
- Параметры
domainиencap_poolдолжны существовать перед использованием этого модуля. Для этого можно использовать модули aci_domain и aci_encap_pool.
См. также
См. также
- aci_domain – Управление физическими, виртуальными, мостовыми, маршрутизируемыми или FC доменными профилями (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
- Официальная документация модуля aci_domain.
- aci_encap_pool – Управление пулами encap (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
- Официальная документация модуля aci_encap_pool.
- Ссылка на модель информации управления APIC
- Дополнительная информация об внутренней APIC-классе infra:RsVlanNs.
- Руководство по Cisco ACI
- Подробная информация о управлении инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add domain to VLAN pool binding
aci_domain_to_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: test_pool
pool_type: vlan
pool_allocation_mode: dynamic
state: present
delegate_to: localhost
- name: Remove domain to VLAN pool binding
aci_domain_to_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: test_pool
pool_type: vlan
pool_allocation_mode: dynamic
state: absent
delegate_to: localhost
- name: Query our domain to VLAN pool binding
aci_domain_to_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
pool: test_pool
pool_type: vlan
pool_allocation_mode: dynamic
state: query
delegate_to: localhost
register: query_result
- name: Query all domain to VLAN pool bindings
aci_domain_to_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
domain_type: phys
pool_type: vlan
pool_allocation_mode: dynamic
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращено | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Метод HTTP, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный результат, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнёром Ansible. [сертифицировано]
Авторы
- Dag Wieers (@dagwieers)
Подсказка
Если вы заметите какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.8/modules/aci_domain_to_encap_pool_module.html