aci_encap_pool_range – Управление диапазонами encap, назначенными пулам (fvns:EncapBlk, fvns:VsanEncapBlk)
Новое в версии 2.5.
Обзор
- Управление диапазонами vlan, vxlan и vsan, назначенными пулам на Cisco ACI фабриках.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| allocation_mode строка |
| Метод, используемый для выделения encaps для ресурсов. Только vlan и vsan поддерживают режимы выделения. псевдонимы: режим |
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если был предоставлен private_key файл, по умолчанию используется private_key имя файла без расширения.Если для private_key был предоставлен контент в формате PEM, по умолчанию используется значение username. псевдонимы: имя_сертификата | |
| description строка | Описание диапазона пула. псевдонимы: описание | |
| host строка / обязательно | IP-адрес или имя хоста, разрешаемые хостом управления Ansible. псевдонимы: имя_хоста | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарь.info добавляет информационный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимно исключает private_key. Если также указан private_key, будет использован он. | |
| pool строка | Имя пула, которому должен быть назначен диапазон. псевдонимы: имя_пула | |
| pool_allocation_mode строка |
| Метод, используемый для выделения encaps для ресурсов. Только vlan и vsan поддерживают режимы выделения. псевдонимы: режим_пула |
| pool_type строка / обязательно |
| Тип encaps для pool.псевдонимы: тип |
| port целое число | Номер порта для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name.Этот параметр взаимно исключает password. Если указан password, он будет проигнорирован.псевдонимы: ключ_сертификата | |
| range_end целое число | Конец диапазона encaps. псевдонимы: конец | |
| range_name строка | Имя, которое нужно дать диапазону encaps. псевдонимы: имя, диапазон | |
| range_start целое число | Начало диапазона encaps. псевдонимы: начало | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое значение |
| Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl логическое значение |
| Если no, вместо стандартного HTTPS-соединения будет использовано HTTP-соединение. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: пользователь |
| validate_certs логическое значение |
| Если no, сертификаты SSL не будут проверяться.Это должно быть установлено в no только при работе с сайтами под собственным контролем с самозаверяющимися сертификатами. |
Примечания
Примечание
- Для добавления или удаления диапазона
poolдолжен существовать.
См. также
См. также
- aci_encap_pool – Управление пулами encap (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
- Официальная документация по модулю aci_encap_pool.
- aci_vlan_pool_encap_block – Управление блоками encaps, назначенными пулам VLAN (fvns:EncapBlk)
- Официальная документация по модулю aci_vlan_pool_encap_block.
- Справочник по модели управления информацией APIC
- Дополнительная информация о внутренних классах APIC fvns:EncapBlk и fvns:VsanEncapBlk.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new VLAN pool range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 40
allocation_mode: inherit
state: present
delegate_to: localhost
- name: Remove a VLAN pool range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 40
state: absent
delegate_to: localhost
- name: Query a VLAN range
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
pool_allocation_mode: static
range_name: anstest
range_start: 20
range_end: 50
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_name
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_name: anstest
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_start
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_start: 20
state: query
delegate_to: localhost
register: query_result
- name: Query a VLAN pool for ranges by range_start and range_end
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
range_start: 20
range_end: 40
state: query
delegate_to: localhost
register: query_result
- name: Query all VLAN pool ranges
aci_encap_pool_range:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата описаны здесь, следующие поля уникальны для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая из APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицированный]
Авторы
- Jacob McGill (@jmcgill298)
Подсказка
Если вы обнаружите какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.8/modules/aci_encap_pool_range_module.html