aci_vlan_pool – Управление пулами VLAN (fvns:VlanInstP)
Новая версия с 2.5.
Обзор
- Управление пулами VLAN на тканях Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикреплённого к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если предоставлено имя файла private_key, значение по умолчанию — имя файла private_key без расширения.Если для private_key предоставлено содержимое в формате PEM, значение по умолчанию — значение username. псевдонимы: cert_name | |
| description строка | Описание для pool.псевдонимы: descr | |
| host строка / обязательно | IP-адрес или имя хоста APIC, разрешимый для хоста управления Ansible. псевдонимы: имя_хоста | |
| output_level строка |
| Влияние на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информативный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр является взаимоисключающим с private_key. Если предоставлен также private_key, он будет использован вместо него. | |
| pool строка | Имя пула. псевдонимы: имя, имя_пула | |
| pool_allocation_mode строка |
| Метод, используемый для выделения VLAN ресурсам. псевдонимы: метод_выделения, режим |
| port целое число | Номер порта, используемый для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если предоставлен также password, он будет проигнорирован.псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для отображения объекта или нескольких объектов. |
| timeout целое число | Значение по умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использован, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS подключения будет использовано HTTP подключение. |
| username строка | Значение по умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: пользователь |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это должно быть установлено в no только при использовании на управляемых сайтах с самозаверенными сертификатами. |
См. также
См. также
- aci_encap_pool – Управление пулами encap (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
- Официальная документация по модулю aci_encap_pool.
- aci_vlan_pool_encap_block – Управление блоками encap, назначенными пулам VLAN (fvns:EncapBlk)
- Официальная документация по модулю aci_vlan_pool_encap_block.
- Справочник по модели информации управления APIC
- Дополнительная информация о внутреннем классе APIC fvns:VlanInstP.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
description: Production VLANs
state: present
delegate_to: localhost
- name: Remove a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: absent
delegate_to: localhost
- name: Query a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: query
delegate_to: localhost
register: query_result
- name: Query all VLAN pools
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная APIC Пример: {'code': '122', 'text': 'неизвестный тип управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из параметров, предоставленных пользователем Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный тип управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратной совместимости. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Jacob McGill (@jmcgill298)
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружите какие-либо проблемы в этой документации, вы можете изменить этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.8/modules/aci_vlan_pool_module.html