aci_epg_to_domain – Привязка EPG к доменам (fv:RsDomAtt)
Новое в версии 2.4.
Описание
- Привязка EPG к физическим и виртуальным доменам на платформах Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| allow_useg строка |
| Разрешает микросегментацию. APIC по умолчанию устанавливает encap при отсутствии значения при создании. |
| ap строка | Имя существующего профиля сетевого приложения, который будет содержать EPG. псевдонимы: app_profile, app_profile_name | |
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если было предоставлено имя файла private_key, значение по умолчанию устанавливается в private_key без расширения.Если для private_key был предоставлен контент в формате PEM, значение по умолчанию устанавливается в username.псевдонимы: cert_name | |
| deploy_immediacy строка |
| Определяет, когда политика отправляется в кэш CAM политики оборудования. APIC по умолчанию устанавливает lazy при отсутствии значения при создании. |
| domain строка | Имя физического или виртуального домена, ассоциируемого с EPG. псевдонимы: domain_name, domain_profile | |
| domain_type строка |
| Указывает, является ли домен физическим (phys), виртуальным (vmm) или ассоциацией с внешним L2-доменом (l2dom). псевдонимы: type |
| encap целое число | Капсулирование VLAN для EPG при привязке VMM-домена со статическими encap_mode. Выступает в качестве дополнительного encap при использовании useg. Допустимые значения находятся в диапазоне от 1 до 4096. | |
| encap_mode строка |
| Метод капсулирования для использования. APIC по умолчанию устанавливает auto при отсутствии значения при создании.Если выбран vxlan, switching_mode должен быть "AVE". |
| epg строка | Имя группы конечных точек. псевдонимы: epg_name, name | |
| host строка / обязательно | IP-адрес или имя хоста, разрешаемое хостом управления Ansible. псевдонимы: hostname | |
| netflow логическое значение |
| Определяет, следует ли включить netflow. APIC по умолчанию устанавливает no при отсутствии значения при создании. |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, вкл. current dictinfo добавляет информативный вывод, вкл. previous, proposed и sent dictsdebug добавляет отладочный вывод, вкл. filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если указано также private_key, будет использовано последнее. | |
| port целое число | Номер порта для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| primary_encap целое число | Определяет первичный идентификатор VLAN при использовании useg. Допустимые значения находятся в диапазоне от 1 до 4096. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемые для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если также указано password, оно будет проигнорировано.псевдонимы: cert_key | |
| resolution_immediacy строка |
| Определяет, когда политики должны быть разрешены и доступны. APIC по умолчанию устанавливает lazy при отсутствии значения при создании. |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| switching_mode строка добавлено в 2.9 |
| Режим коммутации, используемый коммутатором. |
| tenant строка | Имя существующего арендатора. псевдонимы: tenant_name | |
| timeout целое число | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое значение |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl логическое значение |
| Если no, вместо стандартного HTTPS-соединения будет использовано HTTP-соединение. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs логическое значение |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать только в no на контролируемых сайтах, использующих самозаверенные сертификаты. |
| vm_provider строка |
| Платформа виртуальных машин для VMM-доменов. Поддержка Kubernetes была добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1. |
Примечания
Примечание
- Должны существовать
tenant,ap,epg, иdomain, прежде чем использовать этот модуль в вашем плане. Для этого можно использовать модули aci_tenant aci_ap, aci_epg и aci_domain. - Домены VMM OpenStack не должны создаваться с помощью этого модуля. Домен OpenStack VMM создаётся напрямую плагином Cisco APIC Neutron во время установки и настройки. Этот модуль может использоваться для запроса состояния домена OpenStack VMM.
См. также
См. также
- aci_ap — Управление объектами профилей приложений верхнего уровня (AP) (fv:Ap)
- Официальная документация по модулю aci_ap.
- aci_epg — Управление объектами групп конечных точек (EPG) (fv:AEPg)
- Официальная документация по модулю aci_epg.
- aci_domain — Управление профилями физических, виртуальных, мостовых, маршрутизированных или FC доменов (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
- Официальная документация по модулю aci_domain.
- Ссылка на модель управления информацией APIC
- Дополнительная информация об внутренней классе APIC fv:RsDomAtt.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: present
delegate_to: localhost
- name: Remove an existing physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: absent
delegate_to: localhost
- name: Query a specific physical domain to EPG binding
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
tenant: anstest
ap: anstest
epg: anstest
domain: anstest
domain_type: phys
state: query
delegate_to: localhost
register: query_result
- name: Query all domain to EPG bindings
aci_epg_to_domain:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата документированы здесь, следующие — поля, уникальные для этого модуля:
| Ключ | Возвращённое значение | Описание |
|---|---|---|
| current список | успех | Настройка, существующая в APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая из APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Используемая строка фильтрации для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Используемый HTTP-метод для запроса к APIC Пример: POST |
| previous список | информация | Исходная настройка из APIC до начала работы модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сборка конфигурации из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ из APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус из APIC Пример: 200 |
| url строка | ошибка или отладка | Используемый HTTP-URL для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнёром Ansible. [сертифицированный]
Авторы
- Jacob McGill (@jmcgill298)
Подсказка
Если вы заметите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_epg_to_domain_module.html