aci_vmm_credential – Управление профилями учетных данных виртуальных доменов (vmm:UsrAccP)
Новое в версии 2.9.
Описание
- Управление профилями учетных данных виртуальных доменов на Cisco ACI сетях.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикреплённого к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если было предоставлено имя файла private_key, значение по умолчанию равно private_key имени без расширения.Если для private_key был предоставлен контент в формате PEM, значение по умолчанию равно username значению.Псевдонимы: cert_name | |
| credential_password строка | Пароль контроллера VMM. | |
| credential_username строка | Имя пользователя контроллера VMM. | |
| description строка | Описание для тенанта. Псевдонимы: descr | |
| domain строка | Имя профиля виртуального домена. Псевдонимы: domain_name, domain_profile, name | |
| host строка / обязательно | IP-адрес или имя хоста, разрешаемое контрольным хостом Ansible. Псевдонимы: hostname | |
| name строка | Имя профиля учетных данных. Псевдонимы: credential_name, credential_profile | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информационный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также предоставлен private_key, он будет использован вместо него. | |
| port целое число | Порт, используемый для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если также предоставлен password, он будет проигнорирован.Псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для получения списка объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl логическое |
| Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при работе с сайтами, управляемыми лично, которые используют самозаверяющие сертификаты. |
| vm_provider строка |
| Платформа виртуальных машин для VMM доменов. Поддержка Kubernetes была добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1. |
См. также
См. также
- aci_domain – Управление физическими, виртуальными, мостовыми, маршрутизированными или FC профилями доменов (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
- Официальная документация по модулю aci_domain.
- APIC Management Information Model reference
- Дополнительная информация о внутренних классах APIC vmm:DomP
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add credential to VMware VMM domain
aci_vmm_credential:
host: apic
username: admin
password: SomeSecretPassword
domain: vmware_dom
description: secure credential
name: vCenterCredential
credential_username: vCenterUsername
credential_password: vCenterPassword
vm_provider: vmware
state: present
- name: Remove credential from VMware VMM domain
aci_vmm_credential:
host: apic
username: admin
password: SomeSecretPassword
domain: vmware_dom
name: myCredential
vm_provider: vmware
state: absent
- name: Query a specific VMware VMM credential
aci_vmm_credential:
host: apic
username: admin
password: SomeSecretPassword
domain: vmware_dom
name: vCenterCredential
vm_provider: vmware
state: query
delegate_to: localhost
register: query_result
- name: Query all VMware VMM credentials
aci_vmm_credential:
host: apic
username: admin
password: SomeSecretPassword
domain: vmware_dom
vm_provider: vmware
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата описаны здесь, следующие поля уникальны для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращенная APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сформированная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращенный API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратной совместимости. [превью]
- Этот модуль поддерживается сообществом Ansible. [сообщество]
Авторы
- Jason Juenger (@jasonjuenger)
Подсказка
Если вы заметили какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_vmm_credential_module.html