Соответствующие стандарты
На этой странице перечислены все соответствующие стандарты, которым следует Apache HTTP Server, и приведены их краткие описания.
Помимо приведённых ниже сведений, следует обратиться к следующим ресурсам:
- http://purl.org/NET/http-errata — исправления к спецификации HTTP/1.1
- http://www.rfc-editor.org/errata.php — исправления к RFC
- http://ftp.ics.uci.edu/pub/ietf/http/#RFC — предварительно составленный список RFC, относящихся к HTTP
Примечание
Этот документ ещё не завершён.
Рекомендации по HTTP
Независимо от того, какие модули скомпилированы и используются, Apache как базовый веб-сервер соответствует следующим рекомендациям IETF:
- RFC 1945 (Информационный)
- Протокол передачи гипертекста (HTTP) — это протокол прикладного уровня, обладающий лёгкостью и быстродействием, необходимыми для распределённых совместных гипермедийных информационных систем. В этом документе описан HTTP/1.0.
- RFC 2616 (Стандарты)
- Протокол передачи гипертекста (HTTP) — это протокол прикладного уровня для распределённых совместных гипермедийных информационных систем. В этом документе описан HTTP/1.1.
- RFC 2396 (Стандарты)
- Унифицированный идентификатор ресурса (URI) — это компактная строка символов для идентификации абстрактного или физического ресурса.
- RFC 4346 (Стандарты)
- Протокол TLS обеспечивает безопасность обмена данными через Интернет. Он обеспечивает шифрование и предназначен для защиты от перехвата, подмены и фальсификации сообщений.
Рекомендации по HTML
Что касается языка разметки гипертекста, Apache соответствует следующим рекомендациям IETF и W3C:
- RFC 2854 (Информационный)
- В этом документе кратко изложена история развития HTML и определён тип MIME "text/html" со ссылками на соответствующие рекомендации W3C.
- Спецификация HTML 4.01 (Исправления)
- Эта спецификация определяет язык разметки гипертекста (HTML) — язык публикации Всемирной паутины. В спецификации определён HTML 4.01, представляющий собой минорную версию HTML 4.
- Справочная спецификация HTML 3.2
- Язык разметки гипертекста (HTML) — это простой язык разметки, используемый для создания гипертекстовых документов, переносимых с одной платформы на другую. Документы HTML являются документами SGML.
- XHTML 1.1 — модульный XHTML (Исправления)
- Эта рекомендация определяет новый тип документов XHTML, основанный на модульной структуре и модулях, определённых в документе «Модульная структура XHTML».
- XHTML 1.0 — расширяемый язык разметки гипертекста (второе издание) (Исправления)
- Эта спецификация определяет второе издание XHTML 1.0 — переработанную версию HTML 4 в виде приложения XML 1.0, а также три DTD, соответствующие DTD, определённым в HTML 4.
Аутентификация
Что касается различных методов аутентификации, Apache следует следующим рекомендациям IETF:
- RFC 2617 (Стандарты)
- «HTTP/1.0», включает спецификацию схемы базовой аутентификации доступа.
Коды языков и стран
В следующих ссылках приводятся сведения о кодах языков и стран по ISO и другим стандартам:
- ISO 639-2
- ISO 639 содержит два набора кодов языков: один состоит из двухбуквенных кодов (639-1), а другой — из трёхбуквенных кодов (эта часть ISO 639) для представления названий языков.
- ISO 3166-1
- На этих страницах в алфавитном порядке приведены названия стран (официальные краткие названия на английском языке), указанные в ISO 3166-1, а также соответствующие им двухбуквенные коды ISO 3166-1-alpha-2.
- BCP 47 (Рекомендации, актуальные на данный момент), RFC 3066
- В этом документе описан языковой тег для случаев, когда требуется указать язык, используемый в информационном объекте, порядок регистрации значений для использования в этом языковом теге, а также способ сопоставления таких языковых тегов.
- RFC 3282 (Стандарты)
- В этом документе определены заголовок "Content-language:" для указания языка содержимого, имеющего заголовки типа RFC 822, например частей тела MIME или веб-документов, и заголовок "Accept-Language:" для указания предпочтений пользователя относительно языка.
© 2018 The Apache Software Foundation
Licensed under the Apache License, Version 2.0.
https://httpd.apache.org/docs/2.4/en/misc/relevant_standards.html