Spec-Zone.ru › AWS CLI v2

[ aws . dms ]

describe-replications

Описание

Предоставляет подробную информацию о ходе репликации, возвращая сведения о статусе одной или нескольких предоставленных репликаций DMS Serverless.

См. также: Документация AWS API

Синтаксис

  describe-replications
[--filters <value>]
[--max-records <value>]
[--marker <value>]
[--cli-input-json | --cli-input-yaml]
[--generate-cli-skeleton <value>]
[--debug]
[--endpoint-url <value>]
[--no-verify-ssl]
[--no-paginate]
[--output <value>]
[--query <value>]
[--profile <value>]
[--region <value>]
[--version <value>]
[--color <value>]
[--no-sign-request]
[--ca-bundle <value>]
[--cli-read-timeout <value>]
[--cli-connect-timeout <value>]
[--cli-binary-format <value>]
[--no-cli-pager]
[--cli-auto-prompt]
[--no-cli-auto-prompt]

Параметры

--filters (список)

Фильтры, применяемые к репликациям.

Допустимые имена фильтров: replication-config-arn | replication-config-id

(структура)

Определяет имя и значение объекта фильтра. Этот фильтр используется для ограничения количества и типа объектов DMS, возвращаемых для конкретного вызова Describe* или аналогичной операции. Фильтры используются в качестве необязательного параметра для определенных API-операций.

Имя -> (строка)

Имя фильтра, указанное для операции Describe* или аналогичной операции.

Значения -> (список)

Значение фильтра, которое может указывать одно или несколько значений, используемых для сужения возвращаемых результатов.

(строка)

Сокращённый синтаксис:

Name=string,Values=string,string ...

Синтаксис JSON:

[
  {
    "Name": "string",
    "Values": ["string", ...]
  }
  ...
]

--max-records (целое число)

Максимальное количество записей, включаемых в ответ. Если существует больше записей, чем указанное значение MaxRecords, в ответ включается маркер страницы (pagination token), называемый маркером, чтобы можно было получить оставшиеся результаты.

--marker (строка)

Необязательный маркер страницы, полученный в предыдущем запросе. Если этот параметр указан, в ответ включаются только записи после маркера, до значения, указанного параметром MaxRecords.

--cli-input-json | --cli-input-yaml (строка) Считывает аргументы из предоставленной строки JSON. Строка JSON следует формату, указанному в --generate-cli-skeleton. Если другие аргументы предоставлены в командной строке, эти значения перепишут значения, предоставленные в JSON. Невозможно передать произвольные двоичные значения с помощью значения, предоставленного в JSON, так как строка будет воспринята буквально. Это не может быть указано вместе с --cli-input-yaml.

--generate-cli-skeleton (строка) Выводит JSON-скелет в стандартный вывод без отправки запроса API. Если предоставлено значение без значения или со значением input, выводит пример входного JSON, который может быть использован в качестве аргумента для --cli-input-json. Аналогично, если предоставлено yaml-input, будет напечатан пример входного YAML, который можно использовать с --cli-input-yaml. Если предоставлено значение output, оно валидирует входные данные команды и возвращает пример выходного JSON для этой команды. Сгенерированный JSON-скелет не является стабильным между версиями AWS CLI, и нет гарантий обратной совместимости в сгенерированном JSON-скелете.

Глобальные параметры

--debug (логическое значение)

Включает отладку логирования.

--endpoint-url (строка)

Переопределяет значение по умолчанию URL команды заданным URL.

--no-verify-ssl (логическое значение)

По умолчанию AWS CLI использует SSL при общении с AWS-сервисами. Для каждого подключения SSL AWS CLI проверяет сертификаты SSL. Этот параметр переопределяет поведение проверки сертификатов SSL по умолчанию.

--no-paginate (логическое значение)

Отключает автоматическую постраничную навигацию. Если автоматическая постраничная навигация отключена, AWS CLI выполнит только один вызов для первой страницы результатов.

--output (строка)

Стиль форматирования вывода команды.

  • json
  • текст
  • таблица
  • yaml
  • yaml-поток

--query (строка)

Запрос JMESPath для фильтрации данных ответа.

--profile (строка)

Использование определенного профиля из файла с вашими учетными данными.

--region (строка)

Используемый регион. Переопределяет настройки конфигурации/среды.

--version (строка)

Отображение версии этого инструмента.

--color (строка)

Включение/выключение цветного вывода.

  • включено
  • выключено
  • автоматически

--no-sign-request (логическое значение)

Не подписывать запросы. Учетные данные не будут загружены, если этот аргумент указан.

--ca-bundle (строка)

Набор сертификатов CA для использования при проверке сертификатов SSL. Переопределяет настройки конфигурации/среды.

--cli-read-timeout (целое число)

Максимальное время чтения сокета в секундах. Если значение установлено в 0, чтение сокета будет выполняться блокирующим образом и без таймаута. Значение по умолчанию — 60 секунд.

--cli-connect-timeout (целое число)

Максимальное время подключения сокета в секундах. Если значение установлено в 0, подключение сокета будет выполняться блокирующим образом и без таймаута. Значение по умолчанию — 60 секунд.

--cli-binary-format (строка)

Стиль форматирования, используемый для двоичных блоков. Формат по умолчанию — base64. Формат base64 ожидает, что двоичные блоки будут предоставлены в виде строки, закодированной в base64. Формат raw-in-base64-out сохраняет совместимость с поведением AWS CLI V1, и двоичные значения должны быть переданы буквально. При предоставлении содержимого файла, отображающего двоичный блок, fileb:// всегда будет обрабатываться как двоичный и будет использовать содержимое файла напрямую независимо от настройки cli-binary-format. При использовании file:// содержимое файла должно быть правильно отформатировано для настроенного cli-binary-format.

  • base64
  • raw-in-base64-out

--no-cli-pager (логическое значение)

Отключение постраничной навигации cli для вывода.

--cli-auto-prompt (логическое значение)

Автоматически запрашивать параметры входных данных CLI.

--no-cli-auto-prompt (логическое значение)

Отключение автоматического запроса параметров входных данных CLI.

Вывод

Маркер -> (строка)

Необязательный маркер постраничной навигации, предоставленный предыдущим запросом. Если этот параметр указан, в ответ включаются только записи после маркера, до значения, указанного в MaxRecords .

Репликации -> (список)

Описание репликации.

(структура)

Предоставляет информацию, описывающую серверную репликацию, созданную операцией CreateReplication.

ReplicationConfigIdentifier -> (строка)

Идентификатор ReplicationConfig, связанный с репликацией.

ReplicationConfigArn -> (строка)

Amazon Resource Name (ARN) ReplicationConfig, связанной с репликацией.

SourceEndpointArn -> (строка)

Amazon Resource Name (ARN) существующего Endpoint, используемого серверной репликацией в качестве источника данных.

TargetEndpointArn -> (строка)

Amazon Resource Name (ARN) существующего Endpoint, используемого серверной репликацией в качестве целевого объекта.

ReplicationType -> (строка)

Тип серверной репликации.

Статус -> (строка)

Текущий статус серверной репликации.

ProvisionData -> (структура)

Информация о выделении ресурсов для серверной репликации DMS.

ProvisionState -> (строка)

Текущее состояние выделения

ProvisionedCapacityUnits -> (целое число)

Количество единиц мощности, используемых репликацией.

DateProvisioned -> (метка времени)

Дата выделения ресурсов репликации DMS.

IsNewProvisioningAvailable -> (булево значение)

Доступность нового выделения для репликации.

DateNewProvisioningDataAvailable -> (метка времени)

Дата доступности нового выделения.

ReasonForNewProvisioningData -> (строка)

Сообщение, описывающее причину выделения DMS новых ресурсов для серверной репликации.

PremigrationAssessmentStatuses -> (список)

Выходные данные статуса оценки предварительной миграции в describe-replications.

(структура)

Результаты, возвращенные в describe-replications для отображения результатов оценки предварительной миграции из конфигурации репликации.

PremigrationAssessmentRunArn -> (строка)

Amazon Resource Name (ARN) этого запуска оценки.

FailOnAssessmentFailure -> (булево значение)

Конфигурируемый параметр, который можно установить в значение true (по умолчанию) или false. Используйте этот параметр, чтобы остановить автоматический запуск репликации при сбое оценки. Это поможет оценить проблему, препятствующую успешному запуску репликации.

Статус -> (строка)

Описание состояния запуска оценки. Статус может принимать одно из следующих значений:

  • cancelling : Запуск оценки был отменен.
  • deleting : Запуск оценки был удален.
  • failed : По крайней мере, одна отдельная оценка завершилась с ошибкой.
  • error-provisioning : При выделении ресурсов (в состоянии provisioning) произошла внутренняя ошибка.
  • error-executing Внутренняя ошибка произошла при выполнении отдельных оценок (в состоянии running).
  • invalid state : Запуск оценки находится в неизвестном состоянии.
  • passed : Все отдельные оценки завершены, и ни одна не завершилась с ошибкой.
  • provisioning : Ресурсы, необходимые для запуска отдельных оценок, выделены.
  • running : Запускаются отдельные оценки.
  • starting : Запуск оценки начался, но ресурсы для отдельных оценок еще не выделяются.
  • warning : По крайней мере, одна отдельная оценка завершилась с предупреждением.

PremigrationAssessmentRunCreationDate -> (метка времени)

Дата создания запуска оценки.

AssessmentProgress -> (структура)

Значения прогресса, сообщаемые элементом ответа AssessmentProgress.

IndividualAssessmentCount -> (целое число)

Количество отдельных оценок, которые должны быть запущены.

IndividualAssessmentCompletedCount -> (целое число)

Количество отдельных оценок, которые завершились, успешно или нет.

LastFailureMessage -> (строка)

Последнее сообщение, сгенерированное при ошибке отдельной оценки.

ResultLocationBucket -> (строка)

Amazon S3-ведро, созданное Database Migration Service Serverless для хранения результатов этого запуска оценки.

ResultLocationFolder -> (строка)

Папка в Amazon S3-ведре, в которой Database Migration Service Serverless должен хранить результаты этого запуска оценки.

ResultEncryptionMode -> (строка)

Поддерживаемые значения — SSE_KMS и SSE_S3. Если эти значения не указаны, файлы не шифруются при хранении. Дополнительные сведения см. в разделе Создание ключей KMS Amazon Web Services для шифрования целевых объектов Amazon S3.

ResultKmsKeyArn -> (строка)

ARN настраиваемого ключа шифрования KMS, указанного при установке параметра ResultEncryptionMode в значение SSE_KMS.

ResultStatistic -> (структура)

Объект, содержащий статистику результатов завершенного запуска оценки.

Passed -> (целое число)

Количество отдельных оценок, успешно пройденных во всех проверках в рамках запуска оценки.

Failed -> (целое число)

Количество отдельных оценок, которые не соответствуют критериям, определенным в рамках запуска оценки.

Error -> (целое число)

Количество отдельных оценок, столкнувшихся с критическими ошибками и не смогло завершиться должным образом.

Warning -> (целое число)

Указывает, что недавний завершенный AssessmentRun сгенерировал предупреждение.

Cancelled -> (целое число)

Количество отдельных оценок, отмененных во время запуска оценки.

Skipped -> (целое число)

Количество отдельных оценок, пропущенных во время запуска оценки.

StopReason -> (строка)

Причина остановки задачи репликации. Этот параметр ответа может возвращать одно из следующих значений:

  • "Stop Reason NORMAL"
  • "Stop Reason RECOVERABLE_ERROR"
  • "Stop Reason FATAL_ERROR"
  • "Stop Reason FULL_LOAD_ONLY_FINISHED"
  • "Stop Reason STOPPED_AFTER_FULL_LOAD" – Полная загрузка завершена, кэшированные изменения не применены
  • "Stop Reason STOPPED_AFTER_CACHED_EVENTS" – Полная загрузка завершена, кэшированные изменения применены
  • "Stop Reason EXPRESS_LICENSE_LIMITS_REACHED"
  • "Stop Reason STOPPED_AFTER_DDL_APPLY" – Пользовательская остановка задачи после применения DDL
  • "Stop Reason STOPPED_DUE_TO_LOW_MEMORY"
  • "Stop Reason STOPPED_DUE_TO_LOW_DISK"
  • "Stop Reason STOPPED_AT_SERVER_TIME" – Пользовательское серверное время для остановки задачи
  • "Stop Reason STOPPED_AT_COMMIT_TIME" – Пользовательское время коммита для остановки задачи
  • "Stop Reason RECONFIGURATION_RESTART"
  • "Stop Reason RECYCLE_TASK"

FailureMessages -> (список)

Ошибки и другая информация о причинах сбоя серверной репликации.

(строка)

ReplicationStats -> (структура)

Этот объект предоставляет набор статистических данных о серверной репликации.

FullLoadProgressPercent -> (целое число)

Процент завершения полной загрузки серверной репликации.

ElapsedTimeMillis -> (длинное целое)

Затраченное время репликации в миллисекундах.

TablesLoaded -> (целое число)

Количество загруженных таблиц для данной репликации.

TablesLoading -> (целое число)

Количество таблиц, загружаемых в данный момент для данной репликации.

TablesQueued -> (целое число)

Количество таблиц, поставленных в очередь для данной репликации.

TablesErrored -> (целое число)

Количество ошибок, произошедших при данной репликации.

FreshStartDate -> (метка времени)

Дата начала репликации с новым началом или перезагрузкой целевого объекта.

StartDate -> (метка времени)

Дата, когда запланировано начало репликации.

StopDate -> (метка времени)

Дата остановки репликации.

FullLoadStartDate -> (метка времени)

Дата начала полной загрузки репликации.

FullLoadFinishDate -> (метка времени)

Дата завершения полной загрузки репликации.

StartReplicationType -> (строка)

Тип репликации для запуска.

CdcStartTime -> (метка времени)

Указывает время начала операции захвата изменений (CDC). Используйте либо CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.

CdcStartPosition -> (строка)

Указывает время начала операции захвата изменений (CDC). Используйте либо CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.

CdcStopPosition -> (строка)

Указывает время завершения операции захвата изменений (CDC). Значение может быть либо временем сервера, либо временем коммита.

RecoveryCheckpoint -> (строка)

Указывает последний контрольный пункт, выполненный во время операции захвата изменений (CDC). Вы можете предоставить это значение параметру CdcStartPosition, чтобы начать операцию CDC, начиная с этого контрольного пункта.

ReplicationCreateTime -> (метка времени)

Время создания серверной репликации.

ReplicationUpdateTime -> (метка времени)

Время обновления серверной репликации.

ReplicationLastStopTime -> (метка времени)

Метка времени последней остановки репликации.

ReplicationDeprovisionTime -> (метка времени)

Метка времени, когда DMS будет дезактивировать репликацию.

© Copyright 2025, Amazon Web Services. Created using Sphinx.

END_OF_DOCUMENT_MARKER

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API