start-replication
Описание
Для заданной конфигурации репликации DMS Serverless, DMS подключается к целевому конечному пункту и собирает метаданные для анализа рабочей нагрузки репликации. Используя эти метаданные, DMS затем вычисляет и предоставляет необходимую емкость и начинает репликацию в целевой конечной точке, используя системные ресурсы, выделенные DMS для репликации DMS Serverless.
См. также: Документация AWS API
Синтаксис
start-replication
--replication-config-arn <value>
--start-replication-type <value>
[--premigration-assessment-settings <value>]
[--cdc-start-time <value>]
[--cdc-start-position <value>]
[--cdc-stop-position <value>]
[--cli-input-json | --cli-input-yaml]
[--generate-cli-skeleton <value>]
[--debug]
[--endpoint-url <value>]
[--no-verify-ssl]
[--no-paginate]
[--output <value>]
[--query <value>]
[--profile <value>]
[--region <value>]
[--version <value>]
[--color <value>]
[--no-sign-request]
[--ca-bundle <value>]
[--cli-read-timeout <value>]
[--cli-connect-timeout <value>]
[--cli-binary-format <value>]
[--no-cli-pager]
[--cli-auto-prompt]
[--no-cli-auto-prompt]
Параметры
--replication-config-arn (строка)
--start-replication-type (строка)
Тип репликации.
Когда тип репликации — full-load или full-load-and-cdc, единственное допустимое значение для первой итерации репликации — start-replication. Этот параметр запустит репликацию.
Вы также можете использовать ReloadTables для перезагрузки определенных таблиц, которые не удались во время репликации, вместо перезапуска репликации.
Параметр resume-processing не применим для репликации полного объема, так как вы не можете возобновить частично загруженные таблицы во время фазы полной загрузки.
Для репликации full-load-and-cdc DMS мигрирует данные таблиц и затем применяет изменения данных, происходящие на источнике. Чтобы снова загрузить все таблицы и начать захват изменений источника, используйте reload-target. В противном случае используйте resume-processing, чтобы реплицировать изменения с последней позиции остановки.
--premigration-assessment-settings (строка)
Пользовательские настройки для оценки предмиграции. Возможные значения:
-
ResultLocationFolder: папка в ведре Amazon S3, где DMS должен хранить результаты этого запуска оценки. -
ResultEncryptionMode: допустимые значения —SSE_KMSиSSE_S3. Если эти значения не предоставлены, файлы не будут шифроваться в состоянии покоя. Дополнительную информацию см. в разделе Создание ключей KMS Amazon Web Services для шифрования целевых объектов Amazon S3. -
ResultKmsKeyArn: ARN пользовательского ключа шифрования KMS, который вы указываете при установкеResultEncryptionModeнаSSE_KMS. -
IncludeOnly: список имен, разделенных пробелами, для конкретных отдельных оценок, которые вы хотите включить. Эти имена взяты из списка стандартных оценок, поддерживаемых Database Migration Service для соответствующей миграции. -
Exclude: список имен, разделенных пробелами, для конкретных отдельных оценок, которые вы хотите исключить. Эти имена взяты из списка стандартных оценок, поддерживаемых Database Migration Service для соответствующей миграции. -
FailOnAssessmentFailure: настраиваемый параметр, который можно установить наtrue(значение по умолчанию) илиfalse. Используйте этот параметр, чтобы остановить автоматический запуск репликации в случае неудачи оценки. Это может помочь вам оценить проблему, которая мешает успешному запуску репликации.
--cdc-start-time (метка времени)
CdcStartTime, либо CdcStartPosition, чтобы указать время запуска операции CDC. Указание обоих значений приведет к ошибке.--cdc-start-position (строка)
Указывает время запуска операции захвата изменений данных (CDC). Используйте либо CdcStartPosition, либо CdcStartTime, чтобы указать время запуска операции CDC. Указание обоих значений приведет к ошибке.
Значение может быть в формате даты, контрольной точки или LSN/SCN.
--cdc-stop-position (строка)
--cli-input-json | --cli-input-yaml (строка) Читает аргументы из предоставленной JSON-строки. JSON-строка следует формату, предоставленному --generate-cli-skeleton. Если другие аргументы предоставлены в командной строке, эти значения переопределят значения, предоставленные JSON. Невозможно передавать произвольные двоичные значения с помощью значения, предоставленного JSON, поскольку строка будет интерпретироваться буквально. Это не может быть указано вместе с --cli-input-yaml.
--generate-cli-skeleton (строка) Выводит JSON-скелет в стандартный вывод без отправки запроса API. Если предоставлено без значения или со значением input, выводит пример входного JSON, который можно использовать в качестве аргумента для --cli-input-json. Аналогично, если предоставлено yaml-input, он выведет пример входного YAML, который можно использовать с --cli-input-yaml. Если предоставлено значение output, он проверит входные данные команды и вернёт пример выходного JSON для этой команды. Сгенерированный JSON-скелет нестабилен между версиями AWS CLI, и нет гарантии обратной совместимости в сгенерированном JSON-скелете.
Глобальные параметры
--debug (булево)
Включить отладочную запись журнала.
--endpoint-url (строка)
Переопределить URL по умолчанию команды указанным URL.
--no-verify-ssl (булево)
По умолчанию AWS CLI использует SSL при общении с AWS-сервисами. Для каждого SSL-соединения AWS CLI проверит SSL-сертификаты. Этот параметр переопределяет поведение проверки SSL-сертификатов по умолчанию.
--no-paginate (булево)
Отключить автоматическую постраничную навигацию. Если автоматическая постраничная навигация отключена, AWS CLI сделает только один вызов для первой страницы результатов.
--output (строка)
Стиль форматирования для вывода команды.
- json
- text
- table
- yaml
- yaml-stream
--query (строка)
Запрос JMESPath для использования при фильтрации данных ответа.
--profile (строка)
Использовать определенный профиль из файла учетных данных.
--region (строка)
Использовать определенный регион. Переопределяет настройки конфигурации/среды.
--version (строка)
Отобразить версию данного инструмента.
--color (строка)
Включить/отключить цветной вывод.
- on
- off
- auto
--no-sign-request (булево)
Не подписывать запросы. Учетные данные не будут загружаться, если этот аргумент предоставлен.
--ca-bundle (строка)
Файл с сертификатами CA для проверки SSL-сертификатов. Переопределяет настройки конфигурации/среды.
--cli-read-timeout (целое число)
Максимальное время чтения сокета в секундах. Если значение установлено в 0, чтение сокета будет выполняться блокирующим образом и без таймаута. Значение по умолчанию — 60 секунд.
--cli-connect-timeout (целое число)
Максимальное время подключения сокета в секундах. Если значение установлено в 0, подключение сокета будет выполняться блокирующим образом и без таймаута. Значение по умолчанию — 60 секунд.
--cli-binary-format (строка)
Стиль форматирования, используемый для двоичных блоков. Формат по умолчанию — base64. Формат base64 ожидает, что двоичные блоки будут предоставлены как строка в кодировке base64. Формат raw-in-base64-out сохраняет совместимость с поведением AWS CLI V1, и двоичные значения должны быть переданы буквально. При предоставлении содержимого из файла, соответствующего двоичному блоку, fileb:// всегда будет обрабатываться как двоичное и будет использовать содержимое файла напрямую независимо от настройки cli-binary-format. При использовании file:// содержимое файла должно быть правильно отформатировано для настроенного cli-binary-format.
- base64
- raw-in-base64-out
--no-cli-pager (булево)
Отключить кли-пейджер для вывода.
--cli-auto-prompt (булево)
Автоматически запрашивать параметры ввода CLI.
--no-cli-auto-prompt (булево)
Отключить автоматическое запросы параметров ввода CLI.
Вывод
Репликация -> (структура)
Репликация, начатая DMS.
ReplicationConfigIdentifier -> (строка)
ReplicationConfig, связанный с репликацией.ReplicationConfigArn -> (строка)
ReplicationConfig, связанный с репликацией.SourceEndpointArn -> (строка)
Endpoint, который серверная репликация использует в качестве источника данных.TargetEndpointArn -> (строка)
Endpoint, который серверная репликация использует в качестве целевого объекта.ReplicationType -> (строка)
Status -> (строка)
ProvisionData -> (структура)
Информация о выделении ресурсов для серверной репликации DMS.
ProvisionState -> (строка)
ProvisionedCapacityUnits -> (целое число)
DateProvisioned -> (метка времени)
IsNewProvisioningAvailable -> (булево)
DateNewProvisioningDataAvailable -> (метка времени)
ReasonForNewProvisioningData -> (строка)
PremigrationAssessmentStatuses -> (список)
Статус результата оценки предмиграции в describe-replications.
(структура)
Результаты, возвращаемые в describe-replications для отображения результатов оценки предмиграции из конфигурации репликации.
PremigrationAssessmentRunArn -> (строка)
FailOnAssessmentFailure -> (булево)
true (значение по умолчанию) или false. Используйте этот параметр для остановки автоматического запуска репликации в случае неудачи оценки. Это поможет вам оценить проблему, которая мешает успешному запуску репликации.Status -> (строка)
Это описывает статус выполнения оценки. Статус может иметь одно из следующих значений:
-
cancelling: Выполнение оценки было отменено. -
deleting: Выполнение оценки было удалено. -
failed: По крайней мере, одна отдельная оценка завершилась неудачно. -
error-provisioning: При выделении ресурсов произошла внутренняя ошибка (во время статусаprovisioning). -
error-executing: При выполнении отдельных оценок произошла внутренняя ошибка (во время статусаrunning). -
invalid state: Выполнение оценки находится в неизвестном состоянии. -
passed: Все отдельные оценки завершены, и ни одна не завершилась неудачно. -
provisioning: Ресурсы, необходимые для запуска отдельных оценок, выделяется. -
running: Запускаются отдельные оценки. -
starting: Выполнение оценки началось, но ресурсы для отдельных оценок еще не выделены. -
warning: По крайней мере, одна отдельная оценка завершилась с предупреждением.
PremigrationAssessmentRunCreationDate -> (метка времени)
AssessmentProgress -> (структура)
Значения прогресса, сообщенные элементом ответа AssessmentProgress.
IndividualAssessmentCount -> (целое число)
IndividualAssessmentCompletedCount -> (целое число)
LastFailureMessage -> (строка)
ResultLocationBucket -> (строка)
ResultLocationFolder -> (строка)
ResultEncryptionMode -> (строка)
SSE_KMS и SSE_S3. Если эти значения не предоставлены, файлы не шифруются в состоянии покоя. Для получения дополнительной информации см. Создание ключей Amazon Web Services KMS для шифрования объектов целевого Amazon S3.ResultKmsKeyArn -> (строка)
ResultEncryptionMode в значение SSE_KMS.ResultStatistic -> (структура)
Объект, содержащий статистические данные результатов завершенного выполнения оценки.
Passed -> (целое число)
Failed -> (целое число)
Error -> (целое число)
Warning -> (целое число)
Cancelled -> (целое число)
Skipped -> (целое число)
StopReason -> (строка)
Причина остановки задачи репликации. Этот параметр ответа может возвращать одно из следующих значений:
"Stop Reason NORMAL""Stop Reason RECOVERABLE_ERROR""Stop Reason FATAL_ERROR""Stop Reason FULL_LOAD_ONLY_FINISHED"-
"Stop Reason STOPPED_AFTER_FULL_LOAD"– Полная загрузка завершена, с кэшированными изменениями, не примененными -
"Stop Reason STOPPED_AFTER_CACHED_EVENTS"– Полная загрузка завершена, с кэшированными изменениями, примененными "Stop Reason EXPRESS_LICENSE_LIMITS_REACHED"-
"Stop Reason STOPPED_AFTER_DDL_APPLY"– Пользовательская остановка задачи после применения DDL "Stop Reason STOPPED_DUE_TO_LOW_MEMORY""Stop Reason STOPPED_DUE_TO_LOW_DISK"-
"Stop Reason STOPPED_AT_SERVER_TIME"– Пользовательское серверное время для остановки задачи -
"Stop Reason STOPPED_AT_COMMIT_TIME"– Пользовательское время подтверждения для остановки задачи "Stop Reason RECONFIGURATION_RESTART""Stop Reason RECYCLE_TASK"
FailureMessages -> (список)
Ошибки и другая информация о причинах неудачи серверной репликации.
(строка)
ReplicationStats -> (структура)
Этот объект предоставляет набор статистических данных о серверной репликации.
FullLoadProgressPercent -> (целое число)
ElapsedTimeMillis -> (длинное целое число)
TablesLoaded -> (целое число)
TablesLoading -> (целое число)
TablesQueued -> (целое число)
TablesErrored -> (целое число)
FreshStartDate -> (метка времени)
StartDate -> (метка времени)
StopDate -> (метка времени)
FullLoadStartDate -> (метка времени)
FullLoadFinishDate -> (метка времени)
StartReplicationType -> (строка)
CdcStartTime -> (метка времени)
CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.CdcStartPosition -> (строка)
CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.CdcStopPosition -> (строка)
RecoveryCheckpoint -> (строка)
CdcStartPosition, чтобы начать операцию CDC, которая начинается с этой контрольной точки.ReplicationCreateTime -> (метка времени)
ReplicationUpdateTime -> (метка времени)
ReplicationLastStopTime -> (метка времени)
ReplicationDeprovisionTime -> (метка времени)
© Copyright 2025, Amazon Web Services. Created using Sphinx.