stop-replication
Описание
Для заданной конфигурации репликации DMS Serverless, DMS останавливает все текущие репликации DMS Serverless. Данная команда не удаляет остановленные репликации.
См. также: Документацию API AWS
Синтаксис
stop-replication
--replication-config-arn <value>
[--cli-input-json | --cli-input-yaml]
[--generate-cli-skeleton <value>]
[--debug]
[--endpoint-url <value>]
[--no-verify-ssl]
[--no-paginate]
[--output <value>]
[--query <value>]
[--profile <value>]
[--region <value>]
[--version <value>]
[--color <value>]
[--no-sign-request]
[--ca-bundle <value>]
[--cli-read-timeout <value>]
[--cli-connect-timeout <value>]
[--cli-binary-format <value>]
[--no-cli-pager]
[--cli-auto-prompt]
[--no-cli-auto-prompt]
Параметры
--replication-config-arn (строка)
--cli-input-json | --cli-input-yaml (строка) Считывает аргументы из предоставленной JSON-строки. JSON-строка следует формату, предоставленному --generate-cli-skeleton. Если другие аргументы предоставлены в командной строке, эти значения переопределят значения, предоставленные JSON. Невозможно передавать произвольные двоичные значения с помощью значения, предоставленного JSON, так как строка будет воспринята буквально. Это не может быть указано вместе с --cli-input-yaml.
--generate-cli-skeleton (строка) Выводит JSON-скелет в стандартный вывод без отправки запроса API. Если предоставлено значение без значения или значение input, выводит пример входного JSON, который можно использовать в качестве аргумента для --cli-input-json. Аналогично, если предоставлено yaml-input, выведет пример входного YAML, который можно использовать с --cli-input-yaml. Если предоставлено значение output, оно проверяет входные данные команды и возвращает пример выходного JSON для этой команды. Сгенерированный JSON-скелет не стабилен между версиями AWS CLI, и нет гарантий обратной совместимости в сгенерированном JSON-скелете.
Глобальные параметры
--debug (логическое значение)
Включить отладку.
--endpoint-url (строка)
Переопределить значение по умолчанию URL команды на указанный URL.
--no-verify-ssl (логическое значение)
По умолчанию AWS CLI использует SSL при общении с AWS-сервисами. Для каждого подключения SSL AWS CLI будет проверять сертификаты SSL. Этот параметр переопределяет поведение проверки сертификатов SSL по умолчанию.
--no-paginate (логическое значение)
Отключить автоматическую постраничную навигацию. Если автоматическая постраничная навигация отключена, AWS CLI выполнит только один вызов для первой страницы результатов.
--output (строка)
Стиль форматирования вывода команды.
- json
- текст
- таблица
- yaml
- yaml-потоковый
--query (строка)
Запрос JMESPath для фильтрации данных ответа.
--profile (строка)
Использовать определённый профиль из файла учетных данных.
--region (строка)
Регион для использования. Переопределяет настройки конфигурации/среды.
--version (строка)
Отобразить версию этого инструмента.
--color (строка)
Включить/отключить цветной вывод.
- включено
- выключено
- автоматически
--no-sign-request (логическое значение)
Не подписывать запросы. Учетные данные не будут загружены, если этот аргумент предоставлен.
--ca-bundle (строка)
Файл сертификатов CA для проверки сертификатов SSL. Переопределяет настройки конфигурации/среды.
--cli-read-timeout (целое число)
Максимальное время чтения сокета в секундах. Если значение установлено в 0, чтение сокета будет блокирующим и не будет иметь таймаута. Значение по умолчанию составляет 60 секунд.
--cli-connect-timeout (целое число)
Максимальное время подключения сокета в секундах. Если значение установлено в 0, подключение сокета будет блокирующим и не будет иметь таймаута. Значение по умолчанию составляет 60 секунд.
--cli-binary-format (строка)
Стиль форматирования, используемый для двоичных блоков. Формат по умолчанию — base64. Формат base64 ожидает, что двоичные блоки будут предоставлены как закодированная строка base64. Формат raw-in-base64-out сохраняет совместимость с поведением AWS CLI V1, и двоичные значения должны быть переданы буквально. При предоставлении содержимого из файла, отображающего двоичный блок, fileb:// всегда будет обрабатываться как двоичный и использовать содержимое файла напрямую независимо от cli-binary-format. При использовании file:// содержимое файла должно быть правильно отформатировано для настроенного cli-binary-format.
- base64
- raw-in-base64-out
--no-cli-pager (логическое значение)
Отключить кли-педжер для вывода.
--cli-auto-prompt (логическое значение)
Автоматически запросить параметры CLI ввода.
--no-cli-auto-prompt (логическое значение)
Отключить автоматическое запросы параметров CLI ввода.
Вывод
Репликация -> (структура)
Репликация, которую DMS остановил.
ReplicationConfigIdentifier -> (строка)
ReplicationConfig, связанный с репликацией.ReplicationConfigArn -> (строка)
ReplicationConfig, связанный с репликацией.SourceEndpointArn -> (строка)
Endpoint, который используется бессерверной репликацией для источника данных.TargetEndpointArn -> (строка)
Endpoint, который используется бессерверной репликацией для целевого объекта.ReplicationType -> (строка)
Status -> (строка)
ProvisionData -> (структура)
Информация о выделении ресурсов для бессерверной репликации DMS.
ProvisionState -> (строка)
ProvisionedCapacityUnits -> (целое число)
DateProvisioned -> (метка времени)
IsNewProvisioningAvailable -> (логическое значение)
DateNewProvisioningDataAvailable -> (метка времени)
ReasonForNewProvisioningData -> (строка)
PremigrationAssessmentStatuses -> (список)
Статус результатов оценки предоперационной миграции в describe-replications.
(структура)
Результаты, возвращаемые в describe-replications для отображения результатов оценки предоперационной миграции из конфигурации репликации.
PremigrationAssessmentRunArn -> (строка)
FailOnAssessmentFailure -> (логическое значение)
true (значение по умолчанию) или в false. Используйте этот параметр, чтобы остановить автоматический запуск репликации в случае неудачи оценки. Это может помочь в анализе проблемы, препятствующей успешному запуску репликации.Status -> (строка)
Это описывает статус выполнения оценки. Статус может быть одним из следующих значений:
-
cancelling: Выполнение оценки было отменено. -
deleting: Выполнение оценки было удалено. -
failed: По крайней мере, одно отдельное оценивание завершилось с ошибкой. -
error-provisioning: Внутренняя ошибка произошла при выделении ресурсов (во время статусаprovisioning). -
error-executing: Внутренняя ошибка произошла во время выполнения отдельных оценок (во время статусаrunning). -
invalid state: Выполнение оценки находится в неизвестном состоянии. -
passed: Все отдельные оценки завершены, и ни одна из них не завершилась ошибкой. -
provisioning: Требуемые ресурсы для выполнения отдельных оценок выделяются. -
running: Выполняются отдельные оценки. -
starting: Выполнение оценки началось, но ресурсы для отдельных оценок еще не выделяются. -
warning: По крайней мере, одна отдельная оценка завершилась с предупреждением.
PremigrationAssessmentRunCreationDate -> (метка времени)
AssessmentProgress -> (структура)
Значения прогресса, сообщенные элементом ответа AssessmentProgress.
IndividualAssessmentCount -> (целое число)
IndividualAssessmentCompletedCount -> (целое число)
LastFailureMessage -> (строка)
ResultLocationBucket -> (строка)
ResultLocationFolder -> (строка)
ResultEncryptionMode -> (строка)
SSE_KMS и SSE_S3. Если эти значения не заданы, файлы не шифруются при хранении. Для получения дополнительной информации см. Создание ключей KMS Amazon Web Services для шифрования объектов Amazon S3.ResultKmsKeyArn -> (строка)
ResultEncryptionMode в SSE_KMS.ResultStatistic -> (структура)
Объект, содержащий статистические данные результатов завершенного выполнения оценки.
Passed -> (целое число)
Failed -> (целое число)
Error -> (целое число)
Warning -> (целое число)
Cancelled -> (целое число)
Skipped -> (целое число)
StopReason -> (строка)
Причина остановки задачи репликации. Этот параметр ответа может возвращать одно из следующих значений:
"Stop Reason NORMAL""Stop Reason RECOVERABLE_ERROR""Stop Reason FATAL_ERROR""Stop Reason FULL_LOAD_ONLY_FINISHED"-
"Stop Reason STOPPED_AFTER_FULL_LOAD"– Полная загрузка завершена, с кэшированными изменениями, которые не применены -
"Stop Reason STOPPED_AFTER_CACHED_EVENTS"– Полная загрузка завершена, с кэшированными изменениями, которые применены "Stop Reason EXPRESS_LICENSE_LIMITS_REACHED"-
"Stop Reason STOPPED_AFTER_DDL_APPLY"– Пользовательская остановка задачи после применения DDL "Stop Reason STOPPED_DUE_TO_LOW_MEMORY""Stop Reason STOPPED_DUE_TO_LOW_DISK"-
"Stop Reason STOPPED_AT_SERVER_TIME"– Пользовательское серверное время для остановки задачи -
"Stop Reason STOPPED_AT_COMMIT_TIME"– Пользовательское время подтверждения для остановки задачи "Stop Reason RECONFIGURATION_RESTART""Stop Reason RECYCLE_TASK"
FailureMessages -> (список)
Ошибки и другая информация о причинах неудачи бессерверной репликации.
(строка)
ReplicationStats -> (структура)
Этот объект предоставляет набор статистических данных о бессерверной репликации.
FullLoadProgressPercent -> (целое число)
ElapsedTimeMillis -> (длинное целое число)
TablesLoaded -> (целое число)
TablesLoading -> (целое число)
TablesQueued -> (целое число)
TablesErrored -> (целое число)
FreshStartDate -> (метка времени)
StartDate -> (метка времени)
StopDate -> (метка времени)
FullLoadStartDate -> (метка времени)
FullLoadFinishDate -> (метка времени)
StartReplicationType -> (строка)
CdcStartTime -> (метка времени)
CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.CdcStartPosition -> (строка)
CdcStartTime, либо CdcStartPosition, чтобы указать время начала операции CDC. Указание обоих значений приведет к ошибке.CdcStopPosition -> (строка)
RecoveryCheckpoint -> (строка)
CdcStartPosition, чтобы запустить операцию CDC, которая начнется с этой контрольной точки.ReplicationCreateTime -> (метка времени)
ReplicationUpdateTime -> (метка времени)
ReplicationLastStopTime -> (метка времени)
ReplicationDeprovisionTime -> (метка времени)
© Copyright 2025, Amazon Web Services. Created using Sphinx.