describe-update
Описание
Описывает обновление ресурса Amazon EKS.
Когда статус обновления равен Successful, обновление завершено. Если обновление не удалось, статус равен Failed, а в деталях ошибки объясняется причина неудачи.
См. также: Документацию API AWS
Синтаксис
describe-update
--name <value>
--update-id <value>
[--nodegroup-name <value>]
[--addon-name <value>]
[--cli-input-json | --cli-input-yaml]
[--generate-cli-skeleton <value>]
[--debug]
[--endpoint-url <value>]
[--no-verify-ssl]
[--no-paginate]
[--output <value>]
[--query <value>]
[--profile <value>]
[--region <value>]
[--version <value>]
[--color <value>]
[--no-sign-request]
[--ca-bundle <value>]
[--cli-read-timeout <value>]
[--cli-connect-timeout <value>]
[--cli-binary-format <value>]
[--no-cli-pager]
[--cli-auto-prompt]
[--no-cli-auto-prompt]
Параметры
--name (строка)
--update-id (строка)
--nodegroup-name (строка)
--addon-name (строка)
ListAddons https://docs.aws.amazon.com/eks/latest/APIReference/API_ListAddons.html`__ . Этот параметр обязателен, если обновление относится к плагину.--cli-input-json | --cli-input-yaml (строка) Считывает аргументы из предоставленной строки JSON. Строка JSON следует формату, предоставленному --generate-cli-skeleton. Если на командной строке указаны другие аргументы, эти значения переопределят значения, предоставленные в JSON. Невозможно передать произвольные двоичные данные, используя предоставленное значение JSON, так как строка будет взята буквально. Это не может быть указано вместе с --cli-input-yaml.
--generate-cli-skeleton (строка) Выводит JSON-скелет в стандартный вывод без отправки запроса к API. Если предоставлено значение по умолчанию или значение input, выводит пример входного JSON, который можно использовать в качестве аргумента для --cli-input-json. Аналогично, если предоставлено значение yaml-input, будет выведен пример входного YAML, который можно использовать с --cli-input-yaml. Если предоставлено значение output, валидирует входные данные команды и возвращает пример выходного JSON для этой команды. Сгенерированный JSON-скелет нестабилен между версиями AWS CLI, и нет гарантий обратной совместимости в сгенерированном JSON-скелете.
Глобальные параметры
--debug (логическое значение)
Включает отладочную запись журнала.
--endpoint-url (строка)
Переопределяет URL по умолчанию команды указанным URL.
--no-verify-ssl (логическое значение)
По умолчанию AWS CLI использует SSL при взаимодействии с сервисами AWS. Для каждого SSL-соединения AWS CLI проверяет SSL-сертификаты. Этот параметр переопределяет поведение проверки SSL-сертификатов по умолчанию.
--no-paginate (логическое значение)
Отключает автоматическую постраничность. Если автоматическая постраничность отключена, AWS CLI выполнит только один вызов для первой страницы результатов.
--output (строка)
Стиль форматирования для вывода команды.
- json
- текст
- таблица
- yaml
- yaml-поток
--query (строка)
Запрос JMESPath для фильтрации данных ответа.
--profile (строка)
Использование определенного профиля из файла учетных данных.
--region (строка)
Используемый регион. Переопределяет параметры конфигурации/среды.
--version (строка)
Отображение версии этого инструмента.
--color (строка)
Включение/выключение цветного вывода.
- вкл
- выкл
- авто
--no-sign-request (логическое значение)
Не подписывать запросы. Учетные данные не будут загружены, если этот аргумент предоставлен.
--ca-bundle (строка)
Пакет сертификатов CA для проверки SSL-сертификатов. Переопределяет настройки конфигурации/среды.
--cli-read-timeout (целое число)
Максимальное время чтения сокета в секундах. Если значение установлено в 0, чтение сокета будет блокирующим и без таймаута. Значение по умолчанию составляет 60 секунд.
--cli-connect-timeout (целое число)
Максимальное время подключения сокета в секундах. Если значение установлено в 0, подключение сокета будет блокирующим и без таймаута. Значение по умолчанию составляет 60 секунд.
--cli-binary-format (строка)
Стиль форматирования, используемый для двоичных блоков. Формат по умолчанию — base64. Формат base64 ожидает, что двоичные блоки будут предоставлены как закодированная строка base64. Формат raw-in-base64-out сохраняет совместимость с поведением AWS CLI V1, и двоичные значения должны передаваться буквально. При предоставлении содержимого из файла, которое отображается как двоичный блок fileb:// всегда будет обрабатываться как двоичный и будет использовать содержимое файла напрямую независимо от настроек cli-binary-format. При использовании file:// содержимое файла должно быть должным образом отформатировано для настроенного cli-binary-format.
- base64
- raw-in-base64-out
--no-cli-pager (логическое значение)
Отключить показ страниц CLI для вывода.
--cli-auto-prompt (логическое значение)
Автоматически запросить параметры ввода CLI.
--no-cli-auto-prompt (логическое значение)
Отключить автоматический запрос параметров ввода CLI.
Примеры
Примечание
Для использования следующих примеров необходимо установить и настроить AWS CLI. Более подробную информацию см. в руководстве по началу работы в руководстве пользователя AWS CLI.
Если не указано иное, все примеры используют правила цитирования Unix-подобных систем. Эти примеры необходимо адаптировать к правилам цитирования вашей оболочки. См. Использование кавычек со строками в руководстве пользователя AWS CLI.
Пример 1: Описание обновления для кластера
В следующем describe-update примере описывается обновление для кластера с именем.
aws eks describe-update \
--name my-eks-cluster \
--update-id 10bddb13-a71b-425a-b0a6-71cd03e59161
Вывод:
{
"update": {
"id": "10bddb13-a71b-425a-b0a6-71cd03e59161",
"status": "Successful",
"type": "EndpointAccessUpdate",
"params": [
{
"type": "EndpointPublicAccess",
"value": "false"
},
{
"type": "EndpointPrivateAccess",
"value": "true"
}
],
"createdAt": "2024-03-14T10:01:26.297000-04:00",
"errors": []
}
}
Для получения дополнительной информации см. Обновление версии Kubernetes кластера Amazon EKS в руководстве пользователя Amazon EKS.
Пример 2: Описание обновления для кластера
В следующем describe-update примере описывается обновление для кластера с именем.
aws eks describe-update \
--name my-eks-cluster \
--update-id e4994991-4c0f-475a-a040-427e6da52966
Вывод:
{
"update": {
"id": "e4994991-4c0f-475a-a040-427e6da52966",
"status": "Successful",
"type": "AssociateEncryptionConfig",
"params": [
{
"type": "EncryptionConfig",
"value": "[{\"resources\":[\"secrets\"],\"provider\":{\"keyArn\":\"arn:aws:kms:region-code:account:key/key\"}}]"
}
],
"createdAt": "2024-03-14T11:01:26.297000-04:00",
"errors": []
}
}
Для получения дополнительной информации см. Обновление версии Kubernetes кластера Amazon EKS в руководстве пользователя Amazon EKS.
Пример 3: Описание обновления для кластера
В следующем describe-update примере описывается обновление для кластера с именем.
aws eks describe-update \
--name my-eks-cluster \
--update-id b5f0ba18-9a87-4450-b5a0-825e6e84496f
Вывод:
{
"update": {
"id": "b5f0ba18-9a87-4450-b5a0-825e6e84496f",
"status": "Successful",
"type": "VersionUpdate",
"params": [
{
"type": "Version",
"value": "1.29"
},
{
"type": "PlatformVersion",
"value": "eks.1"
}
],
"createdAt": "2024-03-14T12:05:26.297000-04:00",
"errors": []
}
}
Для получения дополнительной информации см. Обновление версии Kubernetes кластера Amazon EKS в руководстве пользователя Amazon EKS.
Вывод
обновление -> (структура)
Полное описание указанного обновления.
id -> (строка)
статус -> (строка)
тип -> (строка)
параметры -> (список)
Ключевое значение, содержащее параметры, связанные с обновлением.
(структура)
Объект, представляющий подробности запроса на обновление.
тип -> (строка)
значение -> (строка)
создано -> (метка времени)
ошибки -> (список)
Любые ошибки, связанные с обновлением Failed.
(структура)
Объект, представляющий ошибку при сбое асинхронной операции.
код_ошибки -> (строка)
Краткое описание ошибки.
- SubnetNotFound : Мы не смогли найти одну из подсетей, связанных с кластером.
- SecurityGroupNotFound : Мы не смогли найти одну из групп безопасности, связанных с кластером.
- EniLimitReached : Превышен лимит эластичных сетевых интерфейсов для вашей учетной записи.
- IpNotAvailable : У подсети, связанной с кластером, нет доступных IP-адресов.
- AccessDenied : У вас нет разрешений для выполнения указанной операции.
- OperationNotPermitted : У роли сервиса, связанной с кластером, нет необходимых разрешений для Amazon EKS.
- VpcIdNotFound : Мы не смогли найти VPC, связанную с кластером.
сообщение_об_ошибке -> (строка)
resourceIds -> (список)
Необязательное поле, содержащее идентификаторы ресурсов, связанные с ошибкой.
(строка)
© Copyright 2025, Amazon Web Services. Created using Sphinx.
|
|