Spec-Zone.ru › AWS CLI v2

[ aws . service-quotas ]

get-aws-default-service-quota

Описание

Возвращает значение по умолчанию для указанной квоты. Значение по умолчанию не отражает любые увеличения квоты.

См. также: Документация API AWS

Синтаксис

  get-aws-default-service-quota
--service-code <value>
--quota-code <value>
[--cli-input-json | --cli-input-yaml]
[--generate-cli-skeleton <value>]
[--debug]
[--endpoint-url <value>]
[--no-verify-ssl]
[--no-paginate]
[--output <value>]
[--query <value>]
[--profile <value>]
[--region <value>]
[--version <value>]
[--color <value>]
[--no-sign-request]
[--ca-bundle <value>]
[--cli-read-timeout <value>]
[--cli-connect-timeout <value>]
[--cli-binary-format <value>]
[--no-cli-pager]
[--cli-auto-prompt]
[--no-cli-auto-prompt]

Параметры

--service-code (строка)

Указывает идентификатор сервиса. Чтобы найти код сервиса для сервиса Amazon Web Services, используйте операцию ListServices.

--quota-code (строка)

Указывает идентификатор квоты. Чтобы найти код квоты для конкретной квоты, используйте операцию ListServiceQuotas и найдите соответствующий QuotaCode ответ в выводе для нужной вам квоты.

--cli-input-json | --cli-input-yaml (строка) Считывает аргументы из предоставленной JSON-строки. JSON-строка следует формату, предоставленному --generate-cli-skeleton. Если на командной строке предоставлены другие аргументы, эти значения переопределят значения, предоставленные в JSON. Передача произвольных двоичных значений с помощью значения, предоставленного в JSON, невозможна, так как строка будет воспринята буквально. Этот параметр не может быть указан вместе с --cli-input-yaml.

--generate-cli-skeleton (строка) Выводит JSON-скелет в стандартный вывод без отправки запроса к API. Если указано без значения или со значением input, выводит пример JSON-входа, который можно использовать в качестве аргумента для --cli-input-json. Аналогично, если указано yaml-input, выведет пример YAML-входа, который можно использовать с --cli-input-yaml. Если указано значение output, проверяет входные данные команды и возвращает пример JSON-вывода для этой команды. Сгенерированный JSON-скелет не является стабильным между версиями AWS CLI, и нет гарантий обратной совместимости в сгенерированном JSON-скелете.

Глобальные параметры

--debug (булево)

Включить отладку регистрации.

--endpoint-url (строка)

Переопределить URL по умолчанию команды заданным URL.

--no-verify-ssl (булево)

По умолчанию AWS CLI использует SSL при общении с сервисами AWS. Для каждого SSL-соединения AWS CLI будет проверять SSL-сертификаты. Этот параметр переопределяет поведение проверки SSL-сертификатов по умолчанию.

--no-paginate (булево)

Отключить автоматическую постраничность. Если автоматическая постраничность отключена, AWS CLI выполнит только один вызов для первой страницы результатов.

--output (строка)

Стиль форматирования для вывода команды.

  • json
  • text
  • table
  • yaml
  • yaml-stream

--query (строка)

Запрос JMESPath для фильтрации данных ответа.

--profile (строка)

Использование конкретного профиля из файла учетных данных.

--region (строка)

Регион для использования. Переопределяет настройки конфигурации/среды.

--version (строка)

Отображение версии этого инструмента.

--color (строка)

Включение/выключение цветного вывода.

  • on
  • off
  • auto

--no-sign-request (булево)

Не подписывать запросы. Учетные данные не будут загружены, если этот аргумент предоставлен.

--ca-bundle (строка)

Сборник сертификатов CA для использования при проверке SSL-сертификатов. Переопределяет настройки конфигурации/среды.

--cli-read-timeout (целое число)

Максимальное время чтения сокета в секундах. Если значение равно 0, чтение сокета будет блокирующим и не будет иметь таймаута. Значение по умолчанию составляет 60 секунд.

--cli-connect-timeout (целое число)

Максимальное время подключения сокета в секундах. Если значение равно 0, подключение сокета будет блокирующим и не будет иметь таймаута. Значение по умолчанию составляет 60 секунд.

--cli-binary-format (строка)

Стиль форматирования для использования с двоичными блоками. Формат по умолчанию — base64. Формат base64 ожидает, что двоичные блоки будут предоставлены в виде закодированной в base64 строки. Формат raw-in-base64-out сохраняет совместимость с поведением AWS CLI V1, и двоичные значения должны передаваться буквально. При предоставлении содержимого из файла, отображающего двоичный блок, fileb:// всегда будет обрабатываться как двоичный и будет использовать содержимое файла непосредственно независимо от параметра cli-binary-format. При использовании file:// содержимое файла должно быть должным образом отформатировано для настроенного cli-binary-format.

  • base64
  • raw-in-base64-out

--no-cli-pager (булево)

Отключить вывод пагинатора CLI.

--cli-auto-prompt (булево)

Автоматически запрашивать параметры ввода CLI.

--no-cli-auto-prompt (булево)

Отключить автоматическую запрос параметров ввода CLI.

Примеры

Примечание

Для использования следующих примеров необходимо установить и настроить AWS CLI. Подробнее см. руководство по началу работы в Руководстве пользователя AWS CLI.

Если не указано иное, во всех примерах используются правила цитирования Unix-подобных систем. Эти примеры необходимо адаптировать к правилам цитирования вашей терминальной среды. См. Использование кавычек со строками в Руководстве пользователя AWS CLI.

Для описания квоты сервиса по умолчанию

Следующий get-aws-default-service-quota пример отображает подробности для указанной квоты.

aws service-quotas get-aws-default-service-quota \
    --service-code ec2 \
    --quota-code L-1216C47A

Вывод:

{
    "Quota": {
        "ServiceCode": "ec2",
        "ServiceName": "Amazon Elastic Compute Cloud (Amazon EC2)",
        "QuotaArn": "arn:aws:servicequotas:us-east-2::ec2/L-1216C47A",
        "QuotaCode": "L-1216C47A",
        "QuotaName": "Running On-Demand Standard (A, C, D, H, I, M, R, T, Z) instances",
        "Value": 5.0,
        "Unit": "None",
        "Adjustable": true,
        "GlobalQuota": false,
        "UsageMetric": {
            "MetricNamespace": "AWS/Usage",
            "MetricName": "ResourceCount",
            "MetricDimensions": {
                "Class": "Standard/OnDemand",
                "Resource": "vCPU",
                "Service": "EC2",
                "Type": "Resource"
            },
            "MetricStatisticRecommendation": "Maximum"
        }
    }
}

Вывод

Квота -> (структура)

Информация о квоте.

ServiceCode -> (строка)

Указывает идентификатор сервиса. Чтобы найти код сервиса для сервиса Amazon Web Services, используйте операцию ListServices.

ServiceName -> (строка)

Указывает имя сервиса.

QuotaArn -> (строка)

Amazon Resource Name (ARN) квоты.

QuotaCode -> (строка)

Указывает идентификатор квоты. Чтобы найти код квоты для конкретной квоты, используйте операцию ListServiceQuotas и найдите соответствующий QuotaCode ответ в выводе для нужной вам квоты.

QuotaName -> (строка)

Указывает имя квоты.

Value -> (двойное число)

Значение квоты.

Unit -> (строка)

Единица измерения.

Adjustable -> (булево)

Указывает, можно ли увеличить значение квоты.

GlobalQuota -> (булево)

Указывает, является ли квота глобальной.

UsageMetric -> (структура)

Информация об измерении.

MetricNamespace -> (строка)

Имя пространства метрики.

MetricName -> (строка)

Имя метрики.

MetricDimensions -> (карта)

Измерение размерности. Это имя/значение, являющееся частью идентификатора метрики.

key -> (строка)

value -> (строка)

MetricStatisticRecommendation -> (строка)

Метрика статистики, которую мы рекомендуем использовать при определении использования квоты.

Period -> (структура)

Период времени.

PeriodValue -> (целое число)

Значение, связанное с отчетом PeriodUnit.

PeriodUnit -> (строка)

Единица времени.

ErrorReason -> (структура)

Код и причина ошибки.

ErrorCode -> (строка)

Service Quotas возвращает следующие значения ошибок:

  • DEPENDENCY_ACCESS_DENIED_ERROR - У вызывающей стороны нет необходимых разрешений для завершения действия. Для устранения ошибки необходимо иметь разрешения на доступ к сервису Amazon Web Services или квоте.
  • DEPENDENCY_THROTTLING_ERROR - Сервис Amazon Web Services ограничивает Service Quotas.
  • DEPENDENCY_SERVICE_ERROR - Сервис Amazon Web Services недоступен.
  • SERVICE_QUOTA_NOT_AVAILABLE_ERROR - Возникла ошибка в Service Quotas.

ErrorMessage -> (строка)

Сообщение об ошибке.

QuotaAppliedAtLevel -> (строка)

Фильтрует ответ, чтобы вернуть примененные значения квот для уровней ACCOUNT, RESOURCE или ALL. ACCOUNT по умолчанию.

QuotaContext -> (структура)

Контекст для этой квоты сервиса.

ContextScope -> (строка)

Указывает область применения значения квоты. Если область применения RESOURCE, значение квоты применяется к каждому ресурсу в учетной записи Amazon Web Services. Если область применения ACCOUNT, значение квоты применяется к учетной записи Amazon Web Services.

ContextScopeType -> (строка)

Указывает тип ресурса, к которому может быть применена квота.

ContextId -> (строка)

Указывает ресурс или ресурсы, к которым относится квота. Значение этого поля — либо Amazon Resource Name (ARN), либо *. Если значение — ARN, значение квоты применяется к этому ресурсу. Если значение — *, тогда значение квоты применяется ко всем ресурсам, перечисленным в поле ContextScopeType. Значение квоты применяется ко всем ресурсам, для которых вы ранее не применяли значение квоты, и к любым новым ресурсам, которые вы создаете в своей учетной записи Amazon Web Services.

Description -> (строка)

Описание квоты.

© Copyright 2025, Amazon Web Services. Created using Sphinx.

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API