Spec-Zone.ru › Elasticsearch 7
›Руководство по Elasticsearch [7.17] ›REST API ›API компактного и выровненного текста (CAT)

API cat snapshots

API cat предназначены только для использования человеком с помощью командной строки или консоли Kibana. Они не предназначены для использования приложениями. Для использования приложениями используйте API получения снимков.

Возвращает информацию о снимках, хранящихся в одном или нескольких репозиториях. Снимок — это резервная копия индекса или работающего кластера Elasticsearch.

Запрос

GET /_cat/snapshots/<repository>

GET /_cat/snapshots

Предварительные условия

  • Если функции безопасности Elasticsearch включены, у вас должен быть monitor_snapshot, create_snapshot или manage право доступа к кластеру, чтобы использовать этот API.

Параметры пути

<repository>

(Необязательный, строка) Список репозиториев снимков, разделенный запятыми, используемый для ограничения запроса. Принимаются выражения с подстановкой. _all возвращает все репозитории.

Если какой-либо репозиторий завершает работу во время запроса, Elasticsearch возвращает ошибку.

Параметры запроса

format
(Необязательно, строка) Короткая версия заголовка HTTP accept. Допустимые значения включают JSON, YAML и т. д.
h

(Необязательно, строка) Список столбцов для отображения, разделённый запятыми.

Если вы не укажете, какие столбцы включить, API вернёт значения по умолчанию в порядке, указанном ниже. Если вы явно укажете один или несколько столбцов, API вернёт только указанные столбцы.

Допустимые столбцы:

id, snapshot
(По умолчанию) Идентификатор снимка, например snap1.
repository, re, repo
(По умолчанию) Название репозитория, например repo1.
status, s

(По умолчанию) Состояние процесса создания снимка. Возвращаемые значения:

  • FAILED: Процесс создания снимка завершился ошибкой.
  • INCOMPATIBLE: Процесс создания снимка несовместим с текущей версией кластера.
  • IN_PROGRESS: Процесс создания снимка начался, но не завершился.
  • PARTIAL: Процесс создания снимка завершился с частичным успехом.
  • SUCCESS: Процесс создания снимка завершился успешно.
start_epoch, ste, startEpoch
(По умолчанию) Временная метка Unix начала процесса создания снимка.
start_time, sti, startTime
(По умолчанию) Временная метка начала процесса создания снимка.
end_epoch, ete, endEpoch
(По умолчанию) Временная метка Unix завершения процесса создания снимка.
end_time, eti, endTime
(По умолчанию) Временная метка завершения процесса создания снимка.
duration, dur
(По умолчанию) Время, затраченное на завершение процесса создания снимка в единицах измерения времени.
indices, i
(По умолчанию) Количество индексов в снимке.
successful_shards, ss
(По умолчанию) Количество успешных фрагментов в снимке.
failed_shards, fs
(По умолчанию) Количество неудачных фрагментов в снимке.
total_shards, ts
(По умолчанию) Общее количество фрагментов в снимке.
reason, `r
Причина любых ошибок при создании снимка.
help
(Необязательно, логическое значение) Если true, ответ включает справочную информацию. По умолчанию false.
ignore_unavailable
(Необязательно, логическое значение) Если true, ответ не включает информацию из недоступных снимков. По умолчанию false.
master_timeout
(Необязательно, единицы измерения времени) Период ожидания подключения к узлу-мастеру. Если ответ не получен до истечения срока ожидания, запрос завершается неудачей и возвращается ошибка. По умолчанию 30s.
s
(Необязательно, строка) Список столбцов или псевдонимов столбцов, разделённых запятыми, для сортировки ответа.
time
(Необязательно, единицы измерения времени) Единица измерения времени.
v
(Необязательно, логическое значение) Если true, ответ включает заголовки столбцов. По умолчанию false.

Примеры

GET /_cat/snapshots/repo1?v=true&s=id

API возвращает следующий ответ:

id     repository status start_epoch start_time end_epoch  end_time duration indices successful_shards failed_shards total_shards
snap1  repo1      FAILED 1445616705  18:11:45   1445616978 18:16:18     4.6m       1                 4             1            5
snap2  repo1      SUCCESS 1445634298  23:04:58   1445634672 23:11:12     6.2m       2                10             0           10

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/cat-snapshots.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API