Spec-Zone.ru › Elasticsearch 7
›Elasticsearch Руководство [7.17] ›Заметки к выпуску

Elasticsearch версия 7.11.1

Также см. Изменения, вносящие разрыв совместимости в 7.11.

Известные проблемы

  • Снимок и восстановление: Если индекс удаляется, в то время как кластер одновременно выполняет более одного снимка, существует риск, что один из снимков никогда не завершится, а также что некоторые данные фрагмента могут быть потеряны из хранилища, что приведет к отказу будущих операций восстановления. Для уменьшения этой проблемы, установите snapshot.max_concurrent_operations: 1, чтобы предотвратить одновременные операции создания снимков:

    PUT _cluster/settings
    {
      "persistent" : {
        "snapshot.max_concurrent_operations" : 1
      }
    }

    Эта проблема исправлена в версиях Elasticsearch 7.13.1 и более поздних. Невозможно исправить хранилище, если оно затронуто этой проблемой, поэтому вы должны восстановить хранилище из резервной копии или очистить хранилище, выполнив DELETE _snapshot/<repository name>/*, или перейти к новому хранилищу. Более подробную информацию см. в #73456.

  • Обработка запроса, когда последний элемент в массиве отфильтровывается (например, с использованием _source_includes), приводит к ошибке. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее значение index.mapper.dynamic может нарушить работу вашего кластера. Его можно установить только с помощью API обновления настроек индекса. Симптомы включают отказ узлов от запуска или отказ фрагментов от распределения. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)

Улучшения

API функций/индексов
  • Предотвращение конкурентных проблем при переходе индексов #67953 (проблемы: #64921, #67836)
Функции/Статистика
  • Добавление статистики версии создания индексов в статистику кластера #68141
Снимок/Восстановление
  • Улучшение удаления фрагментов в службе кэширования снимков для поиска #67160 (проблемы: #66730, #66958)
  • Внедрение асинхронной долговечности кэша блоков #66687

Исправления ошибок

Аутентификация
  • Исправить разрешения для UnboundID LDAP SDK #68872 (задачи: #64743, #68838)
Координация кластера
  • Определить роль данных на основе соглашения #66933 (задача: #66000)
Функции/ILM+SLM
  • Проверить, есть ли действия на фазе удаления #66664 (задача: #65847)
  • Исправить обработку конфигураций с сочетанием максимального и expire-after retention #68352
  • Исправить действие searchable snapshot, чтобы оно ожидает восстановленный индекс #68309 (задача: #67879)
  • Игнорировать clusterChanged события, если состояние не восстановлено #67507 (задача: #67506)
  • ShrinkStep игнорирует флаг isAcknowledged в ответе #67591 (задача: #53111)
  • Пропустить rollover, если поток данных уже был переведен #67778 (задача: #67777)
Функции/API индексов
  • Исправить исключение при валидации составной шаблона без шаблона #67310 (задача: #66949)
Функции/Ingest
  • Исправить разбор пустого значения с скобками, который не удался в обработчике dissect ingest #65524 (задача: #65080)
Функции/Статистики
  • Разрешить чтение /proc/meminfo для обхода ошибки JDK #68742
  • Обход ошибки JDK с общей памятью в Debian 8 #68542 (задачи: #66629, #66885)
Geo
  • Добавить поддержку запроса distance_feature для поля geo_point в режиме выполнения #68094 (задача: #67910)
Инфраструктура/Скрипты
  • Удалить снисходительность при приведении типа def к типу void в Painless #66957 (задача: #66175)
Машинное обучение
  • Убедиться, что отображения обновлены перед откат состояния #68746
Сеть
  • Исправить утечку слушателя AbstractClient#execute #65415 (задача: #65405)
Упаковка
  • Исправить ошибку, возникающую при запуске службы в ОС Windows по пути с пробелом #61895 (задача: #61891)
  • Исправить проблему с установкой MSI в Windows, которая препятствует запуску Elasticsearch #402 (задача: #68914)
Восстановление
  • Проверить кладбище при импорте висящего индекса #67687
SQL
  • Исправить elasticsearch-sql-cli в Docker #67737 (задача: #57744)
  • Исправить функцию MINUTE_OF_DAY(), которая выбрасывает исключение при использовании в сравнениях #68783 (задачи: #67872, #68788)
Снапшоты/Восстановление
  • Уменьшить количество потоков кэширования/предварительной загрузки #67021
  • Настроить кодировку идентификаторов блоков Azure #68957 (задача: #66489)

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.11.1.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API