Spec-Zone.ru › Elasticsearch 7
›Руководство по Elasticsearch [7.17] ›Заметки о релизе

Elasticsearch версия 7.17.1

См. также Изменения, вносящие разрывы совместимости в 7.17.

Известные проблемы

  • Парсинг запроса, когда последний элемент в массиве отфильтрован (например, при использовании _source_includes), завершается ошибкой. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее index.mapper.dynamic значение может нарушить работу вашего кластера. Его можно установить только с помощью API Update index settings. Симптомы включают отказ узлов от запуска или отказ фрагментов от выделения. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)

Устаревания

Infra/Core
  • API информации об устаревании для форматов дат с использованием верблюжьей нотации #83839

Улучшения

Авторизация
  • Использование одной и той же схемы индексов системы в ограниченных именах #84180
Infra/REST API
  • Обновление YAML REST-тестов для проверки заголовка продукта во всех ответах #83290
Восстановление
  • Настройка indices.recovery.max_bytes_per_sec в соответствии с внешними настройками #82819
Преобразование
  • Отображение предупреждений об устаревании скриптов в API информации об устаревании #84040 (проблема: #82936)

Исправление ошибок

Агрегации
  • Обратная совместимость с версией 7.17.0 #83715 (проблемы: #83339, #83533)
Автомасштабирование
  • Исправление автомасштабирования потоковых данных-фолловеров #83302 (проблема: #82857)
Плагины обнаружения
  • Правильная обработка больших зон GCE с 500 или более экземплярами #83785 (проблема: #83783)
Гео
  • GeometryNormalizer не должен завершаться ошибкой, если не может вычислить подписанную область #84051 (проблема: #83946)
ILM+SLM
  • Не допускать отрицательного возраста в ILM explain #84043
Infra/Core
  • Всегда повторно запускать миграции функций, которые столкнулись с ошибками #83918 (проблема: #83917)
  • Копирование trace.id в хранилище threadcontext #83218 (проблема: #81381)
  • Правильная миграция системных индексов, которые все еще используют именованные типы #83817 (проблема: #83779)
  • Регистрация состояния миграции функций с помощью постоянного задания, используя XContent #84192 (проблема: #84115)
  • Обновление метаданных системного индекса, если _meta равно null #83896 (проблема: #83890)
Infra/Скриптинг
  • Исправление устаревших предложений для JodaCompatibleZonedDateTime #83276
Ввод данных
  • Исправление запуска GeoIpDownloader во время постепенного обновления #84000
  • Прерывание поиска шаблонов дат после первого совпадения #83764 (проблема: #73918)
Машинное обучение
  • Исправление ошибки, когда начальное масштабирование с 0→1 могло масштабироваться слишком сильно #84244
  • Повторная попытка восстановления работы задания обнаружения аномалий во время перемещения #83456
  • Решение проблемы с ошибками логов "[CStatisticalTests.cc@102] Test statistic is nan" #2196
  • Решение возможных причин ошибок логов "x = NaN, distribution = N5boost4math23students_t_distribution" #2197
  • Исправление ошибки восстановления состояния сборщика данных для функций обнаружения аномалий по времени суток и неделе #2213
Восстановление
  • Добавление отсутствующего indices.recovery.internal_action_retry_timeout в список настроек #83354 (проблема: #55353)
SQL
  • Исправление формата txt для пустых наборов результатов #83376 (проблема: #83371)
Поиск
  • Избегание ранней загрузки StoredFieldsReader на стадии извлечения #83693 (проблема: #82777)
  • Не десериализовать документ, если это не требуется на стадии извлечения полей #84184
  • Возвращает корректный PIT, когда индекс не найден #83424
Преобразование
  • Предотвращение остановки преобразований из-за ограничений потока #81912 (проблема: #81796)

Обновления

Geo
  • Обновить векторные тайлы google protobuf до 3.16.1 #83402
Packaging
  • Увеличить версию встроенной JDK до 17.0.2+8 #83243 (проблема: #83242)
Transform
  • Передать устаревшие объявления от ответа поиска к ответу API преобразования _preview #83257 (проблема: #82935)

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.17.1.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API