Spec-Zone.ru › Elasticsearch 7
›Elasticsearch Guide [7.17] ›Справочные материалы по выпуску

Elasticsearch версия 7.17.4

Также см. Изменения, требующие перехода, в 7.17.

Известные проблемы

  • Парсинг запроса, когда последний элемент в массиве отфильтрован (например, с использованием _source_includes), завершается сбоем. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее значение index.mapper.dynamic может нарушить работу вашего кластера. Его можно задать только с помощью API Обновление настроек индекса. Симптомы включают сбои при запуске узлов или отказе фрагментов от распределения. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)

Исправления ошибок

Координация кластера
  • Избегайте нарушения голосования исключений добавления/очистки #86657
Geo
  • Исправление ориентации многоугольника mvt #86555 (проблема: #86560)
ILM+SLM
  • Перенаправление после миграции на маршрутизацию уровней данных #86574 (проблема: #86572)
Infra/Core
  • Исправление assertDefaultThreadContext перечисления разрешенных заголовков #86262
  • Смягчение устаревания пути данных с критического на предупреждение #85952
  • Установка автоматического расширения реплик для потоков данных действий флота #85511
Infra/Settings
  • Корректировка устаревания MDP с критического на предупреждение #86102 (проблема: #85695)
Machine Learning
  • Исправление max_model_memory_limit, сообщенное _ml/info при включенном автоматическом масштабировании #86660
  • Повышение надежности статистики задач в больших кластерах #86305
  • Использование одинакового определения устаревания памяти для автоматического масштабирования и распределения задач #86632 (проблема: #86616)
  • Исправление граничного случая, который мог привести к увеличению границ модели после обнаружения сезонности #2261
  • Исправление причины ошибки журнала "Необходимо предоставить точки, в которых необходимо оценить функцию" при обучении классификационных и регрессионных моделей #2268
Упаковка
  • Исправление граничного случая, когда настройки кучи, определенные пользователем, игнорируются #86438 (проблема: #86431)
Снимок/Восстановление
  • Лучшее обращение с ошибками для снимков только источника частично/полностью смонтированных индексов #86207
  • Проверка успешности предварительной выделения кэша поисковых снимков в Windows #86192 (проблема: #85725)
  • Задержка выделения поискового снимка во время завершения работы #86153 (проблема: #85052)
Статистика
  • Правильное вычисление использования дискового пространства для телеметрии замороженного уровня данных #86580 (проблема: #86055)
Управление задачами
  • Использование TaskCancelledException в TMNA #86659

Обновления

Упаковка
  • Переход к OpenJDK и обновление до 18.0.1 #86554

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.17.4.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API