Spec-Zone.ru › Elasticsearch 7
›Руководство по Elasticsearch [7.17] ›Примечания к выпуску

Версия Elasticsearch 7.7.1

См. также Критические изменения в 7.7.

Известные проблемы

  • SQL: Если в WHERE-оператор содержит как минимум два реляционных оператора, соединённых через AND, один из которых является сравнением (<=, <, >=, >), а другой — неравенством (!=, <>), оба по отношению к литералам или складываемым выражениям, неравенство будет проигнорировано. В качестве обходного решения необходимо заменить неравенство оператором NOT IN.

    Мы исправили эту проблему в Elasticsearch 7.10.1 и более поздних версиях. Дополнительную информацию см. в #65488.

  • Разбор запроса, когда последний элемент в массиве отфильтрован (например, с использованием _source_includes), завершается неудачно. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее значение index.mapper.dynamic может нарушить работу кластера. Его можно установить только с помощью API Обновления настроек индекса. Симптомы включают невозможность запуска узлов или невозможность распределения фрагментов. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)

Улучшения

Авторизация
  • Удаление синтетических имён ролей для API-ключей, так как они вводят пользователей в заблуждение #56005
Функции/ILM+SLM
  • ILM: Добавление таймаута обновления кластера при повторной попытке шага #54878
SQL
  • Изменение сообщения об ошибке для сравнения со значениями в фильтрах #57126 (проблема: #57005)

Исправления ошибок

Аутентификация
  • Развернуть idp.metadata.http.refresh для домена SAML #56354
  • Исправить одновременное обновление токенов #55114 (проблема: #54289)
CCR
  • Повторить выполнение задачи следования при полной загрузке очереди удалённого соединения #55314
Координация кластера
  • Исправить проблему двойного восстановления при полном перезапуске кластера (#55564) #55780 (проблема: #55564)
Discovery-Плагины
  • Скрыть шум c.a.a.p.i.BasicProfileConfigFileLoader #56346 (проблемы: #20313, #56333)
Двигатель
  • Обеспечить отсутствие циклической ссылки в исключении translog tragic #55959 (проблема: #55893)
  • Обновить политику translog перед следующей безопасной фиксацией #54839 (проблема: #52223)
Функции/API CAT
  • Обработка исключений при построении ответа _cat/indices #56993 (проблема: #56816)
Функции/Функции
  • Исправления спецификации REST API только для 7.x #56736 (проблема: #55984)
Функции/ILM+SLM
  • Исправление отсутствующего флага IgnoredUnavailable в задаче удержания SLM 7.x #56616
Функции/API индексов
  • Разрешение удаления настроек реплик для закрытых индексов #56680 (проблемы: #56656, #56675)
  • Разрешение удаления параметра index.number_of_replicas #56656 (проблема: #56501)
Функции/Ingest
  • Исправление координатора обогащения для отклонения документов вместо тупика #56247 (проблема: #55634)
  • EnrichProcessorFactory не должен выбрасывать NPE при отсутствии метаданных #55977
  • Предотвращение переполнения стека для множества шаблонов grok. #55899
  • Исправление обработки empty_value в CsvProcessor #55649 (проблема: #55643)
Функции/Java REST-клиент высокого уровня
  • Учитывать IndicesOptions в запросе HLRC putMapping #57118 (проблема: #57045)
Функции/Мониторинг
  • Исправить ошибочное предупреждение журнала при экспорте мониторинга по HTTP без аутентификации #56958 (проблема: #56810)
  • Обеспечить, чтобы исключения при экспорте мониторинга были записаны в журнал. #56237
Функции/Watcher
  • Убедиться, что шаблон .watcher-history-11* установлен перед использованием #56734 (проблема: #56732)
  • Исправить параметр smtp.ssl.trust для электронной почты watcher #56090 (проблемы: #45272, #52153)
Инфра/Ядро
  • Предотвратить неожиданное зависание процесса после вывода нативный контроллер #56491 (проблема: #56366)
  • Добавить метод для проверки, может ли объект быть общедоступным для записи в потоке #54936 (проблема: #54708)
Инфра/Ведение журнала
  • SlowLoggers с использованием одного логгера #56708 (проблема: #56171)
Машинное обучение
  • Исправление сохранения состояния категоризатора. #1137 (проблема: #1136)
  • Исправление сбоев задач классификации, когда количество классов в конфигурации отличается от количества классов в обучающих данных. #1144
  • Исправление основной причины ошибок в журнале "Не удалось вычислить значимость разделения". #1157
  • Исправление возможной основной причины ошибок в журнале "Плохое масштабирование дисперсии nan". #1225
  • Изменение разрешения временной метки инструментации анализа данных фрейма до миллисекунд. #1237
  • Исправление ошибки "Процесс автоопределения неожиданно завершился: Критическая ошибка: terminate called after throwing an instance of 'std::bad_function_call'". #1246 (проблема: #1245)
  • Исправление мониторинга, если существуют оставшиеся задачи обнаружения аномалий. #57235 (проблема: #51888)
  • Исправление задач технического обслуживания delete_expired_data/еженощного обслуживания при необходимости удаления многих снимков моделей. #57041 (проблема: #47103)
  • Обеспечение представления класса при низкой кратности. #56783
  • Использование ненулевого таймаута при принудительной остановке анализа данных DF. #56423
  • Уменьшение спама журналов InferenceProcessor.Factory, не анализируя конвейеры. #56020 (проблема: #55985)
  • Аудит при остановке незадействованных источников данных. #55656 (проблема: #55521)
Сеть
  • Исправление использования защищенных паролем ключей PKCS#8 для SSL. #55457 (проблема: #8)
  • Добавление поддержки дополнительных кривых с именами. #55179 (проблема: #55031)
Восстановление
  • Исправление trimUnsafeCommits для индексов, созданных до версии 6.2. #57187 (проблема: #57091)
SQL
  • Исправление ненужной оценки для CASE/IIF. #57159 (проблема: #49672)
  • JDBC: исправление доступа к манифесту для JAR-ссылок, не являющихся входами. #56797 (проблема: #56759)
  • Исправление шаблона JDBC в документации и сообщении об ошибке. #56612 (проблема: #56476)
  • Исправление сериализации JDBC-предварительного оператора подготовки параметров даты/времени. #56492 (проблема: #56084)
  • Исправление проблемы с запросами диапазона дат и часовым поясом. #56115 (проблема: #56049)
  • Исправление ошибки SubSelect. #55956
Поиск
  • Не запускать оптимизацию сортировки для size=0. #57044 (проблема: #56923)
  • Исправление поведения запроса bool при значении null. #56817 (проблема: #56812)
  • Исправление ошибки вызова слушателя валидации запроса. #56157
  • Асинхронный поиск: корректный подсчет фрагментов. #55758
  • Для constant_keyword, убедитесь, что запрос exists обрабатывает отсутствующие значения. #55757 (проблема: #53545)
  • Исправление (де)сериализации сбоев асинхронного поиска. #55688
  • Исправление времени истечения срока действия в ответе асинхронного поиска. #55435
  • Возвращение true для can_match на неактивных фрагментах поиска. #55428 (проблемы: #27500, #50043)
Снимок/Восстановление
  • Исправление NPE в частичном снимке без глобального состояния. #55776 (проблема: #50234)
  • Исправление приоритета настройки доступа по стилю пути. #55439 (проблема: #55407)

Обновления

Infra/Core
  • Обновление до Jackson 2.10.4. #56188 (проблема: #56071)
Infra/Упаковка
  • Обновление интегрированной JDK до 14.0.1. #57233
SQL
  • Обновление зависимости JLine до 3.14.1. #57111 (проблема: #57076)

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.7.1.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API