Elasticsearch версия 7.8.1
Также см. Изменения, вносящие разрывы в 7.8.
Известные проблемы
-
SQL: Если в
WHERE-запросе содержатся как минимум два реляционных оператора, соединённых черезAND, из которых один является сравнением (<=,<,>=,>), а другой — неравенством (!=,<>), применимыми к литералам или сводимым выражениям, то неравенство будет проигнорировано. Решение — заменить неравенство операторомNOT IN.Мы исправили эту проблему в Elasticsearch 7.10.1 и более поздних версиях. Дополнительные сведения см. в #65488.
- Парсинг запроса, когда последний элемент в массиве отфильтрован (например, с использованием
_source_includes), завершается ошибкой. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456) - Устаревшее значение
index.mapper.dynamicможет нарушить работу кластера. Его можно установить только с помощью API Update index settings. Симптомы включают неспособность узлов запускаться или неспособность фрагментов распределяться. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)
Изменения, вносящие разрывы
- Лицензия
-
- Отображение корпоративной лицензии как платиновой в /_xpack #58217
Новые возможности
Улучшения
- Авторизация
- API функций/индексов
- Машинное обучение
-
- Добавление агрегатора экспоненциального вывода в инференс #58933
- Снимок/восстановление
-
- Разрешение выполнения операций чтения без ожидания полного диапазона записи в кэше #58728 (проблемы: #58164, #58477)
- Позволяет SparseFileTracker последовательно выполнять слушателей во время обработки разрыва #58477 (проблема: #58164)
- Не оборачивать блокировки r/w кэша CacheFile с помощью ReleasableLock #58244 (проблема: #58164)
- Использование информации о снимке для построения метаданных хранилища снимков, допускающего поиск MetadataSnapshot #56289
- Трансформация
Исправления ошибок
- CCR
-
- Обеспечить, чтобы частичные чтения CCR никогда не перерасходовали буфер #58620
- Координация кластера
- Двигатель
- Функции/ILM+SLM
- Функции/API индексов
- Функции/Статистика
-
- Исправить ненужное предупреждение о статистике при отключении свопа #57983
- Гео
- Инфра/Ядро
- Машинное обучение
-
- Разрешить удаление непрогнозируемых/незавершенных прогнозов для остановленных/ошибочных задач #57152 (проблема: #56419)
- Исправить создание псевдонима .ml-stats-write для вывода #58947 (проблема: #58662)
- Исправить состояние гонки при принудительной остановке аналитики фреймов данных #57680
- Обработка неисправного конфигурационного сценария, когда псевдоним состояния является индексом #58999 (проблема: #58482)
- Отметить прогнозы для задач, принудительно закрытых/ошибочных, как ошибочные #57143 (проблема: #56419)
- Улучшенная обработка прерываний во время подключения через именованные каналы #1311
- Ловушка возможной причины SIGFPE #1351 (проблема: #1348)
- Исправить определение модели прогнозирования для моделей регрессии MSLE #1375
- Исправить причину SIGSEGV для классификации и регрессии #1379
- Исправление восстановления детекторов изменений после изменения сезонности #1391
- Исправить потенциальную ошибку SIGSEGV при прогнозировании #1402 (проблема: #1401)
- Сеть
- Percolator
- Восстановление
- SQL
-
- Исправить поведение COUNT(DISTINCT <literal>) #56869
- Исправить ошибку при разрешении псевдонимов относительно фильтров #58399 (проблемы: #57270, #57417)
- Исправить обработку экранированных символов в строке подключения JDBC #58429 (проблема: #57927)
- Обработать функции MIN и MAX для дат в скриптах Painless #57605 (проблема: #57581)
- Поиск
-
- Обеспечить удаление контекстов поиска при удалении индекса #56335
- Фильтр пустых полей в SearchHit#toXContent #58418 (проблема: #41656)
- Исправить запрос exists на неотображаемое поле в query_string #58804 (проблемы: #55785, #58737)
- Исправить обработку terminate_after, когда размер равен 0 #58212 (проблема: #57624)
- Исправить возможную ошибку NPE при сбое фазы поиска #57952 (проблемы: #51708, #57945)
- Обрабатывать сбои без явной причины в асинхронном поиске #58319 (проблемы: #57925, #58311)
- Улучшить обработку ошибок в коде асинхронного поиска #57925 (проблема: #58995)
- Предотвратить ошибки сериализации BigInteger в запросах term #57987 (проблема: #57917)
- Отправлять асинхронный поиск без необходимости привилегий чтения #58942
- Снимок/Восстановление
-
- Исправить некорректный статус совместного использования снимка для фрагментов DONE в выполняемых снимках #58390
- Исправить утечку памяти при переключении мастера во время снимка #58511 (проблема: #56911)
- Исправить ошибку NPE в приложении SnapshotService CS #58680
- Исправить отмену снимка, который не ожидает узлов данных #58214
- Удалить чрезмерно строгие механизмы безопасности в логике снимка фрагмента #57227 (проблема: #57198)
- Управление задачами
- Преобразование
Модернизации
- Инфраструктура/Ядро
-
- Обновить до JNA 5.5.0 #58183
© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.8.1.html