Elasticsearch версия 7.9.2
См. также Изменения, требующие перехода, в версии 7.9.
Известные проблемы
-
SQL: Если в
WHEREзаписи присутствует как минимум два оператора отношений, соединённых черезAND, из которых один является оператором сравнения (<=,<,>=,>), а другой — оператором неравенства (!=,<>), оба из которых применяются к литералам или сжимаемым выражениям, то оператор неравенства будет проигнорирован. Решение — заменить оператор неравенства наNOT INоператор.Мы исправили эту проблему в Elasticsearch 7.10.1 и более поздних версиях. Подробнее см. #65488.
-
Снимок и восстановление: Если индекс удаляется, в то время как кластер одновременно выполняет более одного снимка, существует риск, что один из снимков никогда не завершится, а также что некоторые данные фрагментов могут быть потеряны из репозитория, что приведёт к сбою будущих операций восстановления. Чтобы смягчить эту проблему, установите
snapshot.max_concurrent_operations: 1, чтобы предотвратить одновременные операции создания снимков:PUT _cluster/settings { "persistent" : { "snapshot.max_concurrent_operations" : 1 } }Эта проблема исправлена в версиях Elasticsearch 7.13.1 и более поздних. Повреждённый репозиторий нельзя восстановить, поэтому необходимо восстановить его из резервной копии, очистить репозиторий, выполнив
DELETE _snapshot/<repository name>/*, или перейти к новому репозиторию. Подробнее см. #73456. - Обработка запроса, когда последний элемент в массиве отфильтрован (например, с помощью
_source_includes), завершается ошибкой. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456) - Устаревшее свойство
index.mapper.dynamicможет привести к проблемам в кластере. Его можно установить только с помощью API Обновление настроек индекса. Симптомы включают отказ узлов от запуска или отказ фрагментов от распределения. Не используйте это свойство в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)
Устаревшие элементы
Улучшения
- Картирование
Исправления ошибок
- Агрегации
- Анализ
- Аутентификация
- Авторизация
-
- Обеспечение того, что операции авторизации переопределяют временные заголовки авторизации #61621
- CCR
- EQL
- Движок
- Функции/Потоки данных
-
- Всегда проверять, что в API bulk для потоков данных разрешена только операция создания #62766 (проблема: #62762)
- Исправить исключение NPE при удалении нескольких базовых индексов из потока данных #62274 (проблема: #62272)
- Исправление ошибки разрешения шаблонов потоков данных в API поиска EQL. #61904 (проблема: #60828)
- Запретить использование API создания индекса в пространствах имен, управляемых шаблонами потоков данных #62527
- Функции/ILM+SLM
-
- Исправить условие в шаге ILM, которое не может быть выполнено #62377
- Функции/Обработка
-
- Добавление отсутствующей регистрации NamedWritable для ExecuteEnrichPolicyStatus #62364
- Функции/REST-клиент Java высокого уровня
- Инфраструктура/Упаковка
- Машинное обучение
-
- Добавить проверки на null для обработчика логов C++ #62238
- Сохранить прогресс при установке задачи аналитики фреймов данных в состояние ошибки #61782
- Исправить отчет о пиковом использовании памяти в статистике памяти для аналитики фреймов данных #1468
- Исправить отчет о пиковом использовании памяти в статистике размера модели для обнаружения аномалий #1484
- Картирование
- Сеть
-
- Залогировать описание выделения после установки процессоров netty #62741
- SQL
- Поиск
- Преобразование
Обновления
- Инфраструктура/Упаковка
-
- Обновить встроенную JDK до JDK 15 #62580
© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.9.2.html