Spec-Zone.ru › Elasticsearch 7
›Руководство по Elasticsearch [7.17] ›Примечания к выпуску

Elasticsearch версия 7.9.2

См. также Изменения, требующие перехода, в версии 7.9.

Известные проблемы

  • SQL: Если в WHERE записи присутствует как минимум два оператора отношений, соединённых через AND, из которых один является оператором сравнения (<=, <, >=, >), а другой — оператором неравенства (!=, <>), оба из которых применяются к литералам или сжимаемым выражениям, то оператор неравенства будет проигнорирован. Решение — заменить оператор неравенства на NOT IN оператор.

    Мы исправили эту проблему в Elasticsearch 7.10.1 и более поздних версиях. Подробнее см. #65488.

  • Снимок и восстановление: Если индекс удаляется, в то время как кластер одновременно выполняет более одного снимка, существует риск, что один из снимков никогда не завершится, а также что некоторые данные фрагментов могут быть потеряны из репозитория, что приведёт к сбою будущих операций восстановления. Чтобы смягчить эту проблему, установите snapshot.max_concurrent_operations: 1, чтобы предотвратить одновременные операции создания снимков:

    PUT _cluster/settings
    {
      "persistent" : {
        "snapshot.max_concurrent_operations" : 1
      }
    }

    Эта проблема исправлена в версиях Elasticsearch 7.13.1 и более поздних. Повреждённый репозиторий нельзя восстановить, поэтому необходимо восстановить его из резервной копии, очистить репозиторий, выполнив DELETE _snapshot/<repository name>/*, или перейти к новому репозиторию. Подробнее см. #73456.

  • Обработка запроса, когда последний элемент в массиве отфильтрован (например, с помощью _source_includes), завершается ошибкой. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее свойство index.mapper.dynamic может привести к проблемам в кластере. Его можно установить только с помощью API Обновление настроек индекса. Симптомы включают отказ узлов от запуска или отказ фрагментов от распределения. Не используйте это свойство в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (проблема: #109160)

Устаревшие элементы

Infra/Плагины
  • Устареть xpack.eql.enabled и сделать его бесполезным #61375 (проблема: #54745)

Улучшения

Картирование
  • Улучшение сообщений об ошибках при неверных параметрах [format] и [null_value] для маппера даты #61932 (проблема: #61712)

Исправления ошибок

Агрегации
  • Утечка ресурсов при обработке запросов агрегаций #62685 (проблема: #62439)
  • Исправление ошибки с минимальным количеством документов для терминов #62130 (проблема: #62084)
Анализ
  • Исправление проверки совместимости фильтра standard для поддержки кэширования #62649 (проблемы: #33310, #51092, #62644)
Аутентификация
  • Обеспечение наличия параметра domain_name для AD-домена #61859
  • Обновление заголовков ошибок аутентификации при изменении лицензии #61734 (проблема: #56318)
Авторизация
  • Обеспечение того, что операции авторизации переопределяют временные заголовки авторизации #61621
CCR
  • CCR должен повторно пытаться подключиться при CircuitBreakingException #62013 (проблема: #55633)
EQL
  • Создание запроса поиска со списком индексов #62005 (проблема: #60793)
Движок
  • Разрешить включение мягких удалений при восстановлении из снимка #62018 (проблема: #61969)
Функции/Потоки данных
  • Всегда проверять, что в API bulk для потоков данных разрешена только операция создания #62766 (проблема: #62762)
  • Исправить исключение NPE при удалении нескольких базовых индексов из потока данных #62274 (проблема: #62272)
  • Исправление ошибки разрешения шаблонов потоков данных в API поиска EQL. #61904 (проблема: #60828)
  • Запретить использование API создания индекса в пространствах имен, управляемых шаблонами потоков данных #62527
Функции/ILM+SLM
  • Исправить условие в шаге ILM, которое не может быть выполнено #62377
Функции/Обработка
  • Добавление отсутствующей регистрации NamedWritable для ExecuteEnrichPolicyStatus #62364
Функции/REST-клиент Java высокого уровня
  • Удалить утверждение, что предупреждения ответа REST-клиента соответствуют RFC 7234 #61365 (проблемы: #60889, #61259)
Инфраструктура/Упаковка
  • Проверка версии glibc #62728 (проблема: #62709)
Машинное обучение
  • Добавить проверки на null для обработчика логов C++ #62238
  • Сохранить прогресс при установке задачи аналитики фреймов данных в состояние ошибки #61782
  • Исправить отчет о пиковом использовании памяти в статистике памяти для аналитики фреймов данных #1468
  • Исправить отчет о пиковом использовании памяти в статистике размера модели для обнаружения аномалий #1484
Картирование
  • Разрешить пустые значения null для мапперов полей даты и IP #62487 (проблемы: #57666, #62363)
  • Учитывать разрешение при обработке значения null даты #61994
Сеть
  • Залогировать описание выделения после установки процессоров netty #62741
SQL
  • Не разрешать ссылки на алиасы #62382 (проблема: #62296)
Поиск
  • Исправить отключение allow_leading_wildcard #62300 (проблемы: #60959, #62267)
  • Утечка памяти при поиске #61788
Преобразование
  • Отключить оптимизации при использовании скриптов в group_by #60724 (проблема: #57332)

Обновления

Инфраструктура/Упаковка
  • Обновить встроенную JDK до JDK 15 #62580

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.9.2.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API