Spec-Zone.ru › Elasticsearch 7
›Elasticsearch Руководство [7.17] ›Примечания к релизу

Elasticsearch версия 7.9.3

См. также Разрывающие изменения в 7.9.

Известные проблемы

  • SQL: если в WHERE-оператор входит по меньшей мере два реляционных оператора, соединённых AND, причём один является оператором сравнения (<=, <, >=, >), а другой – оператором неравенства (!=, <>), оба – над литералами или складываемыми выражениями, то оператор неравенства будет проигнорирован. В качестве обходного решения предлагается заменить оператор неравенства оператором NOT IN.

    Мы исправили эту проблему в Elasticsearch 7.10.1 и более поздних версиях. Более подробная информация доступна по адресу #65488.

  • Снимок и восстановление: если индекс удаляется, в то время как кластер одновременно выполняет более одного снимка, существует риск, что один из снимков никогда не завершится, а также что некоторые данные фрагмента потеряются из репозитория, что приведёт к сбою будущих операций восстановления. Для смягчения этой проблемы задайте snapshot.max_concurrent_operations: 1, чтобы предотвратить одновременные операции снимка:

    PUT _cluster/settings
    {
      "persistent" : {
        "snapshot.max_concurrent_operations" : 1
      }
    }

    Эта проблема исправлена в версиях Elasticsearch 7.13.1 и более поздних. Исправить репозиторий, который пострадал от этой проблемы, невозможно, поэтому необходимо восстановить репозиторий из резервной копии или очистить репозиторий, выполнив DELETE _snapshot/<repository name>/*, или перейти к новому репозиторию. Дополнительная информация доступна по адресу #73456.

  • Разбор запроса, когда последний элемент в массиве отфильтрован (например, с использованием _source_includes), завершается сбоем. Это вызвано ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
  • Устаревшее значение index.mapper.dynamic может нарушить работу кластера. Его можно задать только с помощью API Обновления настроек индекса. Симптомы включают сбои в запуске узлов или фрагментов. Не используйте это значение в версиях до 7.17.22. Ошибка исправлена в 7.17.22. (Проблема: #109160)

Исправления ошибок

Распределение
  • InternalClusterInfoService не должен игнорировать скрытые индексы #62995
Аудит
  • Переместить RestRequestFilter в ядро #63507
Аутентификация
  • Обеспечить наличие настройки domain_name для домена AD #61983 (проблема: #61859)
Авторизация
  • Исправить ошибку переписывания дескрипторов ролей API-ключа для обновлённых кластеров #62917 (проблема: #62911)
CCR
  • Повторить задачу следования фрагмента CCR при отсутствии узла-источника #63225
Согласование кластера
  • Уникально связать термин с задачей обновления во время выборов #62212 (проблема: #61437)
EQL
  • Избегать фильтрации по tiebreakers #63215 (проблема: #62781)
  • Исправить ошибку в последовательностях с любым шаблоном #63007 (проблема: #62967)
Двигатель
  • Исправление, фактически ограничивающее индексирование при активации #61768
Функции/Потоки данных
  • Исправить запрос имени потока данных в поле индекса #63170
Функции/Обработка данных
  • Обработка условий ошибки при моделировании конвейеров обработки данных с включённой подробной информацией #63327 (проблема: #63199)
  • Сделать каждый процессор устойчивым к изменению поля #62791 (проблема: #62790)
Машинное обучение
  • Исправить онлайн-обновления с пользовательскими правилами, ссылающимися на фильтры #63057 (проблема: #62948)
  • Сбросить прогресс повторной индексации при возобновлении задачи аналитики кадра данных с неполной повторной индексацией #62772
SQL
  • Исправить исключение при использовании CAST для неточного поля #62943 (проблема: #60178)
Поиск
  • Асинхронный поиск должен повторно пытаться обновить при конфликте версий #63652 (проблема: #63213)
Трансформация
  • Исправить возможную ошибку NPE, если задача трансформации не назначена ни одному узлу #62946 (проблема: #62847)
  • Фильтр пустых объектов из запроса field caps #62945

Обновления

Infra/Упаковка
  • Вернуться к Oracle JDK для комплекта JDK #63288 (проблема: #62709)

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/7.17/release-notes-7.9.3.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API