Spec-Zone.ru › Elasticsearch 8
›Elasticsearch Guide [8.17] ›Устранение неполадок

Решение распространённых проблем кластера

В этом руководстве описано, как устранять распространённые ошибки и проблемы с кластерами Elasticsearch.

Если вы используете Elastic Cloud Hosted, то можете использовать AutoOps для мониторинга вашего кластера. AutoOps значительно упрощает управление кластером с помощью рекомендаций по производительности, визуализации использования ресурсов, обнаружения проблем в реальном времени и путей решения. Для получения дополнительной информации см. Мониторинг с помощью AutoOps.

Ошибки пороговых значений
Устраните ошибки пороговых значений, возникающие, когда у узла данных критически мало места на диске и достигнуто пороговое значение использования диска.
Ошибки разрыва цепи
Elasticsearch использует разрывы цепи для предотвращения исчерпания памяти кучи JVM на узлах. Если Elasticsearch оценивает, что операция превысит предел разрыва цепи, она останавливает операцию и возвращает ошибку.
Высокое использование ЦП
Наиболее распространённые причины высокого использования ЦП и их решения.
Высокое давление памяти JVM
Высокое использование памяти JVM может ухудшить производительность кластера и вызвать ошибки разрыва цепи.
Статус кластера красный или жёлтый
Статус кластера красный или жёлтый указывает на то, что один или несколько фрагментов отсутствуют или не назначены. Эти неназначенные фрагменты увеличивают риск потери данных и могут ухудшить производительность кластера.
Отклоненные запросы
Когда Elasticsearch отклоняет запрос, он останавливает операцию и возвращает ошибку с 429 кодом ответа.
Задержка очереди задач
Задержка очереди задач может препятствовать завершению задач и привести кластер в неустойчивое состояние.
Диагностика неназначенных фрагментов
Существует множество причин, по которым фрагменты могут не быть назначены, от неправильно сконфигурированных параметров распределения до отсутствия места на диске.
Устранение неполадок нестабильного кластера
Кластер, в котором узлы неожиданно покидают его, является нестабильным и может создавать множество проблем.
Взрыв карты
Кластер, в котором индекс или набор индексов взорвался с большим количеством полей карты, что вызывает проблемы с производительностью поиска для Elasticsearch и Kibana.
Горячие точки
Горячие точки могут возникать в Elasticsearch, когда использование ресурсов распределено неравномерно по узлам.

© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/8.17/fix-common-cluster-issues.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API