Elasticsearch версия 8.15.1
Также см. Изменения, требующие перехода в 8.15.
Известные проблемы
- Elasticsearch не будет запускаться, если настройка пользовательских ролевых сопоставлений выполняется с помощью параметра конфигурации
xpack.security.authc.realms.*.files.role_mapping. В качестве обходного решения, пользовательские сопоставления ролей можно настроить с помощью API REST (проблема: #112503) -
Запросы ES|QL могут приводить к сбоям узлов из-за ошибок Out Of Memory, когда:
- Несколько индексов соответствуют шаблону запроса
- У этих индексов много конфликтующих полей сопоставлений
-
Многие из этих полей включены в запрос. Эти проблемы истощают оперативную память, увеличивая вероятность ошибок OOM. (проблема: #111964, #111358). В Kibana такие запросы могут выполняться косвенно при использовании Discover или добавлении панели статистики поля к панели мониторинга.
Для решения этой проблемы у вас есть несколько вариантов:
- Понизить версию до более ранней
- Обновить до 8.15.2 после выпуска
- Следовать инструкциям по отключению запросов ES|QL в Kibana
- Изменить представление данных по умолчанию в Discover на меньший набор индексов и/или индекс с меньшим количеством конфликтов сопоставлений.
-
API Index Stats, Node Stats и Cluster Stats могут возвращать исключение NullPointerException, если индекс содержит поле
dense_vector, но есть сегмент индекса, который не содержит никаких документов с полем плотного вектора (#112720). Способы решения:- Если в затронутом индексе уже есть документы с полем плотного вектора, заставьте индекс слиться в один сегмент.
- Если в затронутом индексе еще нет документов с полем плотного вектора, добавьте документ с полем плотного вектора и затем заставьте слиться в один сегмент.
- Если поля
dense_vectorзатронутого индекса не используются, переиндексируйте без полейdense_vector.
-
Ошибка синтетического источника. Синтетический источник может прервать генерацию _source во время выполнения, что приводит к сбоям в API получения или частичным сбоям в API поиска. В результате _source не может быть получен для затронутых документов. Нет обходных решений, и единственный вариант — обновить до 8.15.2 при выпуске.
Если вы используете синтетический источник, то вы можете быть затронуты этой ошибкой, если выполняется следующее условие: если у вас больше полей, чем позволяет настройка
index.mapping.total_fields.limit. Если вы используете динамические сопоставления, и настройкаindex.mapping.total_fields.ignore_dynamic_beyond_limitвключена.
Исправленные ошибки
- Агрегации
- Авторизация
- ES|QL
- Geo
- API индексов
-
- Исправить блокировку парсинга алиасов шаблонов #112217
- Infra/Core
- Узел Ingest
- Логи
- Машинное обучение
-
- [API вывода] Переместить проверки удаления вывода в поток рабочей зоны #111646
- Сопоставление
-
- Проверка на валидность
parentDocперед получением предыдущего #112005 (проблема: #111990) - Исправление расчета смещения родительского элемента для проигнорированного источника в некоторых случаях #112046
- Исправление синтетического источника для пустых вложенных объектов #111943 (проблема: #111811)
- Отсутствие ошибки, когда
store_array_sourceиспользуется без синтетического источника #111966 - Предотвращение доступа загрузчиков синтетических полей к сохраненным полям из использования устаревших данных #112173 (проблема: #112156)
- Проверка на валидность
- Рейтинг
-
- Правильная обработка фильтров по
TextSimilarityRankретриверу #111673
- Правильная обработка фильтров по
- Релевантность
- Поиск
-
- Объяснение запроса Function Score #111807
- Безопасность
- Поиск векторов
© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/8.17/release-notes-8.15.1.html