Elasticsearch версия 8.4.0
Также см. Изменения, вносящие разрыв в 8.4.
Известные проблемы
-
Данные машинного обучения datafeed не могут быть перечислены, если ни один из них не был изменён с версии 6.x
Если у вас есть datafeed, созданный в версии 5.x или 6.x и не обновлявшийся с 7.0, невозможно перечислить datafeed в 8.4 и 8.5. Это означает, что задания обнаружения аномалий не могут управляться с помощью Kibana. Эта проблема исправлена в 8.6.0.
Если вы переходите на 8.4 или 8.5 с таким datafeed, вам необходимо обойти проблему, обновив информацию об авторизации каждого datafeed с помощью этих шагов.
-
Orchestrator, использующие файл
settings.jsonдля конфигурации Elasticsearch, могут столкнуться с тупиками при выбора мастера (проблема: #92812)Чтобы решить проблему тупика, удалите файл
settings.jsonи перезапустите соответствующий узел. - Обработка запроса, когда последний элемент в массиве отфильтрован (например, с помощью
_source_includes), завершается ошибкой. Это связано с ошибкой в парсере Jackson. Исправлено в Elasticsearch 8.6.1 (#91456)
-
При использовании обработчика вложений ingest, взаимодействие Tika с log4j 2.18.0 и выше (введён в Elasticsearch 8.4.0) приводит к чрезмерному логгированию. Это логгирование настолько чрезмерно, что может привести к нестабильности кластера, вплоть до непригодности кластера к использованию и необходимости перезапуска узлов. (проблема: #91964). Эта проблема решена в Elasticsearch 8.7.0 (#93878)
Чтобы решить проблему, обновитесь до версии 8.7.0 или выше.
Исправленные ошибки
- Агрегации
-
- Исправление обработки многозначных значений в составных агрегациях #88638
- Исправление: извлечение статистических данных матрицы, используя
bucket_selectorbuckets_path#88271 (проблема: #87454) - Сделать метрику в параметре
buckets_pathнеобязательной #87220 (проблема: #72983) - Распространять фильтры псевдонимов на фильтры агрегаций значимости #88221 (проблема: #81585)
- Распределение
-
- Ограничить автоматическое расширение реплик ближайшим значением #87505 (проблема: #84788)
- Предотвратить повторное балансирование с использованием устаревших весов узлов в некоторых случаях #88385 (проблема: #88384)
- Удалить все существующие
read_only_allow_deleteблоки индекса, когдаcluster.routing.allocation.disk.threshold_enabledустановлено вfalse#87841 (проблема: #86383) - Заменить запрос состояния запросом наблюдателя состояния #88641
- Аутентификация
-
- Исправить проверку уникального имени домена, чтобы охватить стандартные домены #87999
- Авторизация
- Автомасштабирование
- Координация кластера
-
- Улучшить отказ от неоднозначного имени конфигурации голосования #89239
- Потоки данных
- Распределённый
-
- Исправлена NullPointerException при запросе массовой обработки #88385
- EQL
- Гео
- Состояние
- Выделение
- ILM+SLM
-
- Пакетное перемещение ILM на задачу обновления шага повторной попытки #86759
- Инфраструктура/CLI
- Инфраструктура/Основное ядро
-
- Всегда закрывать потоки директорий #88560
- Удалять недействительные настройки для системных индексов #88903 (проблема: #88324)
- Запретить трехзначные младшие и ревизионные версии #87338
- Обрабатывать восстановление снимков в настройках файлов #89321 (проблема: #89183)
- Системные индексы игнорируют все шаблоны пользователей #87260 (проблемы: #42508, #74271)
- Инфраструктура/Жизненный цикл узла
-
- Исправить сообщение о приостановленной остановке #89254
- Инфраструктура/Плагины
- Инфраструктура/Скриптинг
-
- Скрипт:
UpdateByQueryможет читать версию документа при запросе #88740
- Скрипт:
- Машинное обучение
-
- Устранение потенциальной ошибки, когда обученные модели застревают на старте после распределения по узлу #88945
- Исправление ошибки токенизации BERT и MPNet при обработке акцентов в юникоде #88907 (проблема: #88900)
- Исправление задачи NLP
question_answering, когда лучший ответ состоит всего из одного токена #88347 - Включение параметров старта в
_statsдля развертывания моделей, не начатых с нуля #89091 - Исправление незначительной ошибки токенизации при использовании задачи fill_mask с токенизатором roberta #88825
- Исправление потенциальной причины сбоев задач классификации и регрессии #2385
- Сопоставление
- Сеть
- SQL
- Поиск
- Безопасность
-
- Обеспечение, что
secureStringостаются открытыми при перезагрузке защитных настроек #88922
- Обеспечение, что
- Снимок/Восстановление
- Преобразование
-
- Правильная обработка ошибки обновления #88619
Устаревшие возможности
- Поиск по векторам
-
- Устаревание конечной точки
_knn_search#88828
- Устаревание конечной точки
Улучшения
- Агрегации
-
- Добавление поддержки кардинальности для
random_sampleragg #86838 - Незначительная
RangeAggоптимизация #86935 (проблема: #84262) - Ускорение подсчета фильтров/диапазонов/агрегаций date_histogram #81322
- Обновление путей агрегаций метрик корзины, чтобы разрешить промежуточные агрегации одной корзины и агрегации с несколькими корзинками, квалифицированные по корзине #85729
- Добавление поддержки кардинальности для
- Распределение
- Аудит
-
- Аудит идентификатора ключа API при создании или предоставлении ключей API #88456
- Включение метаданных ключа API в журнал аудита при создании, предоставлении или обновлении ключа API #88642
- Обновляемые ключи API — регистрация события аудита #88276
- Профиль пользователя — поддержка аудита для домена безопасности #87097
- Аутентификация
-
- Если проверка подписи завершается неудачно, перезагружаются ключи JWK и производится повторная попытка, если новые ключи JWK найдены #88023
- Авторизация
-
- Разрешения приложений с шаблонами действий не извлекают привилегии #85455
- Отменяемая проверка наличия привилегии профиля #87224
- Возврат ошибки «действие запрещено», когда пользователь с недостаточными привилегиями (
manage_own_api_key) пытается запросить ключ API #87461 (проблема: #87438) - Обновление разрешений индексов для учетной записи службы Enterprise Search #88703
- Автомасштабирование
- Координация кластера
-
- Устранение дублирования отображений в сохраненном состоянии кластера #88479
- Отображение подробностей фрагмента в отладочном журнале ПСК #87412
- Периодическое предупреждение для кластера из 1 узла с узлами-семенами #88013 (проблема: #85222)
- Отчет о общем размере отображения в статистике кластера #87556
- Потоки данных
-
- Предоставление отображений только со значениями документов для числовых полей в шаблонах метрик #87100
- Распределённый
- FIPS
- Гео
-
- Оптимизация агрегаций geogrid для одиночных точек #87439
- Поддержка прямоугольной формы с значениями документов #88487
- Использование более быстрого, но менее точного алгоритма логарифмирования для вычисления координаты Geotile Y #87515
- Использование более быстрого математического метода для проекции WGS84 на Меркатор #88231
- Состояние
-
- Добавление действия пользователя состояния для подсчёта сбоев нездоровой политики SLM #88523
- Добавление транспортного действия для получения информации о формировании кластера #87306
- Добавление дополнительных возможностей к сервису индикатора состояния
master_is_stable#87482 - Создание транспортного действия для
CoordinationDiagnosticsService#87984 - Перемещение логики устойчивости мастера в собственную службу, отдельную от
HealthIndicatorService#87672 - Опрос состояния формирования кластера для индикатора состояния «мастер-устойчив» #88397
- Удаление проверки предварительного прогона блокировки кластера из API состояния #87520 (проблема: #87464)
- ILM+SLM
- Инфраструктура/Основное
-
- Улучшение сообщений об ошибках консоли #87942
- Вывод полной ошибки, когда консоль не интерактивна #88297
- Прекращение перевода индекса в состояние только для чтения при выполнении действия управления жизненным циклом индекса force merge #81162 (проблема: #81162)
- Поддержка входного и выходного потоков для необязательных коллекций #88127
- Обновление версии внутреннего http клиента #87491
- Инфраструктура/Логирование
-
- Перехват исключения при ошибке форматирования строки #87132
- Инфраструктура/Скриптинг
- Infra/Настройки
-
- Преобразование порогов использования диска в RelativeByteSizeValues #88719
- Ingest
-
- Разрешение процессору конвейера игнорировать отсутствующие конвейеры #87354
- Перенос процессора вложения ingest в распределение по умолчанию #87989
- Выполнение проверки
ensureNoSelfReferencesво время ingest только при необходимости #87352 (задача: #87335) - Удаление зависимостей
BouncyCastleиз плагина ingest-attachment #88031
- Machine Learning
-
- Добавление информации об авторизации в списки конфигурации ML #87884
- Добавление развернутых собственных моделей в
inference_statsв ответе на информацию о подготовленных моделях #88187 - Добавление количества попаданий в кэш инференции в статистику узла инференции #88807
- Добавление нового параметра
cache_sizeв API развертыванияtrained_model#88450 - Расширение разрешенных меток NER до любых меток с маркировкой I-O-B #87091
- Повышение масштабируемости NLP-моделей #87366
- Указание общего сбоя развертывания, если все маршруты узла завершились ошибкой #88378
- Новая
frequent_itemsагрегация #83055 - Более справедливое применение штрафа за размер при выборе модели для обучения моделей классификации и регрессии #2291
- Ускорение обучения аналитики кадров данных путем пропуска тонкой настройки параметров, если это не нужно #2298
- Решение некоторых причин больших временных затрат при обучении моделей регрессии и классификации на больших наборах данных с множеством признаков #2332
- Добавление кэширования для инференции PyTorch #2305
- Повышение точности оценки медианы обнаружения аномалий #2367 (задача: #2364)
- Mapping
- Мониторинг
-
- Использование SingleObjectCache в JvmService #87236
- Сеть
- Языки запросов
- Rollup
-
- [TSDB] Добавлена поддержка Kahan к суммированию при уменьшении выборки #87554
- SQL
- Поиск
- Безопасность
-
- Добавление настройки для
tcp_keepaliveдля oidc обратного канала #87868 - Поддержка предоставления доступа другому пользователю при выдаче API-ключей #88335
- Поддержка запроса exists для запросов API-ключей #87229
- Обновляемые API-ключи - спецификация REST API и тесты #88270
- Обновляемые API-ключи - проверка noop #88346
- Добавление настройки для
- Снимок/Восстановление
-
- Журналирование INFO о создании снимков и завершении восстановления #88257 (задача: #86610)
- Сделать удаления снимков, не блокирующими репозиторий во время удаления блоков данных #86514
- Повторная попытка после всех сбоев получения из S3, которые дали результат #88015 (задача: #87243)
- Ускорить создание новых
IndexMetaDataGenerationsбез удалённых снимков #88344 - Обновление репозитория HDFS до HDFS 3.3.3 #88039
- Статистика
-
- Сортировка статистики конвейера ingest по использованию #88035
- TLS
-
- Добавление издателя в GET _ssl/certificates #88445
- Преобразование
Новые возможности
- Аутентификация
-
- Поддержка обновлений атрибутов ключа API (маршрут одной операции) #88186
- Здоровье
- Infra/Core
-
- Сервис настроек файлов #88329
- Infra/Ведение журнала
-
- Стабильный API ведения журнала — базовый случай использования #86612
- Машинное обучение
-
- Сделать составные агрегации в потоках данных общедоступными #88589
- Поиск
-
- Добавить параметр mode к полю
_sourceмаппера #88211
- Добавить параметр mode к полю
- TSDB
- Поиск по векторам
Обновления
© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/8.17/release-notes-8.4.0.html