Устранение повторных сбоев политики создания моментальных снимков
Повторные сбои создания моментальных снимков обычно указывают на проблему с вашей развертыванием. Постоянные сбои автоматических моментальных снимков могут оставить развертывание без вариантов восстановления в случае потери данных или сбоев.
Elasticsearch отслеживает количество повторных сбоев при выполнении автоматических моментальных снимков. Если автоматический моментальный снимок терпит неудачу слишком много раз без успешного выполнения, API состояния будет сообщать об предупреждении. Количество повторных сбоев до сообщения об предупреждении контролируется параметром slm.health.failed_snapshot_warn_threshold.
В случае, если выполнение автоматической политики управления жизненным циклом моментальных снимков сталкивается с повторными ошибками, выполните следующие действия, чтобы получить дополнительную информацию о проблеме:
Для проверки состояния политики создания моментальных снимков, которые вызывают сбои, нам необходимо перейти в Kibana и получить информацию о политике жизненного цикла моментальных снимков.
Использование Kibana
- Войдите в консоль Elastic Cloud.
-
В панели Сервис Elasticsearch щелкните имя вашей развертывания.
Если имя вашей развертывания отключено, ваши экземпляры Kibana могут быть неисправными. В этом случае обратитесь за помощью в поддержку Elastic. Если ваше развертывание не включает Kibana, необходимо включить его вначале.
-
Откройте меню боковой навигации развертывания (размещенное под логотипом Elastic в верхнем левом углу) и перейдите к Dev Tools > Console.
-
Получите политику управления жизненным циклом моментальных снимков:
resp = client.slm.get_lifecycle( policy_id="<affected-policy-name>", ) print(resp)const response = await client.slm.getLifecycle({ policy_id: "<affected-policy-name>", }); console.log(response);GET _slm/policy/<affected-policy-name>
Ответ будет выглядеть следующим образом:
{ "affected-policy-name": { "version": 1, "modified_date": "2099-05-06T01:30:00.000Z", "modified_date_millis": 4081757400000, "policy" : { "schedule": "0 30 1 * * ?", "name": "<daily-snap-{now/d}>", "repository": "my_repository", "config": { "indices": ["data-*", "important"], "ignore_unavailable": false, "include_global_state": false }, "retention": { "expire_after": "30d", "min_count": 5, "max_count": 50 } }, "last_success" : { "snapshot_name" : "daily-snap-2099.05.30-tme_ivjqswgkpryvnao2lg", "start_time" : 4083782400000, "time" : 4083782400000 }, "last_failure" : { "snapshot_name" : "daily-snap-2099.06.16-ywe-kgh5rfqfrpnchvsujq", "time" : 4085251200000, "details" : """{"type":"snapshot_exception","reason":"[daily-snap-2099.06.16-ywe-kgh5rfqfrpnchvsujq] failed to create snapshot successfully, 5 out of 149 total shards failed"}""" }, "stats": { "policy": "daily-snapshots", "snapshots_taken": 0, "snapshots_failed": 0, "snapshots_deleted": 0, "snapshot_deletion_failures": 0 }, "next_execution": "2099-06-17T01:30:00.000Z", "next_execution_millis": 4085343000000 } }Затронутая политика жизненного цикла моментального снимка.
Информация о последнем сбое для политики.
Время наступления сбоя в миллисекундах. Используйте параметр запроса
human=trueдля просмотра отформатированного временного отметки.Подробности ошибки, содержащие причину сбоя создания моментального снимка.
Моментальные снимки могут не удаваться по различным причинам. Если сбои связаны с ошибками конфигурации, обратитесь к документации репозитория, используемого автоматическими моментальными снимками. Обратитесь к руководству по управлению репозиториями в ECE, если вы используете такую развертывание.
Один из распространенных сценариев сбоев - это повреждение репозитория. Это чаще всего происходит, когда несколько экземпляров Elasticsearch записывают в одно и то же место репозитория. Есть отдельное руководство по устранению неполадок для решения этой проблемы.
В случае, если сбои моментальных снимков происходят по другим причинам, проверьте журналы на избранном узле-мастере в период выполнения создания моментального снимка для получения дополнительной информации.
Получите политику управления жизненным циклом моментальных снимков:
resp = client.slm.get_lifecycle(
policy_id="<affected-policy-name>",
)
print(resp) const response = await client.slm.getLifecycle({
policy_id: "<affected-policy-name>",
});
console.log(response); GET _slm/policy/<affected-policy-name>
Ответ будет выглядеть следующим образом:
{
"affected-policy-name": {
"version": 1,
"modified_date": "2099-05-06T01:30:00.000Z",
"modified_date_millis": 4081757400000,
"policy" : {
"schedule": "0 30 1 * * ?",
"name": "<daily-snap-{now/d}>",
"repository": "my_repository",
"config": {
"indices": ["data-*", "important"],
"ignore_unavailable": false,
"include_global_state": false
},
"retention": {
"expire_after": "30d",
"min_count": 5,
"max_count": 50
}
},
"last_success" : {
"snapshot_name" : "daily-snap-2099.05.30-tme_ivjqswgkpryvnao2lg",
"start_time" : 4083782400000,
"time" : 4083782400000
},
"last_failure" : {
"snapshot_name" : "daily-snap-2099.06.16-ywe-kgh5rfqfrpnchvsujq",
"time" : 4085251200000,
"details" : """{"type":"snapshot_exception","reason":"[daily-snap-2099.06.16-ywe-kgh5rfqfrpnchvsujq] failed to create snapshot successfully, 5 out of 149 total shards failed"}"""
},
"stats": {
"policy": "daily-snapshots",
"snapshots_taken": 0,
"snapshots_failed": 0,
"snapshots_deleted": 0,
"snapshot_deletion_failures": 0
},
"next_execution": "2099-06-17T01:30:00.000Z",
"next_execution_millis": 4085343000000
}
} | Затронутая политика жизненного цикла моментального снимка. | |
| Информация о последнем сбое для политики. | |
| Время наступления сбоя в миллисекундах. Используйте параметр запроса | |
| Подробности ошибки, содержащие причину сбоя создания моментального снимка. |
Моментальные снимки могут не удаваться по различным причинам. Если сбои связаны с ошибками конфигурации, обратитесь к документации репозитория, используемого автоматическими моментальными снимками.
Один из распространенных сценариев сбоев - это повреждение репозитория. Это чаще всего происходит, когда несколько экземпляров Elasticsearch записывают в одно и то же место репозитория. Есть отдельное руководство по устранению неполадок для решения этой проблемы.
В случае, если сбои моментальных снимков происходят по другим причинам, проверьте журналы на избранном узле-мастере в период выполнения создания моментального снимка для получения дополнительной информации.
© 2023-2025 Elasticsearch
As of September 2024, Elasticsearch is available under a choice of three licenses: the Server Side Public License (SSPL), the Elastic License, or the AGPLv3 (OSI approved).
Elasticsearch and the Elasticsearch logo are trademarks of Elasticsearch B.V., registered in the U.S. and in other countries.
https://www.elastic.co/guide/en/elasticsearch/reference/8.17/repeated-snapshot-failures.html