Пакет mime
Обзор
Пакет mime реализует части спецификации MIME.
Индекс
Примеры
Файлы пакета
encodedword.go grammar.go mediatype.go type.go type_unix.go
Константы
const (
// BEncoding represents Base64 encoding scheme as defined by RFC 2045.
BEncoding = WordEncoder('b')
// QEncoding represents the Q-encoding scheme as defined by RFC 2047.
QEncoding = WordEncoder('q')
) Переменные
ErrInvalidMediaParameter возвращается функцией ParseMediaType, если значение типа медиа было найдено, но произошла ошибка при синтаксическом анализе необязательных параметров
var ErrInvalidMediaParameter = errors.New("mime: invalid media parameter") func AddExtensionType
func AddExtensionType(ext, typ string) error
AddExtensionType связывает MIME-тип typ с расширением ext. Расширение должно начинаться с точки, например, ".html".
func ExtensionsByType 1.5
func ExtensionsByType(typ string) ([]string, error)
ExtensionsByType возвращает расширения, связанные с MIME-типом typ. Каждое возвращаемое расширение начинается с точки, например, ".html". Если с typ не связано ни одного расширения, ExtensionsByType возвращает срез nil.
Встроенная таблица невелика, но в unix она дополняется базой данных MIME-info локальной системы или файлом(ами) mime.types, если они доступны под одним или несколькими из следующих имен:
/usr/local/share/mime/globs2 /usr/share/mime/globs2 /etc/mime.types /etc/apache2/mime.types /etc/apache/mime.types /etc/httpd/conf/mime.types
В Windows расширения извлекаются из реестра.
func FormatMediaType
func FormatMediaType(t string, param map[string]string) string
FormatMediaType сериализует тип медиа t и параметры param в тип медиа, соответствующий RFC 2045 и RFC 2616. Имена типов и параметров записываются в нижнем регистре. Если какой-либо из аргументов приводит к нарушению стандарта, FormatMediaType возвращает пустую строку.
Пример
Код:
mediatype := "text/html"
params := map[string]string{
"charset": "utf-8",
}
result := mime.FormatMediaType(mediatype, params)
fmt.Println("result:", result)
Вывод:
result: text/html; charset=utf-8
func ParseMediaType
func ParseMediaType(v string) (mediatype string, params map[string]string, err error)
ParseMediaType разбирает значение типа медиа и любые необязательные параметры согласно RFC 1521. Типы медиа — это значения в заголовках Content-Type и Content-Disposition (RFC 2183). В случае успеха ParseMediaType возвращает тип медиа, приведенный к нижнему регистру и очищенный от пробелов, а также ненулевое отображение map. Если при разборе необязательного параметра возникает ошибка, тип медиа возвращается вместе с ошибкой ErrInvalidMediaParameter. Возвращаемая карта params сопоставляет атрибуты в нижнем регистре со значениями атрибутов с сохранением их регистра.
Пример
Код:
mediatype, params, err := mime.ParseMediaType("text/html; charset=utf-8")
if err != nil {
panic(err)
}
fmt.Println("type:", mediatype)
fmt.Println("charset:", params["charset"])
Вывод:
type: text/html charset: utf-8
func TypeByExtension
func TypeByExtension(ext string) string
TypeByExtension возвращает MIME-тип, связанный с расширением файла ext. Расширение ext должно начинаться с точки, например, ".html". Если с ext не связан ни один тип, TypeByExtension возвращает "".
Поиск расширений сначала выполняется с учетом регистра, затем — без учета регистра.
Встроенная таблица невелика, но в unix она дополняется базой данных MIME-info локальной системы или файлом(ами) mime.types, если они доступны под одним или несколькими из следующих имен:
/usr/local/share/mime/globs2 /usr/share/mime/globs2 /etc/mime.types /etc/apache2/mime.types /etc/apache/mime.types /etc/httpd/conf/mime.types
В Windows MIME-типы извлекаются из реестра.
Для текстовых типов по умолчанию установлен параметр charset со значением "utf-8".
type WordDecoder 1.5
WordDecoder декодирует MIME-заголовки, содержащие закодированные слова (encoded-words) по стандарту RFC 2047.
type WordDecoder struct {
// CharsetReader, if non-nil, defines a function to generate
// charset-conversion readers, converting from the provided
// charset into UTF-8.
// Charsets are always lower-case. utf-8, iso-8859-1 and us-ascii charsets
// are handled by default.
// One of the CharsetReader's result values must be non-nil.
CharsetReader func(charset string, input io.Reader) (io.Reader, error)
}
func (*WordDecoder) Decode 1.5
func (d *WordDecoder) Decode(word string) (string, error)
Decode декодирует закодированное слово (encoded-word) по стандарту RFC 2047.
Пример
Код:
dec := new(mime.WordDecoder)
header, err := dec.Decode("=?utf-8?q?=C2=A1Hola,_se=C3=B1or!?=")
if err != nil {
panic(err)
}
fmt.Println(header)
dec.CharsetReader = func(charset string, input io.Reader) (io.Reader, error) {
switch charset {
case "x-case":
// Fake character set for example.
// Real use would integrate with packages such
// as code.google.com/p/go-charset
content, err := io.ReadAll(input)
if err != nil {
return nil, err
}
return bytes.NewReader(bytes.ToUpper(content)), nil
default:
return nil, fmt.Errorf("unhandled charset %q", charset)
}
}
header, err = dec.Decode("=?x-case?q?hello!?=")
if err != nil {
panic(err)
}
fmt.Println(header)
Вывод:
¡Hola, señor! HELLO!
func (*WordDecoder) DecodeHeader 1.5
func (d *WordDecoder) DecodeHeader(header string) (string, error)
DecodeHeader декодирует все закодированные слова (encoded-words) заданной строки. Метод возвращает ошибку тогда и только тогда, когда WordDecoder.CharsetReader объекта d возвращает ошибку.
Пример
Код:
dec := new(mime.WordDecoder)
header, err := dec.DecodeHeader("=?utf-8?q?=C3=89ric?= <eric@example.org>, =?utf-8?q?Ana=C3=AFs?= <anais@example.org>")
if err != nil {
panic(err)
}
fmt.Println(header)
header, err = dec.DecodeHeader("=?utf-8?q?=C2=A1Hola,?= =?utf-8?q?_se=C3=B1or!?=")
if err != nil {
panic(err)
}
fmt.Println(header)
dec.CharsetReader = func(charset string, input io.Reader) (io.Reader, error) {
switch charset {
case "x-case":
// Fake character set for example.
// Real use would integrate with packages such
// as code.google.com/p/go-charset
content, err := io.ReadAll(input)
if err != nil {
return nil, err
}
return bytes.NewReader(bytes.ToUpper(content)), nil
default:
return nil, fmt.Errorf("unhandled charset %q", charset)
}
}
header, err = dec.DecodeHeader("=?x-case?q?hello_?= =?x-case?q?world!?=")
if err != nil {
panic(err)
}
fmt.Println(header)
Вывод:
Éric <eric@example.org>, Anaïs <anais@example.org> ¡Hola, señor! HELLO WORLD!
type WordEncoder 1.5
WordEncoder представляет собой кодировщик закодированных слов (encoded-words) по стандарту RFC 2047.
type WordEncoder byte
func (WordEncoder) Encode 1.5
func (e WordEncoder) Encode(charset, s string) string
Encode возвращает строку s в формате закодированного слова (encoded-word). Если s состоит из символов ASCII без специальных символов, она возвращается без изменений. Переданный charset представляет собой имя кодировки s согласно IANA. Регистр не учитывается.
Пример
Код:
fmt.Println(mime.QEncoding.Encode("utf-8", "¡Hola, señor!"))
fmt.Println(mime.QEncoding.Encode("utf-8", "Hello!"))
fmt.Println(mime.BEncoding.Encode("UTF-8", "¡Hola, señor!"))
fmt.Println(mime.QEncoding.Encode("ISO-8859-1", "Caf\xE9"))
Вывод:
=?utf-8?q?=C2=A1Hola,_se=C3=B1or!?= Hello! =?UTF-8?b?wqFIb2xhLCBzZcOxb3Ih?= =?ISO-8859-1?q?Caf=E9?=
Поддиректории
| Имя | Краткое описание |
|---|---|
| .. | |
| multipart | Пакет multipart реализует синтаксический анализ multipart MIME, как определено в RFC 2046. |
| quotedprintable | Пакет quotedprintable реализует кодирование quoted-printable в соответствии со спецификацией RFC 2045. |
© Google, Inc.
Licensed under the Creative Commons Attribution License 3.0.
http://golang.org/pkg/mime/