Spec-Zone.ru › HTTP

Ресурсы и спецификации

Ресурсы и спецификации HTTP

HTTP впервые был специфицирован в начале 1990-х годов. Изначально разработанный с расчётом на расширяемость, он за прошедшие годы получил множество дополнений; в результате его спецификация оказалась распределена по многочисленным документам (среди которых есть экспериментальные заброшенные расширения). На этой странице перечислены полезные ресурсы по HTTP.

Спецификация Название Статус
RFC 9110 Семантика HTTP Интернет-стандарт
RFC 9111 Кэширование HTTP Интернет-стандарт
RFC 9112 HTTP/1.1 Интернет-стандарт
RFC 9113 HTTP/2 Предлагаемый стандарт
RFC 9114 HTTP/3 Предлагаемый стандарт
RFC 5861 Расширения Cache-Control для устаревшего содержимого HTTP Информационный документ
RFC 8246 Неизменяемые ответы HTTP Предлагаемый стандарт
RFC 6265 Механизм управления состоянием HTTP Определяет файлы cookie Предлагаемый стандарт
Проект спецификации Префиксы файлов cookie Проект IETF
Проект спецификации Файлы cookie с атрибутом Same-Site Проект IETF
Проект спецификации Отказ от изменения защищённых файлов cookie из небезопасных источников Проект IETF
RFC 2145 Использование и интерпретация номеров версий HTTP Информационный документ
RFC 6585 Дополнительные коды состояния HTTP Предлагаемый стандарт
RFC 7725 Код состояния HTTP для сообщения о юридических препятствиях На пути к стандарту
RFC 2397 Схема URL «data» Предлагаемый стандарт
RFC 3986 Унифицированный идентификатор ресурса (URI): общий синтаксис Интернет-стандарт
RFC 5988 Связывание в Web Определяет заголовок Link Предлагаемый стандарт
Проект спецификации Client Hints HTTP Проект IETF
RFC 7578 Передача значений из форм: multipart/form-data Предлагаемый стандарт
RFC 6266 Использование поля заголовка Content-Disposition в протоколе передачи гипертекста (HTTP) Предлагаемый стандарт
RFC 2183 Передача сведений о представлении в интернет-сообщениях: поле заголовка Content-Disposition В контексте сообщений HTTP можно использовать только часть синтаксиса заголовка Content-Disposition. Предлагаемый стандарт
RFC 7239 Расширение Forwarded для HTTP Предлагаемый стандарт
RFC 6455 Протокол WebSocket Предлагаемый стандарт
RFC 5246 Версия 1.2 протокола защиты транспортного уровня (TLS) Эта спецификация была изменена последующими RFC, однако эти изменения не влияют на протокол HTTP. Предлагаемый стандарт
RFC 8446 Версия 1.3 протокола защиты транспортного уровня (TLS) Заменяет TLS 1.2. Предлагаемый стандарт
RFC 2817 Переход на TLS в HTTP/1.1 Предлагаемый стандарт
RFC 7541 HPACK: сжатие заголовков для HTTP/2 На пути к стандарту
RFC 7838 Альтернативные службы HTTP На пути к стандарту
RFC 7301 Расширение согласования протокола прикладного уровня для протокола защиты транспортного уровня (TLS) Используется для согласования HTTP/2 на транспортном уровне, чтобы избежать дополнительного цикла запроса и ответа. Предлагаемый стандарт
RFC 6454 Понятие источника Web Предлагаемый стандарт
Fetch Совместное использование ресурсов между источниками Действующий стандарт
RFC 7034 Поле заголовка HTTP X-Frame-Options Информационный документ
RFC 6797 Строгая транспортная безопасность HTTP (HSTS) Предлагаемый стандарт
Upgrade Insecure Requests Перевод небезопасных запросов на защищённые Кандидат в рекомендации
Спецификация Content Security Policy Content Security Policy, уровень 3 Устаревшая
Документ Microsoft Указание режимов устаревших документов* Определяет X-UA-Compatible Примечание
RFC 5689 Расширения HTTP для распределённого создания и управления версиями в Web (WebDAV) Эти расширения Web, а также CardDAV и CalDAV, не входят в область применения HTTP в Web. В настоящее время современные API приложений определяются с использованием REST-подхода. Предлагаемый стандарт
RFC 2324 Протокол управления кофейником через гипертекст (HTCPCP/1.0) Шуточная спецификация, опубликованная 1 апреля
RFC 7168 Протокол управления устройствами для заваривания чая через гипертекст (HTCPCP-TEA) Шуточная спецификация, опубликованная 1 апреля
Действующий стандарт HTML HTML Определяет расширения HTTP для событий, отправляемых сервером Действующий стандарт
Reporting API Заголовок Report-To Проект
Проект спецификации Расширение Expect-CT для HTTP Проект IETF
RFC 7486 Аутентификация HTTP с привязкой к источнику (HOBA) Экспериментальный документ
RFC 7240 Заголовок Prefer для HTTP Предлагаемый стандарт

См. также

  • Эволюция HTTP
  • Термины глоссария:
    • HTTP
    • HTTP/2
    • QUIC
    • Протокол управления передачей (TCP)

© 2005–2025 MDN contributors.
Licensed under the Creative Commons Attribution-ShareAlike License v2.5 or later.
https://developer.mozilla.org/en-US/docs/Web/HTTP/Reference/Resources_and_specifications

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API