MariaDB для DirectAdmin с использованием RPM
Если вы используете DirectAdmin и столкнулись с проблемами при установке MariaDB с помощью YUM, то приведенные ниже инструкции могут помочь. Процесс очень простой.
Примечание: Установка с помощью YUM предпочтительнее ручного использования пакетов MariaDB RPM, поэтому делайте это только в случае проблем, таких как:
Starting httpd:
httpd:
Syntax error on line 18 of /etc/httpd/conf/httpd.conf:
Syntax error on line 1 of /etc/httpd/conf/extra/httpd-phpmodules.conf:
Cannot load /usr/lib/apache/libphp5.so into server:
libmysqlclient.so.18: cannot open shared object file: No such file or directory
Или:
Starting httpd:
httpd:
Syntax error on line 18 of /etc/httpd/conf/httpd.conf:
Syntax error on line 1 of /etc/httpd/conf/extra/httpd-phpmodules.conf:
Cannot load /usr/lib/apache/libphp5.so into server:
/usr/lib/apache/libphp5.so: undefined symbol: client_errors
Установка RPM
Для установки RPM есть быстрый и простой гид по установке MariaDB с помощью инструмента RPM. Следуйте инструкциям там.
Необходимые изменения
Мы не хотим, чтобы настраиваемый сборщик DirectAdmin удалял/перезаписывал нашу установку MariaDB при каждом обновлении. Для исправления этого отключите автоматическую установку MySQL.
Отредактируйте /usr/local/directadmin/custombuild/options.conf
Измените:
mysql_inst=yes
На:
mysql_inst=no
Примечание: Когда MariaDB устанавливается вручную (то есть не с помощью YUM), обновления не происходят автоматически. Вам потребуется обновить RPM-пакеты самостоятельно.
© 2023 MariaDB
Licensed under the Creative Commons Attribution 3.0 Unported License and the GNU Free Documentation License.
https://mariadb.com/kb/en/mariadb-for-directadmin-using-rpms/