Запуск mysqld от имени root
MariaDB обычно не следует запускать от имени системного пользователя root (это не относится к пользователю MariaDB root). Если это делается, любой пользователь с правом FILE может создавать или изменять любые файлы на сервере от имени root.
MariaDB обычно возвращает ошибку Критическая ошибка: Пожалуйста, прочитайте раздел "Безопасность" руководства, чтобы узнать, как запустить mysqld от имени root!, если вы попытаетесь запустить mysqld от имени root. Если по какой-то причине вам нужно обойти это ограничение, запустите mysqld с параметром user=root.
Лучшая практика, и стандартное поведение в большинстве случаев, – использовать отдельного пользователя, предназначенного исключительно для MariaDB. В большинстве дистрибутивов этот пользователь называется mysql.
© 2023 MariaDB
Licensed under the Creative Commons Attribution 3.0 Unported License and the GNU Free Documentation License.
https://mariadb.com/kb/en/running-mysqld-as-root/