Spec-Zone.ru › MySQL 5.7

16.2.2.3 Параметры запуска и каналы репликации

В этом разделе описаны параметры запуска, которые зависят от добавления каналов репликации.

Для использования репликации из нескольких источников необходимо правильно настроить следующие параметры запуска.

  • relay_log_info_repository.

    Это значение должно быть установлено в TABLE. Если эта переменная установлена в FILE, попытка добавления дополнительных источников к реплике завершится ошибкой.

  • master_info_repository

    Это значение должно быть установлено в TABLE. Если эта переменная установлена в FILE, попытка добавления дополнительных источников к реплике завершится ошибкой.

Следующие параметры запуска теперь влияют на все каналы в топологии репликации.

  • --log-slave-updates

    Все транзакции, полученные репликой (даже из нескольких источников), записываются в бинарный журнал.

  • --relay-log-purge

    При установке, каждый канал автоматически очищает свой собственный журнал репликации.

  • --slave_transaction_retries

    Потоки-приемники всех каналов повторно пытаются выполнить транзакции.

  • --skip-slave-start

    Ни один поток репликации не запускается ни в одном канале.

  • --slave-skip-errors

    Выполнение продолжается, и ошибки пропускаются для всех каналов.

Значения, заданные для следующих параметров запуска, применяются к каждому каналу; поскольку это параметры запуска mysqld, они применяются к каждому каналу.

  • --max-relay-log-size=size

    Максимальный размер отдельного файла журнала репликации для каждого канала; после достижения этого предела файл переименовывается.

  • --relay-log-space-limit=size

    Верхний предел для общего размера всех журналов репликации вместе, для каждого отдельного канала. Для N каналов общий размер этих журналов ограничен значением relay_log_space_limit * N.

  • --slave-parallel-workers=value

    Количество рабочих потоков на канал.

  • slave_checkpoint_group

    Время ожидания потока ввода-вывода для каждого источника.

  • --relay-log-index=filename

    Базовое имя файла индекса журнала репликации каждого канала. См. Раздел 16.2.2.4, «Правила именования каналов репликации».

  • --relay-log=filename

    Указывает базовое имя файла журнала репликации каждого канала. См. Раздел 16.2.2.4, «Правила именования каналов репликации».

  • --slave_net-timeout=N

    Это значение устанавливается для каждого канала, так что каждый канал ожидает N секунд, чтобы проверить разрыв соединения.

  • --slave-skip-counter=N

    Это значение устанавливается для каждого канала, так что каждый канал пропускает N событий от своего источника.

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-5.7-en/channels-startup-options.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API