16.2.2.3 Параметры запуска и каналы репликации
В этом разделе описаны параметры запуска, которые зависят от добавления каналов репликации.
Для использования репликации из нескольких источников необходимо правильно настроить следующие параметры запуска.
-
Это значение должно быть установлено в
TABLE. Если эта переменная установлена вFILE, попытка добавления дополнительных источников к реплике завершится ошибкой. -
Это значение должно быть установлено в
TABLE. Если эта переменная установлена вFILE, попытка добавления дополнительных источников к реплике завершится ошибкой.
Следующие параметры запуска теперь влияют на все каналы в топологии репликации.
-
Все транзакции, полученные репликой (даже из нескольких источников), записываются в бинарный журнал.
-
При установке, каждый канал автоматически очищает свой собственный журнал репликации.
-
Потоки-приемники всех каналов повторно пытаются выполнить транзакции.
-
Ни один поток репликации не запускается ни в одном канале.
-
Выполнение продолжается, и ошибки пропускаются для всех каналов.
Значения, заданные для следующих параметров запуска, применяются к каждому каналу; поскольку это параметры запуска mysqld, они применяются к каждому каналу.
-
--max-relay-log-size=sizeМаксимальный размер отдельного файла журнала репликации для каждого канала; после достижения этого предела файл переименовывается.
-
--relay-log-space-limit=sizeВерхний предел для общего размера всех журналов репликации вместе, для каждого отдельного канала. Для
Nканалов общий размер этих журналов ограничен значениемrelay_log_space_limit *.N -
--slave-parallel-workers=valueКоличество рабочих потоков на канал.
-
Время ожидания потока ввода-вывода для каждого источника.
-
--relay-log-index=filenameБазовое имя файла индекса журнала репликации каждого канала. См. Раздел 16.2.2.4, «Правила именования каналов репликации».
-
--relay-log=filenameУказывает базовое имя файла журнала репликации каждого канала. См. Раздел 16.2.2.4, «Правила именования каналов репликации».
-
--slave_net-timeout=NЭто значение устанавливается для каждого канала, так что каждый канал ожидает
Nсекунд, чтобы проверить разрыв соединения. -
--slave-skip-counter=NЭто значение устанавливается для каждого канала, так что каждый канал пропускает
Nсобытий от своего источника.
© 2025 Oracle
Licensed under the GPLv2 License.