17.2.1.4 Запуск Group Replication
Сначала необходимо убедиться, что плагин Group Replication установлен на сервере s1. Если вы использовали plugin_load_add='group_replication.so' в файле опций, то плагин Group Replication уже установлен, и вы можете перейти к следующему шагу. В противном случае, вы должны установить плагин вручную; для этого подключитесь к серверу с помощью клиента mysql и выполните представленное ниже SQL-команду:
mysql> INSTALL PLUGIN group_replication SONAME 'group_replication.so';
Пользователь mysql.session должен существовать, прежде чем вы сможете загрузить Group Replication. mysql.session был добавлен в MySQL версии 5.7.19. Если ваш словарь данных был инициализирован с использованием более ранней версии, вы должны выполнить процедуру обновления MySQL (см. Раздел 2.10, «Обновление MySQL»). Если обновление не выполнено, Group Replication не запускается с сообщением об ошибке Произошла ошибка при попытке доступа к серверу с пользователем: mysql.session@localhost. Убедитесь, что пользователь присутствует на сервере и что mysql_upgrade был запущен после обновления сервера.
Чтобы проверить, что плагин был успешно установлен, выполните SHOW PLUGINS; и проверьте вывод. Он должен показать что-то вроде этого:
mysql> SHOW PLUGINS;
+----------------------------+----------+--------------------+----------------------+-------------+
| Name | Status | Type | Library | License |
+----------------------------+----------+--------------------+----------------------+-------------+
| binlog | ACTIVE | STORAGE ENGINE | NULL | PROPRIETARY |
(...)
| group_replication | ACTIVE | GROUP REPLICATION | group_replication.so | PROPRIETARY |
+----------------------------+----------+--------------------+----------------------+-------------+
© 2025 Oracle
Licensed under the GPLv2 License.