Spec-Zone.ru › MySQL 5.7

5.8.1.2 Создание файлов трассировки

Если сервер mysqld не запускается или часто терпит сбои, можно попробовать создать файл трассировки, чтобы найти проблему.

Для этого нужен сервер mysqld, скомпилированный с поддержкой отладки. Проверить это можно, выполнив mysqld -V. Если номер версии заканчивается на -debug, он скомпилирован с поддержкой файлов трассировки. (В Windows отладочный сервер называется mysqld-debug, а не mysqld.)

Запустите сервер mysqld с журналом трассировки в /tmp/mysqld.trace на Unix или \mysqld.trace на Windows:

$> mysqld --debug

В Windows также следует использовать флаг --standalone, чтобы mysqld не запускался как служба. В консольном окне используйте эту команду:

C:\> mysqld-debug --debug --standalone

После этого можно использовать инструмент командной строки mysql.exe во втором консольном окне, чтобы воспроизвести проблему. Сервер mysqld можно остановить с помощью mysqladmin shutdown.

Файл трассировки может стать очень большим! Для создания более компактного файла трассировки можно использовать параметры отладки, например:

mysqld --debug=d,info,error,query,general,where:O,/tmp/mysqld.trace

Это выведет в файл трассировки только информацию с наиболее интересными тегами.

Если вы подаёте ошибку, пожалуйста, добавьте в отчёт об ошибке только те строки из файла трассировки, которые указывают, где что-то, кажется, идет не так. Если вы не можете определить место ошибки, откройте отчёт об ошибке и загрузите в него весь файл трассировки, чтобы разработчик MySQL смог на него взглянуть. Инструкции см. в разделе 1.5, «Как сообщать об ошибках или проблемах».

Файл трассировки создан с помощью пакета DBUG Фреда Фиша. См. раздел 5.8.3, «Пакет DBUG».

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-5.7-en/making-trace-files.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API