21.6.2.1 NDB Кластер: Сообщения в журнале кластера
В следующей таблице перечислены наиболее распространённые сообщения журнала кластера. NDB Для получения информации о журнале кластера, событиях журнала и типах событий, см. Раздел 21.6.3, “Отчёты о событиях, генерируемые в NDB кластере”. Эти сообщения журнала также соответствуют типам событий журнала в API MGM; см. для получения связанной информации, представляющей интерес для разработчиков API кластера.
Таблица 21.47 Общие сообщения журнала NDB кластера
Таблица 21.47 Общие сообщения журнала NDB кластера
Сообщение журнала
Описание
Имя события
Тип события
Приоритет
Степень серьёзности
Node mgm_node_id: Node
data_node_id
Connected
Узел данных с идентификатором узла node_id подключился к серверу управления (узел mgm_node_id).
Connected
Connection
8
INFO
Node mgm_node_id: Node
data_node_id
Disconnected
Узел данных с идентификатором узла data_node_id отключился от сервера управления (узел mgm_node_id).
Disconnected
Connection
8
ALERT
Node data_node_id: Communication to
Node api_node_id
closed
Узел API или SQL с идентификатором узла api_node_id больше не общается с узлом данных data_node_id.
CommunicationClosed
Connection
8
INFO
Node data_node_id: Communication to
Node api_node_id
opened
Узел API или SQL с идентификатором узла api_node_id теперь общается с узлом данных data_node_id.
CommunicationOpened
Connection
8
INFO
Node mgm_node_id: Node
api_node_id: API
version
Узел API с идентификатором узла api_node_id подключился к управляющему узлу mgm_node_id, используя API-версию NDBversion (как правило, совпадающую с номером версии MySQL).
ConnectedApiVersion
Connection
8
INFO
Node node_id: Global checkpoint
gci started
Запущен глобальный контрольный пункт с идентификатором gci; узел node_id является мастером, ответственным за этот глобальный контрольный пункт.
GlobalCheckpointStarted
Checkpoint
9
INFO
Node node_id: Global checkpoint
gci completed
Завершён глобальный контрольный пункт с идентификатором gci; узел node_id был мастером, ответственным за этот глобальный контрольный пункт.
Запущен локальный контрольный пункт с последовательным идентификатором lcp на узле node_id. Самый недавний доступный GCI имеет индекс current_gci, а самый старый GCI, из которого можно восстановить кластер, имеет индекс old_gci.
LocalCheckpointStarted
Checkpoint
7
INFO
Node node_id: Local checkpoint
lcp completed
Завершён локальный контрольный пункт с последовательным идентификатором lcp на узле node_id.
LocalCheckpointCompleted
Checkpoint
8
INFO
Node node_id: Local Checkpoint
stopped in CALCULATED_KEEP_GCI
Узел не смог определить самый недавний доступный GCI.
LCPStoppedInCalcKeepGci
Checkpoint
0
ALERT
Node node_id: Table ID =
table_id, fragment
ID = fragment_id has completed
LCP on Node node_id
maxGciStarted: started_gci
maxGciCompleted:
completed_gci
Фрагмент таблицы был зафиксирован на диск на узле node_id. Процесс GCI имеет индекс started_gci, а самый недавний завершенный GCI имеет индекс completed_gci.
LCPFragmentCompleted
Checkpoint
11
INFO
Node node_id: ACC Blocked
num_1 and TUP Blocked
num_2 times last
second
Обработка отката заблокирована, так как буфер журнала близок к переполнению.
UndoLogBlocked
Checkpoint
7
INFO
Node node_id: Start initiated
version
Узел данных node_id, работающий под версией NDBversion, начинает процесс запуска.
NDBStartStarted
StartUp
1
INFO
Node node_id: Started
version
Узел данных node_id, работающий под версией NDBversion, успешно запущен.
NDBStartCompleted
StartUp
1
INFO
Node node_id: STTORRY received after
restart finished
Узел получил сигнал о завершении перезапуска кластера.
STTORRYRecieved
StartUp
15
INFO
Node node_id: Start phase
phase completed
(type)
Узел завершил фазу запуска phase запуска type. Список фаз запуска см. в Разделе 21.6.4, «Обзор фаз запуска NDB Cluster». (type — одно из initial, system, node, initial node или <Unknown>.)
StartPhaseCompleted
StartUp
4
INFO
Node node_id: CM_REGCONF president =
president_id, own Node =
own_id, our dynamic id =
dynamic_id
Узел president_id выбран в качестве «президента». own_id и dynamic_id всегда должны совпадать с идентификатором (node_id) узла-отправителя.
CM_REGCONF
StartUp
3
INFO
Node node_id: CM_REGREF from Node
president_id to our Node
node_id. Cause =
cause
Узел-отправитель (с ID node_id) не смог принять узел president_id в качестве президента. Причиной проблемы является одно из значений Busy, Election with wait = false, Not president, Election
without selecting new candidate или No
such cause.
CM_REGREF
StartUp
8
INFO
Node node_id: We are Node
own_id with dynamic ID
dynamic_id, our left neighbor
is Node id_1, our right is Node
id_2
Узел обнаружил соседние узлы в кластере (узел id_1 и узел id_2). node_id, own_id и dynamic_id всегда должны быть одинаковыми; в противном случае это указывает на серьёзную неправильную настройку узлов кластера.
FIND_NEIGHBOURS
StartUp
8
INFO
Node node_id:
type shutdown
initiated
Узел получил сигнал о завершении работы. Причиной завершения работы является либо Cluster, либо Node.
NDBStopStarted
StartUp
1
INFO
Node node_id: Node shutdown
completed [,
action] [Initiated by signal
signal.]
Узел остановлен. Этот отчёт может содержать action, которое, если есть, является одним из значений restarting, no
start или initial. Отчёт также может содержать ссылку на протокол NDBsignal; для возможных сигналов см. Операции и Сигналы.
NDBStopCompleted
StartUp
1
INFO
Node node_id: Forced node shutdown
completed [,
action]. [Occurred
during startphase
start_phase.] [ Initiated by
signal.] [Caused by error
error_code:
'error_message(error_classification).
error_status'. [(extra info
extra_code)]]
Узел был принудительно остановлен. Также сообщается о последующем значении action (одно из restarting, no
start или initial), если таковое имеется. Если остановка произошла во время запуска узла, в отчёте указана start_phase, в ходе которой узел завершил работу. Если это произошло из-за signal, отправленного узлу, эта информация также предоставлена (см. Операции и Сигналы для получения дополнительной информации). Если причина сбоя известна, она также указана; для получения дополнительной информации об ошибках и классификациях сообщений об ошибках NDB см. Ошибки API NDB Cluster.
Это сообщает о глобальных контрольных точках, используемых при запуске узла. Журнал переигрывания до keep_pos удаляется. last_pos — последняя глобальная контрольная точка, в которой участвовал узел данных; restore_pos — глобальная контрольная точка, которая фактически используется для восстановления всех узлов данных.
Node node_id: Node restart completed
copy of dictionary information
Копирование информации словаря данных на перезапущенный узел завершено.
NR_CopyDict
NodeRestart
8
INFO
Node node_id: Node restart completed
copy of distribution information
Копирование информации о распределении данных на перезапущенный узел завершено.
NR_CopyDistr
NodeRestart
8
INFO
Node node_id: Node restart starting
to copy the fragments to Node
node_id
Началось копирование фрагментов в запускаемый узел данных node_id
NR_CopyFragsStarted
NodeRestart
8
INFO
Node node_id: Table ID =
table_id, fragment ID =
fragment_id have been copied to
Node node_id
Фрагмент fragment_id из таблицы table_id скопирован в узел данных node_id
NR_CopyFragDone
NodeRestart
10
INFO
Node node_id: Node restart completed
copying the fragments to Node
node_id
Копирование всех фрагментов таблиц в перезапускаемый узел данных node_id завершено
NR_CopyFragsCompleted
NodeRestart
8
INFO
Node node_id: Node
node1_id completed failure of
Node node2_id
Узел данных node1_id обнаружил сбой узла данных node2_id
NodeFailCompleted
NodeRestart
8
ALERT
All nodes completed failure of Node
node_id
Все (оставшиеся) узлы данных обнаружили сбой узла данных node_id
NodeFailCompleted
NodeRestart
8
ALERT
Node failure of
node_idblock
completed
Сбой узла данных node_id обнаружен в ядре blockNDB блоке, где блок 1 из DBTC, DBDICT, DBDIH или DBLQH; для получения дополнительной информации см. Блоки ядра NDB
NodeFailCompleted
NodeRestart
8
ALERT
Node mgm_node_id: Node
data_node_id has failed. The
Node state at failure was
state_code
Сбой узла данных. Его состояние в момент сбоя описывается кодом состояния арбитража state_code: возможные значения кодов состояния можно найти в файле include/kernel/signaldata/ArbitSignalData.hpp.
NODE_FAILREP
NodeRestart
8
ALERT
President restarts arbitration thread
[state=state_code] или Prepare arbitrator node
node_id
[ticket=ticket_id] или Receive arbitrator node
node_id
[ticket=ticket_id] или Started arbitrator node
node_id
[ticket=ticket_id] или Lost arbitrator node
node_id - process failure
[state=state_code] или Lost arbitrator node
node_id - process exit
[state=state_code] или Lost arbitrator node
node_id -
error_message
[state=state_code]
Это отчет о текущем состоянии и ходе арбитража в кластере. node_id — идентификатор узла узла управления или SQL-узла, выбранного в качестве арбитра. state_code — код состояния арбитража, как указано в include/kernel/signaldata/ArbitSignalData.hpp. При возникновении ошибки предоставляется error_message, также определённый в ArbitSignalData.hpp. ticket_id — уникальный идентификатор, выданный арбитром при его выборе всем узлам, участвовавшим в процессе выбора; это используется для обеспечения того, что каждый узел, запрашивающий арбитраж, был одним из узлов, участвовавших в процессе выбора.
ArbitState
NodeRestart
6
INFO
Arbitration check lost - less than 1/2 nodes left или Arbitration check won - all node groups and more
than 1/2 nodes left или Arbitration
check won - node group majority или Arbitration check lost - missing node
group или Network partitioning -
arbitration required или Arbitration won
- positive reply from node
node_id или Arbitration lost - negative reply from node
node_id или Network partitioning - no arbitrator
available или Network partitioning - no
arbitrator configured или Arbitration
failure - error_message
[state=state_code]
Это сообщение сообщает о результате арбитража. В случае неудачи арбитража предоставляются error_message и код состояния арбитража state_code; определения обоих находятся в include/kernel/signaldata/ArbitSignalData.hpp.
ArbitResult
NodeRestart
2
ALERT
Node node_id: GCP Take over
started
Этот узел пытается взять на себя ответственность за следующую глобальную контрольную точку (то есть, он становится узлом-мастером)
GCP_TakeoverStarted
NodeRestart
7
INFO
Node node_id: GCP Take over
completed
Этот узел стал мастером и взял на себя ответственность за следующую глобальную контрольную точку
GCP_TakeoverCompleted
NodeRestart
7
INFO
Node node_id: LCP Take over
started
Этот узел пытается взять на себя ответственность за следующий набор локальных контрольных точек (то есть, он становится узлом-мастером)
LCP_TakeoverStarted
NodeRestart
7
INFO
Node node_id: LCP Take over
completed
Этот узел стал мастером и взял на себя ответственность за следующий набор локальных контрольных точек
Этот отчет о транзакционной активности предоставляется примерно раз в 10 секунд
TransReportCounters
Statistic
8
INFO
Node node_id:
Operations=operations
Количество операций, выполненных этим узлом, предоставляется примерно раз в 10 секунд
OperationReportCounters
Statistic
8
INFO
Node node_id: Table with ID =
table_id created
Создана таблица с указанным идентификатором таблицы
TableCreated
Statistic
7
INFO
Node node_id: Mean loop Counter in
doJob last 8192 times =
count
JobStatistic
Statistic
9
INFO
Mean send size to Node = node_id
last 4096 sends = bytes
bytes
Этот узел отправляет в среднем bytes байт на отправку узлу node_id
SendBytesStatistic
Statistic
9
INFO
Mean receive size to Node = node_id
last 4096 sends = bytes
bytes
Этот узел получает в среднем bytes данных каждый раз, когда получает данные от узла node_id
ReceiveBytesStatistic
Statistic
9
INFO
Node node_id: Data usage is
data_memory_percentage%
(data_pages_used 32K pages of
total
data_pages_total) / Node node_id: Index
usage is
index_memory_percentage%
(index_pages_used 8K pages of
total index_pages_total)
Этот отчет генерируется при выполнении команды DUMP
1000 в клиенте управления кластером
MemoryUsage
Statistic
5
INFO
Node node1_id: Transporter to node
node2_id reported error
error_code:
error_message
Node node1_id: Transporter to node
node2_id reported error
error_code:
error_message
Предупреждение о возможной проблеме транспортера при общении с узлом node2_id; для получения списка кодов и сообщений об ошибках транспортера см. NDB Transporter Errors для получения дополнительной информации
Это сообщение отображается при интенсивном использовании буфера событий, например, когда много обновлений применяется за относительно короткий промежуток времени; сообщение отображает количество байтов и процент используемой памяти буфера событий, количество выделенных байтов и процент оставшейся доступной памяти, а также последние и последние восстанавливаемые эпохи.
EventBufferStatus
Info
7
INFO
(NDB 7.5.1 и более поздние версии:) Node
node_id: Event buffer status
(object_id):
used=bytes_used
(percent_used% of alloc)
alloc=bytes_allocated
max=bytes_available
latest_consumed_epoch=latest_consumed_epoch
latest_buffered_epoch=latest_buffered_epoch
report_reason=report_reason
Это сообщение отображается при интенсивном использовании буфера событий, например, когда много обновлений применяется за относительно короткий промежуток времени; сообщение отображает количество байтов и процент используемой памяти буфера событий, количество выделенных байтов и процент оставшейся доступной памяти, а также последние буферизованные и потреблённые эпохи; для получения дополнительной информации см. Раздел 21.6.2.3, «Отчёт о буфере событий в журнале кластера»
EventBufferStatus2
Info
7
INFO
Node node_id: Entering single user
mode, Node
node_id: Entered single user
mode Node API_node_id has
exclusive access, Node
node_id: Entering single user
mode
Эти сообщения записываются в журнал кластера при входе и выходе из режима одного пользователя; API_node_id — идентификатор узла API или SQL, имеющего исключительный доступ к кластеру (для получения дополнительной информации см. Раздел 21.6.6, «Режим одного пользователя кластера NDB»); сообщение Unknown single user report
API_node_id указывает на ошибку и не должно отображаться в нормальной работе
SingleUser
Info
7
INFO
Node node_id: Backup
backup_id started from node
mgm_node_id