21.3.7.1 Модернизация и понижение версии NDB 7.5
В этом разделе представлена информация о совместимости различных релизов NDB Cluster 7.5 при выполнении модернизаций и понижений версий, а также матрицы совместимости и замечания. Дополнительную информацию о понижении версии с NDB 7.5 до предыдущих серий релизов NDB можно найти здесь. Перед попыткой модернизации или понижения версии вы должны быть знакомы с установкой и настройкой NDB Cluster. Обратитесь к разделу 21.4 «Настройка NDB Cluster».
В приведенной ниже таблице представлена информация о совместимости NDB Cluster при модернизации и понижении версий между различными выпусками NDB 7.5. Дополнительные замечания о модернизациях и понижениях версий в рамках серии релизов NDB Cluster 7.5 можно найти после таблицы.
Рисунок 21.5 Совместимость при модернизации и понижении версии NDB Cluster, MySQL NDB Cluster 7.5
Поддержка версий. Следующие версии NDB Cluster поддерживаются для модернизации до релизов NDB Cluster 7.5 (7.5.4 и более поздние):
Релизы NDB Cluster 7.4 (7.4.4 и более поздние)
Релизы NDB Cluster 7.3 (7.3.2 и более поздние)
Известные проблемы при модернизации или понижении версии NDB Cluster 7.5. Следующие проблемы известны при модернизации или понижении версий NDB 7.5:
-
При выполнении с
--initializeсерверу не требуется поддержкаNDB; включениеNDBв этот момент может вызвать проблемы соndbinfoтаблицами. Чтобы этого избежать, опция--initializeтеперь заставляет mysqld игнорировать опцию--ndbcluster, если она также указана.Решение для модернизации, которая завершилась неудачей по этим причинам, выполняется следующим образом:
Выполните поэтапный перезапуск всего кластера.
Удалите все файлы
.frmв каталогеdata/ndbinfo.Запустите mysql_upgrade.
(Ошибка #81689, Ошибка #82724, Ошибка #24521927, Ошибка #23518923)
Во время онлайн-модернизации с релиза NDB Cluster 7.3 до релиза NDB 7.4 (или более позднего) сбои нескольких узлов данных, работающих с более ранней версией во время локальных контрольных точек (LCP), и непосредственно перед модернизацией этих узлов, приводили к дополнительным отказам узлов после модернизации. Это было связано с оставшимися элементами протокола
EMPTY_LCP, инициированными старыми узлами как частью последовательности LCP-плюс-перезапуск, которая больше не используется в NDB 7.4 и более поздних версиях из-за оптимизаций LCP, реализованных в этих версиях. Эта проблема была исправлена в NDB 7.5.4. (Ошибка #23129433)-
В NDB 7.5 (и более поздних версиях) таблица
ndb_binlog_indexиспользует движок храненияInnoDB. Использование движка храненияMyISAMдля этой таблицы по-прежнему поддерживается для обратной совместимости.При модернизации предыдущей версии до NDB 7.5 (или более поздней) вы можете использовать опции
--force--upgrade-system-tablesс mysql_upgrade, чтобы она выполнялаALTER TABLE ... ENGINE=INNODBнад таблицейndb_binlog_index.Дополнительную информацию см. в разделе 21.7.4 «Схема и таблицы репликации NDB Cluster».
© 2025 Oracle
Licensed under the GPLv2 License.