4.2.2.4 Модификаторы опций программы
Некоторые опции являются “булевыми” и управляют поведением, которое может быть включено или выключено. Например, клиент mysql поддерживает опцию --column-names, которая определяет, отображать ли строку имён столбцов в начале результатов запроса. По умолчанию эта опция включена. Однако вы можете отключить её в некоторых случаях, например, при передаче вывода mysql в другую программу, которая ожидает увидеть только данные, а не начальную строку заголовка.
Чтобы отключить имена столбцов, вы можете указать опцию в любой из этих форм:
--disable-column-names
--skip-column-names
--column-names=0
Префиксы --disable и --skip, а также суффикс =0 имеют одинаковый эффект: они отключают опцию.
Форму “включенная” опции можно указать любым из следующих способов:
--column-names
--enable-column-names
--column-names=1
Значения ON, TRUE, OFF и FALSE также распознаются для булевых опций (регистр не учитывается).
Если опция имеет префикс --loose, программа не завершается с ошибкой, если не распознаёт опцию, а вместо этого выводит только предупреждение:
$> mysql --loose-no-such-option
mysql: WARNING: unknown option '--loose-no-such-option'
Префикс --loose может быть полезен, когда вы запускаете программы из нескольких установок MySQL на одном компьютере и перечисляете опции в файле опций. Опцию, которая может не распознаваться всеми версиями программы, можно указать с префиксом --loose (или loose в файле опций). Версии программы, распознающие опцию, обрабатывают её нормально, а версии, которые не распознают её, выдают предупреждение и игнорируют её.
Префикс --maximum доступен только для mysqld и позволяет ограничить размер, до которого клиентские программы могут устанавливать переменные сеанса системы. Для этого используйте префикс --maximum с именем переменной. Например, --maximum-max_heap_table_size=32M предотвращает любой клиент от увеличения ограничения размера таблицы кучи более 32М.
Префикс --maximum предназначен для использования с переменными системы, имеющими значение сеанса. Если он применяется к переменной системы, имеющей только глобальное значение, возникает ошибка. Например, с --maximum-back_log=200 сервер выдает следующую ошибку:
Maximum value of 'back_log' cannot be set
© 2025 Oracle
Licensed under the GPLv2 License.