Spec-Zone.ru › MySQL 8.4

B.3.6.1 Проблемы с ALTER TABLE

Если при использовании ALTER TABLE для изменения набора символов или сортировки символьной колонки возникает ошибка дублирующего ключа, причиной является либо то, что новая сортировка колонки отображает два ключа в одно значение, либо таблица повреждена. В последнем случае вы должны запустить REPAIR TABLE для данной таблицы. REPAIR TABLE работает для таблиц MyISAM, ARCHIVE и CSV.

Если вы используете ALTER TABLE на транзакционной таблице или используете Windows, ALTER TABLE разблокирует таблицу, если вы использовали LOCK TABLE. Это делается, потому что InnoDB и эти операционные системы не могут удалить таблицу, которая используется.

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-8.4-en/alter-table-problems.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API