1.7.3.1 Ограничения PRIMARY KEY и UNIQUE Index
Обычно ошибки возникают для операторов изменения данных (таких как INSERT или UPDATE), нарушающих ограничения первичного ключа, уникального ключа или внешнего ключа. Если используется транзакционный движок хранения, такой как InnoDB, MySQL автоматически отменяет оператор. Если используется не транзакционный движок хранения, MySQL прекращает обработку оператора на строке, где произошла ошибка, и оставляет оставшиеся строки необработанными.
MySQL поддерживает ключевое слово IGNORE для INSERT, UPDATE и т.д. Если вы его используете, MySQL игнорирует нарушения первичного ключа или уникального ключа и продолжает обработку со следующей строкой. См. раздел для используемого оператора (Раздел 15.2.7, «Оператор INSERT», Раздел 15.2.17, «Оператор UPDATE» и т.д.).
Вы можете получить информацию о количестве фактически вставленных или обновлённых строк с помощью функции API C. Вы также можете использовать оператор SHOW
WARNINGS. См. , и Раздел 15.7.7.42, «Оператор SHOW WARNINGS».
InnoDB и NDB таблицы поддерживают внешние ключи. См. Раздел 1.7.3.2, «Ограничения внешнего ключа».
© 2025 Oracle
Licensed under the GPLv2 License.