Spec-Zone.ru › MySQL 8.4

25.6.2.1 NDB Кластер: Сообщения в журнале кластера

В следующей таблице перечислены наиболее распространенные сообщения журнала кластера NDB. Сведения о журнале кластера, событиях журнала и типах событий см. в разделе 25.6.3, «Отчёты об событиях, сгенерированные в NDB Кластере». Эти сообщения журнала также соответствуют типам событий журнала в API MGM; см. , для получения дополнительной информации, представляющей интерес для разработчиков API кластера.

Таблица 25.25 Распространённые сообщения журнала NDB кластера

Таблица 25.25 Распространённые сообщения журнала NDB кластера
Сообщение журнала Описание Имя события Тип события Приоритет Серьёзность
Node mgm_node_id: Node data_node_id Connected Узел данных с идентификатором узла node_id подключился к серверу управления (узел mgm_node_id). Connected Connection 8 INFO
Node mgm_node_id: Node data_node_id Disconnected Узел данных с идентификатором узла data_node_id отключился от сервера управления (узел mgm_node_id). Disconnected Connection 8 ALERT
Node data_node_id: Communication to Node api_node_id closed Узел API или SQL-узел с идентификатором узла api_node_id больше не общается с узлом данных data_node_id. CommunicationClosed Connection 8 INFO
Node data_node_id: Communication to Node api_node_id opened Узел API или SQL-узел с идентификатором узла api_node_id теперь общается с узлом данных data_node_id. CommunicationOpened Connection 8 INFO
Node mgm_node_id: Node api_node_id: API version Узел API с идентификатором узла api_node_id подключился к узлу управления mgm_node_id, используя API NDB версии version (обычно совпадает с номером версии MySQL). ConnectedApiVersion Connection 8 INFO
Node node_id: Global checkpoint gci started Запущен глобальный контрольный пункт с идентификатором gci; узел node_id является мастером, ответственным за этот глобальный контрольный пункт. GlobalCheckpointStarted Checkpoint 9 INFO
Node node_id: Global checkpoint gci completed Завершен глобальный контрольный пункт с идентификатором gci; узел node_id был мастером, ответственным за этот глобальный контрольный пункт. GlobalCheckpointCompleted Checkpoint 10 INFO
Node node_id: Local checkpoint lcp started. Keep GCI = current_gci oldest restorable GCI = old_gci Запущен локальный контрольный пункт с номером последовательности lcp на узле node_id. Последний доступный GCI имеет индекс current_gci, а самый старый GCI, с которого можно восстановить кластер, имеет индекс old_gci. LocalCheckpointStarted Checkpoint 7 INFO
Node node_id: Local checkpoint lcp completed Завершен локальный контрольный пункт с номером последовательности lcp на узле node_id. LocalCheckpointCompleted Checkpoint 8 INFO
Node node_id: Local Checkpoint stopped in CALCULATED_KEEP_GCI Узел не смог определить последний доступный GCI. LCPStoppedInCalcKeepGci Checkpoint 0 ALERT
Node node_id: Table ID = table_id, fragment ID = fragment_id has completed LCP on Node node_id maxGciStarted: started_gci maxGciCompleted: completed_gci Фрагмент таблицы был записан на диск на узле node_id. Процесс GCI имеет индекс started_gci, а последний завершенный GCI имеет индекс completed_gci. LCPFragmentCompleted Checkpoint 11 INFO
Node node_id: ACC Blocked num_1 and TUP Blocked num_2 times last second Регистрация обратного процесса заблокирована, так как буфер журнала близок к переполнению. UndoLogBlocked Checkpoint 7 INFO
Node node_id: Start initiated version Узел данных node_id, работающий под NDB версией version, начинает процесс запуска. NDBStartStarted StartUp 1 INFO
Node node_id: Started version Узел данных node_id, работающий под NDB версией version, успешно запущен. NDBStartCompleted StartUp 1 INFO
Node node_id: STTORRY received after restart finished Узел получил сигнал о завершении перезапуска кластера. STTORRYRecieved StartUp 15 INFO
Node node_id: Start phase phase completed (type) Узел завершил фазу запуска phase процесса запуска type. Список фаз запуска см. в разделе 25.6.4, "Сводка фаз запуска NDB Cluster". (type — одно из значений initial, system, node, initial node или <Unknown>.) StartPhaseCompleted StartUp 4 INFO
Node node_id: CM_REGCONF president = president_id, own Node = own_id, our dynamic id = dynamic_id Узел president_id выбран в качестве «президента». own_id и dynamic_id всегда должны совпадать с идентификатором (node_id) узла, отправляющего отчет. CM_REGCONF StartUp 3 INFO
Node node_id: CM_REGREF from Node president_id to our Node node_id. Cause = cause Узел отчета (ID node_id) не смог принять узел president_id в качестве президента. Причина проблемы — одно из значений Busy, Election with wait = false, Not president, Election without selecting new candidate или No such cause. CM_REGREF StartUp 8 INFO
Node node_id: We are Node own_id with dynamic ID dynamic_id, our left neighbor is Node id_1, our right is Node id_2 Узел обнаружил соседние узлы в кластере (узел id_1 и узел id_2). node_id, own_id и dynamic_id должны всегда совпадать; в противном случае это указывает на серьезную некорректную настройку узлов кластера. FIND_NEIGHBOURS StartUp 8 INFO
Node node_id: type shutdown initiated Узел получил сигнал на остановку. Причина остановки — либо Cluster, либо Node. NDBStopStarted StartUp 1 INFO
Node node_id: Node shutdown completed [, action] [Initiated by signal signal.] Узел был остановлен. Данный отчет может содержать action, которое, если присутствует, является одним из значений restarting, no start или initial. Отчет также может содержать ссылку на протокол NDB signal; для возможных сигналов см. Операции и сигналы. NDBStopCompleted StartUp 1 INFO
Node node_id: Forced node shutdown completed [, action]. [Occurred during startphase start_phase.] [ Initiated by signal.] [Caused by error error_code: 'error_message(error_classification). error_status'. [(extra info extra_code)]] Узел был принудительно остановлен. Также сообщается о последующем возникновении action (одно из значений restarting, no start или initial), если таковые есть. Если остановка произошла во время запуска узла, отчет включает start_phase, во время которого узел завершил работу. Если это результат сигнала signal, отправленного узлу, эта информация также предоставляется (см. Операции и сигналы для получения дополнительной информации). Если известна ошибка, вызвавшая сбой, она также указана; для получения дополнительной информации об ошибках NDB и их классификации, см. NDB Cluster API Errors. NDBStopForced StartUp 1 ALERT
Node node_id: Node shutdown aborted Процесс остановки узла был прерван пользователем. NDBStopAborted StartUp 1 INFO
Node node_id: StartLog: [GCI Keep: keep_pos LastCompleted: last_pos NewestRestorable: restore_pos] Это сообщает о глобальных контрольных точках, на которые ссылались при запуске узла. Журнал переигрывания до keep_pos удаляется. last_pos — последняя глобальная контрольная точка, в которой участвовал узел данных; restore_pos — глобальная контрольная точка, которая фактически используется для восстановления всех узлов данных. StartREDOLog StartUp 4 INFO
startup_message [Перечислены отдельно; см. ниже.] Существует ряд возможных сообщений об ошибках запуска, которые могут быть записаны в журнал в разных ситуациях. Они перечислены отдельно; см. Раздел 25.6.2.2, «Сообщения журнала кластера NDB о запуске». StartReport StartUp 4 INFO
Node node_id: Node restart completed copy of dictionary information Копирование информации словаря данных на перезапущенный узел завершено. NR_CopyDict NodeRestart 8 INFO
Node node_id: Node restart completed copy of distribution information Копирование информации о распределении данных на перезапущенный узел завершено. NR_CopyDistr NodeRestart 8 INFO
Node node_id: Node restart starting to copy the fragments to Node node_id Началась копирование фрагментов в запускаемый узел данных node_id NR_CopyFragsStarted NodeRestart 8 INFO
Node node_id: Table ID = table_id, fragment ID = fragment_id have been copied to Node node_id Фрагмент fragment_id из таблицы table_id был скопирован на узел данных node_id NR_CopyFragDone NodeRestart 10 INFO
Node node_id: Node restart completed copying the fragments to Node node_id Копирование всех фрагментов таблицы на перезапускаемый узел данных node_id завершено NR_CopyFragsCompleted NodeRestart 8 INFO
Node node_id: Node node1_id completed failure of Node node2_id Узел данных node1_id обнаружил отказ узла данных node2_id NodeFailCompleted NodeRestart 8 ALERT
All nodes completed failure of Node node_id Все (оставшиеся) узлы данных обнаружили отказ узла данных node_id NodeFailCompleted NodeRestart 8 ALERT
Node failure of node_idblock completed Отказ узла данных node_id был обнаружен в блоке ядра blockNDB ядра, где блок — 1 из DBTC, DBDICT, DBDIH или DBLQH; для получения дополнительной информации см. Блоки ядра NDB NodeFailCompleted NodeRestart 8 ALERT
Node mgm_node_id: Node data_node_id has failed. The Node state at failure was state_code Отказал узел данных. Его состояние в момент отказа описывается кодом состояния арбитража state_code: возможные значения кода состояния можно найти в файле include/kernel/signaldata/ArbitSignalData.hpp. NODE_FAILREP NodeRestart 8 ALERT
President restarts arbitration thread [state=state_code] или Prepare arbitrator node node_id [ticket=ticket_id] или Receive arbitrator node node_id [ticket=ticket_id] или Started arbitrator node node_id [ticket=ticket_id] или Lost arbitrator node node_id - process failure [state=state_code] или Lost arbitrator node node_id - process exit [state=state_code] или Lost arbitrator node node_id - error_message [state=state_code] Это отчет о текущем состоянии и прогрессе арбитража в кластере. node_id — идентификатор узла узла управления или узла SQL, выбранного в качестве арбитра. state_code — код состояния арбитража, как указано в include/kernel/signaldata/ArbitSignalData.hpp. При возникновении ошибки предоставляется error_message, также определенное в ArbitSignalData.hpp. ticket_id — уникальный идентификатор, выданный арбитром всем узлам, участвовавшим в его выборе; это используется для того, чтобы каждый запрашивающий арбитраж узел был одним из узлов, участвовавших в процессе выбора. ArbitState NodeRestart 6 INFO
Arbitration check lost - less than 1/2 nodes left или Arbitration check won - all node groups and more than 1/2 nodes left или Arbitration check won - node group majority или Arbitration check lost - missing node group или Network partitioning - arbitration required или Arbitration won - positive reply from node node_id или Arbitration lost - negative reply from node node_id или Network partitioning - no arbitrator available или Network partitioning - no arbitrator configured или Arbitration failure - error_message [state=state_code] Это сообщение сообщает о результате арбитража. В случае сбоя арбитража предоставляются error_message и арбитражный state_code; определения обоих находятся в include/kernel/signaldata/ArbitSignalData.hpp. ArbitResult NodeRestart 2 ALERT
Node node_id: GCP Take over started Этот узел пытается взять на себя ответственность за следующую глобальную контрольную точку (то есть, он становится узлом-мастером) GCP_TakeoverStarted NodeRestart 7 INFO
Node node_id: GCP Take over completed Этот узел стал мастером и взял на себя ответственность за следующую глобальную контрольную точку GCP_TakeoverCompleted NodeRestart 7 INFO
Node node_id: LCP Take over started Этот узел пытается взять на себя ответственность за следующий набор локальных контрольных точек (то есть, он становится узлом-мастером) LCP_TakeoverStarted NodeRestart 7 INFO
Node node_id: LCP Take over completed Этот узел стал мастером и взял на себя ответственность за следующий набор локальных контрольных точек LCP_TakeoverCompleted NodeRestart 7 INFO
Node node_id: Trans. Count = transactions, Commit Count = commits, Read Count = reads, Simple Read Count = simple_reads, Write Count = writes, AttrInfo Count = AttrInfo_objects, Concurrent Operations = concurrent_operations, Abort Count = aborts, Scans = scans, Range scans = range_scans Этот отчет о транзакционной активности предоставляется примерно раз в 10 секунд TransReportCounters Statistic 8 INFO
Node node_id: Operations=operations Количество операций, выполненных этим узлом, предоставляется примерно раз в 10 секунд OperationReportCounters Statistic 8 INFO
Node node_id: Table with ID = table_id created Таблица с указанным идентификатором таблицы была создана TableCreated Statistic 7 INFO
Node node_id: Mean loop Counter in doJob last 8192 times = count JobStatistic Statistic 9 INFO
Mean send size to Node = node_id last 4096 sends = bytes bytes Этот узел отправляет в среднем bytes байт на отправку узлу node_id SendBytesStatistic Statistic 9 INFO
Mean receive size to Node = node_id last 4096 sends = bytes bytes Этот узел получает в среднем bytes данных каждый раз, когда он получает данные от узла node_id ReceiveBytesStatistic Statistic 9 INFO
Node node_id: Data usage is data_memory_percentage% (data_pages_used 32K pages of total data_pages_total) / Node node_id: Index usage is index_memory_percentage% (index_pages_used 8K pages of total index_pages_total) Этот отчет генерируется при выполнении команды DUMP 1000 в клиенте управления кластером MemoryUsage Statistic 5 INFO
Node node1_id: Transporter to node node2_id reported error error_code: error_message При общении с узлом node2_id произошла ошибка транспортного средства; для просмотра списка кодов и сообщений об ошибках транспортного средства см. Ошибки NDB Transporter, в Руководстве по внутренним механизмам MySQL NDB Cluster TransporterError Error 2 ERROR
Node node1_id: Transporter to node node2_id reported error error_code: error_message Предупреждение о потенциальной проблеме транспортного средства при общении с узлом node2_id; для просмотра списка кодов и сообщений об ошибках транспортного средства см. Ошибки NDB Transporter, для получения дополнительной информации TransporterWarning Error 8 WARNING
Node node1_id: Node node2_id missed heartbeat heartbeat_id Этот узел пропустил сигнал о жизнеспособности от узла node2_id MissedHeartbeat Error 8 WARNING
Node node1_id: Node node2_id declared dead due to missed heartbeat Этот узел пропустил как минимум 3 сердечных удара от узла node2_id и поэтому объявил этот узел “мертвым” DeadDueToHeartbeat Error 8 ALERT
Node node1_id: Node Sent Heartbeat to node = node2_id Этот узел отправил сердечный удар узлу node2_id SentHeartbeat Info 12 INFO
Node node_id: Event buffer status (object_id): used=bytes_used (percent_used% of alloc) alloc=bytes_allocated max=bytes_available latest_consumed_epoch=latest_consumed_epoch latest_buffered_epoch=latest_buffered_epoch report_reason=report_reason Данный отчет отображается при интенсивном использовании буфера событий, например, когда много обновлений применяются в относительно короткий промежуток времени; отчет показывает количество байтов и процент памяти буфера событий, используемой, выделенные байты и процент оставшейся памяти, а также последние буферизованные и потребленные эпохи; для получения дополнительной информации см. Раздел 25.6.2.3, «Отчеты о буфере событий в журнале кластера» EventBufferStatus2 Info 7 INFO
Node node_id: Entering single user mode, Node node_id: Entered single user mode Node API_node_id has exclusive access, Node node_id: Entering single user mode Эти отчеты записываются в журнал кластера при входе и выходе из режима одного пользователя; API_node_id — это идентификатор узла API или SQL, имеющего эксклюзивный доступ к кластеру (для получения дополнительной информации см. Раздел 25.6.6, «Режим одного пользователя кластера NDB»); сообщение Unknown single user report API_node_id указывает на возникновение ошибки и никогда не должно отображаться в нормальной работе SingleUser Info 7 INFO
Node node_id: Backup backup_id started from node mgm_node_id Началось резервное копирование с использованием узла управления с mgm_node_id; это сообщение также отображается в клиенте управления кластером при выполнении команды START BACKUP; для получения дополнительной информации см. Раздел 25.6.8.2, «Использование клиента управления кластером NDB для создания резервной копии» BackupStarted Backup 7 INFO
Node node_id: Backup backup_id started from node mgm_node_id completed. StartGCP: start_gcp StopGCP: stop_gcp #Records: records #LogRecords: log_records Data: data_bytes bytes Log: log_bytes bytes Завершено резервное копирование с идентификатором backup_id; для получения дополнительной информации см. Раздел 25.6.8.2, «Использование клиента управления кластером NDB для создания резервной копии» BackupCompleted Backup 7 INFO
Node node_id: Backup request from mgm_node_id failed to start. Error: error_code Не удалось начать резервное копирование; см. коды ошибок BackupFailedToStart Backup 7 ALERT
Node node_id: Backup backup_id started from mgm_node_id has been aborted. Error: error_code Резервное копирование было прервано после запуска, возможно, из-за вмешательства пользователя BackupAborted Backup 7 ALERT

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-8.4-en/mysql-cluster-logs-cluster-log.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API