Spec-Zone.ru › MySQL 9.2

B.3.2.11 Невозможно создать/записать в файл

Если при выполнении некоторых запросов возникает ошибка следующего типа, это означает, что MySQL не может создать временный файл для набора результатов в временном каталоге:

Can't create/write to file '\\sqla3fe_0.ism'.

Предыдущая ошибка — типичное сообщение для Windows; сообщение для Unix аналогично.

Одним из решений является запуск mysqld с параметром --tmpdir или добавление параметра в раздел [mysqld] вашего файла конфигурации. Например, для указания каталога C:\temp используйте следующие строки:

[mysqld]
tmpdir=C:/temp

Каталог C:\temp должен существовать и иметь достаточное свободное место для записи MySQL-сервером. См. Раздел 6.2.2.2, «Использование файлов конфигурации».

Другой причиной этой ошибки могут быть проблемы с правами доступа. Убедитесь, что MySQL-сервер может записывать в каталог tmpdir.

Также проверьте код ошибки, полученный с помощью perror. Одна из причин, по которой сервер не может записать в таблицу, — это переполнение файловой системы:

$> perror 28
OS error code  28:  No space left on device

Если при запуске возникает ошибка следующего типа, это указывает на то, что файловая система или каталог, используемые для хранения файлов данных, защищены от записи. При условии, что ошибка записи относится к тестовому файлу, ошибка несерьёзна и может быть безопасно проигнорирована.

Can't create test file /usr/local/mysql/data/master.lower-test

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-8.4-en/cannot-create.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API