Spec-Zone.ru › MySQL 9.2

20.4.2 Состояния серверов группы репликации

Состояние узла группы репликации показывает его текущую роль в группе. Таблица Performance Schema replication_group_members отображает состояние каждого узла в группе. Если группа функционирует в полном объеме, и все узлы общаются должным образом, все узлы сообщают одинаковое состояние для всех других узлов. Однако узел, который покинул группу или является частью сетевого раздела, не может сообщить точную информацию об других серверах. В этой ситуации узел не пытается угадать статус других серверов и вместо этого сообщает о них как недоступных.

Узел группы может находиться в следующих состояниях:

ONLINE

Сервер является активным узлом группы и находится в полностью работоспособном состоянии. Другие узлы группы могут подключиться к нему, как и клиенты, если применимо. Узел полностью синхронизирован с группой и участвует в ней только когда он находится в состоянии ONLINE.

RECOVERING

Сервер присоединился к группе и находится в процессе становления активным узлом. В настоящее время происходит распределенное восстановление, где узел получает передачу состояния от донора, используя удаленную операцию клонирования или бинарный журнал донора. Это состояние

Для получения дополнительной информации см. Раздел 20.5.4, «Распределенное восстановление».

OFFLINE

Плагин Group Replication загружен, но узел не принадлежит ни одной группе. Это состояние может кратковременно возникать, когда узел присоединяется или повторно присоединяется к группе.

ERROR

Узел находится в состоянии ошибки и не функционирует правильно как узел группы. Узел может перейти в состояние ошибки при применении транзакций или во время фазы восстановления. Узел в этом состоянии не участвует в транзакциях группы. Для получения дополнительной информации о возможных причинах состояний ошибки см. Раздел 20.7.7, «Ответы на обнаружение сбоя и сетевое разделение».

В зависимости от установленного действия выхода group_replication_exit_state_action, узел находится в режиме только для чтения (super_read_only=ON) и также может находиться в автономном режиме (offline_mode=ON). Обратите внимание, что сервер в автономном режиме после действия выхода OFFLINE_MODE отображается со статусом ERROR, а не со статусом OFFLINE. Сервер с действием выхода ABORT_SERVER выключается и удаляется из представления группы. Для получения дополнительной информации см. Раздел 20.7.7.4, «Действие выхода».

Пока узел присоединяется или повторно присоединяется к группе репликации, его статус может отображаться как ERROR, прежде чем группа завершит проверки совместимости и примет его в качестве узла.

UNREACHABLE

Местный детектор сбоев предполагает, что с узлом невозможно связаться, так как сообщения группы отключаются по истечении срока ожидания. Это может произойти, если узел был отключён насильно, например. Если вы видите этот статус для других серверов, это также может означать, что узел, на котором вы запрашиваете эту таблицу, является частью раздела, где подмножество серверов группы могут связываться друг с другом, но не могут связываться с другими серверами в группе. Для получения дополнительной информации см. Раздел 20.7.8, «Обработка сетевого раздела и потери кворума».

См. Раздел 20.4.3, «Таблица replication_group_members» для примера содержимого таблицы Performance Schema.

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-9.2-en/group-replication-server-states.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API