7.9.1.2 Создание файлов трассировки
Если сервер mysqld не запускается или часто завершается аварийно, можно попробовать создать файл трассировки, чтобы найти проблему.
Для этого необходимо, чтобы mysqld был скомпилирован с поддержкой отладки. Проверить это можно, выполнив mysqld -V. Если номер версии заканчивается на -debug, он скомпилирован с поддержкой файлов трассировки. (В Windows сервер отладки называется mysqld-debug, а не mysqld.)
Запустите сервер mysqld с логом трассировки в /tmp/mysqld.trace в Unix или в \mysqld.trace в Windows:
$> mysqld --debug
В Windows также следует использовать флаг --standalone, чтобы не запускать mysqld как службу. В консольном окне используйте следующую команду:
C:\> mysqld-debug --debug --standalone
После этого можно использовать инструмент командной строки mysql.exe в другом консольном окне, чтобы воспроизвести проблему. Можно остановить сервер mysqld с помощью команды mysqladmin shutdown.
Файл трассировки может стать очень большим! Чтобы сгенерировать более компактный файл трассировки, можно использовать параметры отладки, например:
mysqld --debug=d,info,error,query,general,where:O,/tmp/mysqld.trace
Это выводит в файл трассировки только информацию с наиболее интересными метками.
Если вы подаёте ошибку, пожалуйста, добавьте в отчёт об ошибке только те строки из файла трассировки, которые указывают на то, где, по-видимому, что-то идёт не так. Если вы не можете найти ошибку, откройте отчёт об ошибке и загрузите весь файл трассировки в отчёт, чтобы разработчик MySQL мог его изучить. Инструкции см. в разделе 1.6 «Как сообщать об ошибках или проблемах».
Файл трассировки создан с помощью пакета DBUG от Фреда Фиша. См. раздел 7.9.4 «Пакет DBUG».
© 2025 Oracle
Licensed under the GPLv2 License.