Spec-Zone.ru › MySQL 9.2

6.2.2.4 Модификаторы параметров программы

Некоторые параметры являются “булевыми” и управляют поведением, которое может быть включено или выключено. Например, клиент mysql поддерживает параметр --column-names, который определяет, отображать ли строку имён столбцов в начале результатов запроса. По умолчанию этот параметр включен. Однако, вы можете отключить его в некоторых случаях, например, когда вы отправляете вывод mysql в другую программу, которая ожидает увидеть только данные, а не начальную строку заголовков.

Для отключения имён столбцов вы можете указать параметр в любой из этих форм:

--disable-column-names
--skip-column-names
--column-names=0

Префиксы --disable и --skip и суффикс =0 все имеют одинаковый эффект: они отключают параметр.

Включённая форма параметра может быть указана любым из этих способов:

--column-names
--enable-column-names
--column-names=1

Значения ON, TRUE, OFF и FALSE также распознаются для булевых параметров (регистр не учитывается).

Если параметр начинается с --loose, программа не завершается с ошибкой, если она не распознаёт параметр, а вместо этого выводит только предупреждение:

$> mysql --loose-no-such-option
mysql: WARNING: unknown option '--loose-no-such-option'

Префикс --loose может быть полезен, когда вы запускаете программы из нескольких установок MySQL на одном компьютере и перечисляете параметры в файле параметров. Параметр, который может не распознаваться всеми версиями программы, может быть задан с использованием префикса --loose (или loose в файле параметров). Версии программы, которые распознают параметр, обрабатывают его обычно, а версии, которые его не распознают, выдают предупреждение и игнорируют его.

Префикс --maximum доступен только для mysqld и позволяет ограничить размер, до которого клиентские программы могут устанавливать системные переменные сессии. Для этого используйте префикс --maximum с именем переменной. Например, --maximum-max_heap_table_size=32M предотвращает любые клиенты от увеличения предела размера таблицы кучи больше 32 МБ.

Префикс --maximum предназначен для использования с системными переменными, которые имеют значение сессии. Если он применяется к системной переменной, которая имеет только глобальное значение, возникает ошибка. Например, с --maximum-back_log=200 сервер выводит эту ошибку:

Maximum value of 'back_log' cannot be set

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-8.4-en/option-modifiers.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API