Регистрация в syslog
Директивы error_log и access_log поддерживают регистрацию в syslog. Следующие параметры конфигурируют регистрацию в syslog:
-
server=address - Определяет адрес сервера syslog. Адрес может быть указан как доменное имя или IP-адрес с необязательным портом или как путь к сокету UNIX-домена, указанный после префикса “
unix:”. Если порт не указан, используется UDP-порт 514. Если доменное имя разрешается в несколько IP-адресов, используется первый разрешенный адрес. -
facility=string - Устанавливает тип сообщения syslog, как определено в RFC 3164. Тип может быть одним из “
kern”, “user”, “mail”, “daemon”, “auth”, “intern”, “lpr”, “news”, “uucp”, “clock”, “authpriv”, “ftp”, “ntp”, “audit”, “alert”, “cron”, “local0”..“local7”. По умолчанию “local7”. -
severity=string - Устанавливает уровень серьезности сообщений syslog для access_log, как определено в RFC 3164. Возможные значения такие же, как для второго параметра (уровень) директивы error_log. По умолчанию “
info”.Уровень серьезности сообщений об ошибках определяется nginx, поэтому параметр игнорируется в директиве
error_log. -
tag=string - Устанавливает метку сообщений syslog. По умолчанию “
nginx”. nohostname- Отключает добавление поля “hostname” в заголовок сообщения syslog (1.9.7).
Пример конфигурации syslog:
error_log syslog:server=192.168.1.1 debug; access_log syslog:server=unix:/var/log/nginx.sock,nohostname; access_log syslog:server=[2001:db8::1]:12345,facility=local7,tag=nginx,severity=info combined;
Регистрация в syslog доступна начиная с версии 1.7.1. В рамках нашей коммерческой подписки регистрация в syslog доступна начиная с версии 1.5.3.
© 2002-2021 Igor Sysoev
© 2011-2024 Nginx, Inc.
Licensed under the BSD License.
https://nginx.org/en/docs/syslog.html