Spec-Zone.ru › OpenJDK 25

Пакет javax.security.auth.x500

package javax.security.auth.x500
Этот пакет содержит классы, которые следует использовать для хранения X500 Principal и X500 Private Credentials в объекте Subject.

Спецификация пакета

  • RFC 1779: Строковое представление отличительных имен
  • RFC 2253: Протокол облегчённого доступа к каталогам (версия 3): UTF-8-представление отличительных имен
  • RFC 5280: Профиль сертификатов инфраструктуры открытых ключей Internet X.509 и списков отзыва сертификатов (CRL)
  • RFC 4512: Протокол облегчённого доступа к каталогам (LDAP): модели данных каталога
С версии:
1.4
Внешние спецификации
  • RFC 1779: Строковое представление отличительных имен
  • RFC 2253: Протокол облегчённого доступа к каталогам (версия 3): UTF-8-представление отличительных имен
  • RFC 4512: Протокол облегчённого доступа к каталогам (LDAP): модели данных каталога
  • RFC 5280: Профиль сертификатов инфраструктуры открытых ключей Internet X.509 и списков отзыва сертификатов (CRL)
java.base
java.base
java.security.jgss
java.base
java.base
Модуль Пакет Описание
javax.security.auth
Этот пакет предоставляет инфраструктуру для аутентификации и авторизации.
javax.security.auth.callback
Этот пакет предоставляет классы, необходимые службам для взаимодействия с приложениями с целью получения информации (например, данных аутентификации, включая имена пользователей или пароли) или отображения информации (например, сообщений об ошибках и предупреждений).
javax.security.auth.kerberos
Этот пакет содержит вспомогательные классы, связанные с сетевым протоколом аутентификации Kerberos.
javax.security.auth.login
Этот пакет предоставляет подключаемую инфраструктуру аутентификации.
javax.security.auth.spi
Этот пакет предоставляет интерфейс для реализации подключаемых модулей аутентификации.
Класс Описание
X500Principal
Этот класс представляет собой принципала X.500 Principal.
X500PrivateCredential
Этот класс представляет собой X500PrivateCredential.

Сообщить об ошибке или предложить улучшение
Дополнительные справочные материалы по API и документацию для разработчиков см. в разделе Документация Java SE, где представлены более подробные описания для разработчиков, обзоры концепций, определения терминов, обходные решения и рабочие примеры кода. Другие версии.
Java является товарным знаком или зарегистрированным товарным знаком Oracle и/или её аффилированных лиц в США и других странах.
Авторское право © 1993, 2025, Oracle и/или её аффилированные лица, 500 Oracle Parkway, Redwood Shores, CA 94065 USA.
Все права защищены. Использование регулируется условиями лицензии и политикой распространения документации.

© 1993, 2025, Oracle and/or its affiliates. All rights reserved.
Documentation extracted from Debian's OpenJDK Development Kit package.
Licensed under the GNU General Public License, version 2, with the Classpath Exception.
Various third party code in OpenJDK is licensed under different licenses (see Debian package).
Java and OpenJDK are trademarks or registered trademarks of Oracle and/or its affiliates.
https://docs.oracle.com/en/java/javase/25/docs/api/java.base/javax/security/auth/x500/package-summary.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API