Spec-Zone.ru › OpenJDK 25

Пакет javax.security.sasl

package javax.security.sasl
Содержит классы и интерфейсы для поддержки SASL. Этот пакет определяет классы и интерфейсы для механизмов SASL. Он используется разработчиками для добавления поддержки аутентификации в протоколы, основанные на соединениях и использующие SASL.

Обзор SASL

Simple Authentication and Security Layer (SASL) определяет протокол «запрос — ответ», в рамках которого клиент и сервер обмениваются данными для аутентификации и (при необходимости) установления уровня безопасности, предназначенного для последующего обмена данными. Он используется с протоколами, основанными на соединениях, такими как LDAPv3 или IMAPv4. Описание SASL приведено в RFC 2222. Для SASL определены различные механизмы. Каждый механизм определяет данные, которыми клиент и сервер должны обменяться для успешной аутентификации. Обмен данными, необходимый для конкретного механизма, называется его профилем протокола. Ниже приведены примеры механизмов, определённых сообществом по стандартизации Интернета.
  • DIGEST-MD5 (RFC 2831). Этот механизм определяет, как аутентификация HTTP Digest может использоваться в качестве механизма SASL.
  • Anonymous (RFC 2245). Этот механизм обеспечивает анонимную аутентификацию, для которой не требуются учётные данные.
  • External (RFC 2222). Этот механизм получает сведения для аутентификации из внешнего источника (например, TLS или IPsec).
  • S/Key (RFC 2222). Этот механизм использует алгоритм хеширования MD4 для обмена данными на основе общего секрета.
  • GSSAPI (RFC 2222). Этот механизм использует GSSAPI для получения сведений об аутентификации.
Некоторые из этих механизмов обеспечивают и аутентификацию, и установление уровня безопасности, другие — только аутентификацию. Anonymous и S/Key не обеспечивают уровни безопасности. GSSAPI и DIGEST-MD5 позволяют согласовывать уровень безопасности. Для External уровень безопасности определяется внешним протоколом.

Использование

Пользователями этого API обычно являются разработчики, создающие реализации клиентских библиотек для протоколов, основанных на соединениях, таких как LDAPv3 и IMAPv4, а также разработчики серверов (например, серверов LDAP и IMAP). Разработчики клиентских библиотек используют интерфейсы SaslClient и SaslClientFactory. Разработчики серверов используют интерфейсы SaslServer и SaslServerFactory. Каждую из этих двух групп пользователей можно дополнительно разделить на две подгруппы: тех, кто создаёт механизмы SASL, и тех, кто их использует. Разработчики механизмов SASL должны предоставлять реализации этих интерфейсов, а пользователи механизмов SASL используют API этого пакета для доступа к этим реализациям.

Связанная документация

Сведения об использовании этого API приведены в руководстве по программированию Java SASL.
С момента:
1.5
Класс Описание
AuthenticationException
Это исключение выбрасывается реализацией механизма SASL, чтобы указать на сбой обмена SASL по причинам, связанным с аутентификацией, например из-за недопустимого идентификатора, парольной фразы или ключа.
AuthorizeCallback
Этот обратный вызов используется интерфейсом SaslServer для определения того, может ли одна сущность (идентифицированная аутентифицированным идентификатором аутентификации) действовать от имени другой сущности (идентифицированной идентификатором авторизации).
RealmCallback
Этот обратный вызов используется интерфейсами SaslClient и SaslServer для получения сведений о домене.
RealmChoiceCallback
Этот обратный вызов используется интерфейсами SaslClient и SaslServer для выбора домена из списка доступных вариантов.
Sasl
Статический класс для создания клиентов и серверов SASL.
SaslClient
Выполняет аутентификацию SASL в качестве клиента.
SaslClientFactory
Интерфейс для создания экземпляров SaslClient.
SaslException
Этот класс представляет ошибку, возникшую при использовании SASL.
SaslServer
Выполняет аутентификацию SASL в качестве сервера.
SaslServerFactory
Интерфейс для создания экземпляров SaslServer.

Сообщить об ошибке или предложить улучшение
Дополнительные справочные материалы по API и документацию для разработчиков см. в разделе документации Java SE, где содержатся более подробные описания для разработчиков, обзоры концепций, определения терминов, обходные решения и рабочие примеры кода. Другие версии.
Java является товарным знаком или зарегистрированным товарным знаком Oracle и/или её аффилированных лиц в США и других странах.
Авторские права © 1993, 2025, Oracle и/или её аффилированные лица, 500 Oracle Parkway, Redwood Shores, CA 94065 USA.
Все права защищены. Использование регулируется условиями лицензии и политикой распространения документации.

© 1993, 2025, Oracle and/or its affiliates. All rights reserved.
Documentation extracted from Debian's OpenJDK Development Kit package.
Licensed under the GNU General Public License, version 2, with the Classpath Exception.
Various third party code in OpenJDK is licensed under different licenses (see Debian package).
Java and OpenJDK are trademarks or registered trademarks of Oracle and/or its affiliates.
https://docs.oracle.com/en/java/javase/25/docs/api/java.security.sasl/javax/security/sasl/package-summary.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API