Spec-Zone.ru › OpenJDK 27

Пакет java.net.http

package java.net.http

API HTTP-клиента и WebSocket

Предоставляет высокоуровневые клиентские интерфейсы для HTTP (версий 1.1, 2 и 3) и низкоуровневые клиентские интерфейсы для WebSocket. Основные определённые типы:

  • HttpClient
  • HttpRequest
  • HttpResponse
  • WebSocket

Требования, специфичные для протоколов, определены в спецификациях Протокол передачи гипертекста версии 3 (HTTP/3), Протокол передачи гипертекста версии 2 (HTTP/2), Протокол передачи гипертекста (HTTP/1.1) и Протокол WebSocket.

Как правило, асинхронные задачи выполняются либо в потоке, вызывающем операцию, например отправку HTTP-запроса, либо в потоках, предоставленных executor клиента. Зависимые задачи, запускаемые возвращёнными CompletionStage или CompletableFuture, которые явно не указывают исполнитель, выполняются в том же default executor, что и CompletableFuture, либо в вызывающем потоке, если операция завершается до регистрации зависимой задачи.

Объекты CompletableFuture, возвращаемые этим API, при вызове методов obtrudeValue и obtrudeException выбрасывают исключение UnsupportedOperationException. Если не указано иное, вызов метода cancel для CompletableFuture, возвращённого этим API, может не прервать выполняющуюся операцию, но может быть полезен для завершения с исключением зависимых этапов, которые ещё не завершились.

Если не указано иное, значения параметров null приводят к тому, что методы всех классов этого пакета выбрасывают NullPointerException.

Версия:
11
Внешние спецификации
  • RFC 9114: HTTP/3
  • RFC 7540: Протокол передачи гипертекста версии 2 (HTTP/2)
  • RFC 2616: Протокол передачи гипертекста -- HTTP/1.1
  • RFC 6455: Протокол WebSocket
См. также:
  • java.net.http
java.base
java.base
Модуль Пакет Описание
java.net
Предоставляет классы для разработки сетевых приложений.
java.net.spi
Классы поставщиков служб для пакета java.net.
Класс Описание
HttpClient
HTTP-клиент.
HttpClient.Builder
Построитель HTTP-клиентов.
HttpClient.Redirect
Определяет политику автоматической переадресации.
HttpClient.Version
Версия протокола HTTP.
HttpConnectTimeoutException
Выбрасывается, если соединение, по которому предполагается отправить HttpRequest, не удалось установить в течение указанного периода времени.
HttpHeaders
Представление набора заголовков HTTP только для чтения.
HttpOption<T>
Этот интерфейс используется для передачи дополнительных подсказок о параметрах конфигурации запроса, определяющих способ выполнения обмена HTTP-запросом и ответом реализацией HttpClient.
HttpOption.Http3DiscoveryMode
Это перечисление помогает HttpClient определить способ установки соединения для обмена данными по HTTP/3. Его можно передать в качестве значения параметра HttpOption.H3_DISCOVERY методу Builder.setOption.
HttpRequest
HTTP-запрос.
HttpRequest.BodyPublisher
BodyPublisher преобразует высокоуровневые объекты Java в последовательность буферов байтов, пригодную для отправки в качестве тела запроса.
HttpRequest.BodyPublishers
Реализации BodyPublisher, предоставляющие различные полезные издатели, например для отправки тела запроса из строки или файла.
HttpRequest.Builder
Построитель HTTP-запросов.
HttpResponse<T>
HTTP-ответ.
HttpResponse.BodyHandler<T>
Обработчик тела ответа.
HttpResponse.BodyHandlers
Реализации BodyHandler, предоставляющие различные полезные обработчики, например для обработки тела ответа как строки или потоковой записи тела ответа в файл.
HttpResponse.BodySubscriber<T>
BodySubscriber получает байты тела ответа и преобразует их в тип Java более высокого уровня.
HttpResponse.BodySubscribers
Реализации BodySubscriber, предоставляющие различные полезные подписчики, например для преобразования байтов тела ответа в строку или потоковой записи байтов в файл.
HttpResponse.PushPromiseHandler<T>
Обработчик обещаний push.
HttpResponse.PushPromiseHandler.PushId
Представляет PushID HTTP/3.
HttpResponse.PushPromiseHandler.PushId.Http3PushId
Представляет PushId HTTP/3.
HttpResponse.ResponseInfo
Начальная информация об ответе, передаваемая обработчику BodyHandler при получении ответа, до обработки его тела.
HttpTimeoutException
Выбрасывается, если ответ не получен в течение указанного периода времени.
StreamLimitException
Исключение, возникающее при достижении ограничения на создание потоков в HTTP-соединении, когда клиент не может создать новый поток.
UnsupportedProtocolVersionException
Выбрасывается, если HTTP-клиент не поддерживает определённую версию HTTP.
WebSocket
Клиент WebSocket.
WebSocket.Builder
Построитель клиентов WebSocket.
WebSocket.Listener
Интерфейс для получения данных от WebSocket.
WebSocketHandshakeException
Выбрасывается, если начальное рукопожатие завершилось неудачей.

Сообщить об ошибке или предложить улучшение
Дополнительную справочную информацию по API и документацию для разработчиков см. в разделе Документация Java SE, содержащем более подробные описания для разработчиков, обзоры концепций, определения терминов, обходные решения и примеры работающего кода. Другие версии.
Java является товарным знаком или зарегистрированным товарным знаком Oracle и/или её дочерних компаний в США и других странах.
Авторские права © 1993, 2026, Oracle и/или её дочерние компании, 500 Oracle Parkway, Redwood Shores, CA 94065 USA.
Все права защищены. Использование регулируется условиями лицензии и политикой распространения документации.

© 1993, 2025, Oracle and/or its affiliates. All rights reserved.
Documentation extracted from Debian's OpenJDK Development Kit package.
Licensed under the GNU General Public License, version 2, with the Classpath Exception.
Various third party code in OpenJDK is licensed under different licenses (see Debian package).
Java and OpenJDK are trademarks or registered trademarks of Oracle and/or its affiliates.

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API