http — модули HTTP
Исходный код: Lib/http/__init__.py
http — пакет, объединяющий несколько модулей для работы с протоколом передачи гипертекста:
-
http.client— низкоуровневый клиент протокола HTTP; для открытия URL на высоком уровне используйтеurllib.request -
http.serverсодержит базовые классы HTTP-сервера на основеsocketserver -
http.cookiesсодержит утилиты для реализации управления состоянием с помощью файлов cookie -
http.cookiejarобеспечивает хранение файлов cookie
Модуль http также определяет следующие перечисления, помогающие работать с кодом, связанным с HTTP:
-
class http.HTTPStatus -
Добавлено в версии 3.5.
Подкласс
enum.IntEnum, определяющий набор кодов состояния HTTP, фраз с пояснениями и подробных описаний на английском языке.Использование:
>>> from http import HTTPStatus >>> HTTPStatus.OK HTTPStatus.OK >>> HTTPStatus.OK == 200 True >>> HTTPStatus.OK.value 200 >>> HTTPStatus.OK.phrase 'OK' >>> HTTPStatus.OK.description 'Request fulfilled, document follows' >>> list(HTTPStatus) [HTTPStatus.CONTINUE, HTTPStatus.SWITCHING_PROTOCOLS, ...]
Коды состояния HTTP
Поддерживаемые коды состояния, зарегистрированные в IANA и доступные в http.HTTPStatus:
Код | Имя элемента перечисления | Подробности |
|---|---|---|
|
| HTTP/1.1 RFC 7231, раздел 6.2.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.2.2 |
|
| WebDAV RFC 2518, раздел 10.1 |
|
| Код состояния HTTP для указания подсказок RFC 8297 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.3 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.4 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.5 |
|
| HTTP/1.1 RFC 7231, раздел 6.3.6 |
|
| HTTP/1.1 RFC 7233, раздел 4.1 |
|
| WebDAV RFC 4918, раздел 11.1 |
|
| Расширения привязки WebDAV RFC 5842, раздел 7.1 (экспериментальный) |
|
| Дельта-кодирование в HTTP RFC 3229, раздел 10.4.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.3 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.4 |
|
| HTTP/1.1 RFC 7232, раздел 4.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.5 |
|
| HTTP/1.1 RFC 7231, раздел 6.4.7 |
|
| Постоянное перенаправление RFC 7238, раздел 3 (экспериментальный) |
|
| HTTP/1.1 RFC 7231, раздел 6.5.1 |
|
| Аутентификация HTTP/1.1 RFC 7235, раздел 3.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.3 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.4 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.5 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.6 |
|
| Аутентификация HTTP/1.1 RFC 7235, раздел 3.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.7 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.8 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.9 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.10 |
|
| HTTP/1.1 RFC 7232, раздел 4.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.11 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.12 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.13 |
|
| Запросы диапазонов HTTP/1.1 RFC 7233, раздел 4.4 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.14 |
|
| HTCPCP/1.0 RFC 2324, раздел 2.3.2 |
|
| HTTP/2 RFC 7540, раздел 9.1.2 |
|
| WebDAV RFC 4918, раздел 11.2 |
|
| WebDAV RFC 4918, раздел 11.3 |
|
| WebDAV RFC 4918, раздел 11.4 |
|
| Использование ранних данных в HTTP RFC 8470 |
|
| HTTP/1.1 RFC 7231, раздел 6.5.15 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Код состояния HTTP для сообщения о юридических препятствиях RFC 7725 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.1 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.2 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.3 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.4 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.5 |
|
| HTTP/1.1 RFC 7231, раздел 6.6.6 |
|
| Прозрачное согласование содержимого в HTTP RFC 2295, раздел 8.1 (экспериментальный) |
|
| WebDAV RFC 4918, раздел 11.5 |
|
| Расширения привязки WebDAV RFC 5842, раздел 7.2 (экспериментальный) |
|
| Платформа расширений HTTP RFC 2774, раздел 7 (экспериментальный) |
|
| Дополнительные коды состояния HTTP RFC 6585, раздел 6 |
Для обеспечения обратной совместимости значения перечисления также представлены в модуле http.client в виде констант. Имя элемента перечисления совпадает с именем константы (то есть http.HTTPStatus.OK также доступно как http.client.OK).
Изменено в версии 3.7: Добавлен код состояния 421 MISDIRECTED_REQUEST.
Добавлено в версии 3.8: Добавлен код состояния 451 UNAVAILABLE_FOR_LEGAL_REASONS.
Добавлено в версии 3.9: Добавлены коды состояния 103 EARLY_HINTS, 418 IM_A_TEAPOT и 425 TOO_EARLY.
Категории кодов состояния HTTP
Добавлено в версии 3.12.
Элементы перечисления имеют несколько свойств, указывающих категорию кода состояния HTTP:
Свойство | Указывает, что | Подробности |
|---|---|---|
|
| HTTP/1.1 RFC 7231, раздел 6 |
|
| HTTP/1.1 RFC 7231, раздел 6 |
|
| HTTP/1.1 RFC 7231, раздел 6 |
|
| HTTP/1.1 RFC 7231, раздел 6 |
|
| HTTP/1.1 RFC 7231, раздел 6 |
Использование:
>>> from http import HTTPStatus >>> HTTPStatus.OK.is_success True >>> HTTPStatus.OK.is_client_error False
-
class http.HTTPMethod -
Добавлено в версии 3.11.
Подкласс
enum.StrEnum, определяющий набор методов HTTP и описаний на английском языке.Использование:
>>> from http import HTTPMethod >>> >>> HTTPMethod.GET <HTTPMethod.GET> >>> HTTPMethod.GET == 'GET' True >>> HTTPMethod.GET.value 'GET' >>> HTTPMethod.GET.description 'Retrieve the target.' >>> list(HTTPMethod) [<HTTPMethod.CONNECT>, <HTTPMethod.DELETE>, <HTTPMethod.GET>, <HTTPMethod.HEAD>, <HTTPMethod.OPTIONS>, <HTTPMethod.PATCH>, <HTTPMethod.POST>, <HTTPMethod.PUT>, <HTTPMethod.TRACE>]
Методы HTTP
Поддерживаемые методы, зарегистрированные в IANA и доступные в http.HTTPMethod:
Метод | Имя элемента перечисления | Подробности |
|---|---|---|
|
| HTTP/1.1 RFC 7231, раздел 4.3.1 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.2 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.3 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.4 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.5 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.6 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.7 |
|
| HTTP/1.1 RFC 7231, раздел 4.3.8 |
|
| HTTP/1.1 RFC 5789 |
© 2001–2024 Python Software Foundation
Licensed under the PSF License.
https://docs.python.org/3.12/library/http.html