http — Модули HTTP
Исходный код: Lib/http/__init__.py
http — пакет, который собирает несколько модулей для работы с протоколом HyperText Transfer Protocol:
-
http.client— низкоуровневый клиент протокола HTTP; для открытия URL высокого уровня используйтеurllib.request -
http.serverсодержит базовые классы сервера HTTP, основанные наsocketserver -
http.cookiesсодержит утилиты для реализации управления состоянием с помощью файлов cookie -
http.cookiejarобеспечивает сохранение файлов cookie
http также является модулем, который определяет ряд кодов состояния HTTP и соответствующих сообщений через перечисление http.HTTPStatus:
-
class http.HTTPStatus -
Введено в версии 3.5.
Подкласс
enum.IntEnum, который определяет набор кодов состояния HTTP, фраз причины и длинных описаний, написанных на английском языке.Использование:
>>> from http import HTTPStatus >>> HTTPStatus.OK <HTTPStatus.OK: 200> >>> HTTPStatus.OK == 200 True >>> http.HTTPStatus.OK.value 200 >>> HTTPStatus.OK.phrase 'OK' >>> HTTPStatus.OK.description 'Request fulfilled, document follows' >>> list(HTTPStatus) [<HTTPStatus.CONTINUE: 100>, <HTTPStatus.SWITCHING_PROTOCOLS: 101>, ...]
21.11.1. Коды состояния HTTP
Поддерживаемые, зарегистрированные IANA коды состояния, доступные в http.HTTPStatus, это:
Код | Имя перечисления | Детали |
|---|---|---|
|
| HTTP/1.1 RFC 7231, Раздел 6.2.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.2.2 |
|
| WebDAV RFC 2518, Раздел 10.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.3 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.4 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.5 |
|
| HTTP/1.1 RFC 7231, Раздел 6.3.6 |
|
| HTTP/1.1 RFC 7233, Раздел 4.1 |
|
| WebDAV RFC 4918, Раздел 11.1 |
|
| Расширения привязки WebDAV RFC 5842, Раздел 7.1 (Экспериментальный) |
|
| Кодирование дельт в HTTP RFC 3229, Раздел 10.4.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.3 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.4 |
|
| HTTP/1.1 RFC 7232, Раздел 4.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.5 |
|
| HTTP/1.1 RFC 7231, Раздел 6.4.7 |
|
| Постоянное перенаправление RFC 7238, Раздел 3 (Экспериментальный) |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.1 |
|
| Аутентификация HTTP/1.1 RFC 7235, Раздел 3.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.3 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.4 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.5 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.6 |
|
| Аутентификация HTTP/1.1 RFC 7235, Раздел 3.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.7 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.8 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.9 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.10 |
|
| HTTP/1.1 RFC 7232, Раздел 4.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.11 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.12 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.13 |
|
| HTTP/1.1 Запросы с диапазоном RFC 7233, Раздел 4.4 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.14 |
|
| WebDAV RFC 4918, Раздел 11.2 |
|
| WebDAV RFC 4918, Раздел 11.3 |
|
| WebDAV RFC 4918, Раздел 11.4 |
|
| HTTP/1.1 RFC 7231, Раздел 6.5.15 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.1 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.2 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.3 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.4 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.5 |
|
| HTTP/1.1 RFC 7231, Раздел 6.6.6 |
|
| Прозрачное согласование содержимого в HTTP RFC 2295, Раздел 8.1 (Экспериментальный) |
|
| WebDAV RFC 4918, Раздел 11.5 |
|
| Расширения привязки WebDAV RFC 5842, Раздел 7.2 (Экспериментальный) |
|
| Фреймворк расширений HTTP RFC 2774, Раздел 7 (Экспериментальный) |
|
| Дополнительные коды состояния HTTP RFC 6585, Раздел 6 |
Для сохранения обратной совместимости значения перечислений также присутствуют в модуле http.client в виде констант. Название перечисления совпадает с именем константы (т.е. http.HTTPStatus.OK также доступно как http.client.OK).
© 2001–2020 Python Software Foundation
Licensed under the PSF License.
https://docs.python.org/3.6/library/http.html